blurry tiles

Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

blurry tiles

Toni Hernandez Valles
Helo everyone,

I am using a vector tile from mapbox and I am getting bluring tiles
with no apparent reason. Not for me, at least

I have checked tiles directly to mapbox and the quality is perfect,
but, when using tiles with OpenLayers the map quality gets lower.

In this link (https://mapscloud.udg.edu/blurry_tiles.png) you can see
the quality of the map image (on the left) and the quality of a single
tile. Check the costline and the name "Roses" to see the difference.


I have tried both tile sizes (256 and 512) with the same result.

This is the code for the layer for size 256.

var mapbox =  new TileLayer({
    source: new SourceXYZ({
      url: '
https://api.mapbox.com/styles/v1/mapesbasesigte/ck9olcn8017xc1it6mhv6myje/tiles/256/{z}/{x}/{y}?access_token=mytoken'
,
    })
  })

And the code for the map.

map = new Map({
  layers: [ mapbox ],
  target: 'map',
  view: new View({
    center: [0, 0],
    zoom: 2,
    projection: 'EPSG:3857',
  }),
  controls: defaultControls({attribution:
false}).extend([attribution]),
});

Am I doing something wrong?

Thanks you!!!
_______________________________________________
Users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: blurry tiles

Andreas Hocevar
By default, OpenLayers applies up- and downscaling to the tiles. To avoid upscaling, configure the source with

    zDirection: -1

Andreas.

On Mon, May 4, 2020 at 8:47 PM Toni Hernandez Valles <[hidden email]> wrote:
Helo everyone,

I am using a vector tile from mapbox and I am getting bluring tiles
with no apparent reason. Not for me, at least

I have checked tiles directly to mapbox and the quality is perfect,
but, when using tiles with OpenLayers the map quality gets lower.

In this link (https://mapscloud.udg.edu/blurry_tiles.png) you can see
the quality of the map image (on the left) and the quality of a single
tile. Check the costline and the name "Roses" to see the difference.


I have tried both tile sizes (256 and 512) with the same result.

This is the code for the layer for size 256.

var mapbox =  new TileLayer({
    source: new SourceXYZ({
      url: '
https://api.mapbox.com/styles/v1/mapesbasesigte/ck9olcn8017xc1it6mhv6myje/tiles/256/{z}/{x}/{y}?access_token=mytoken'
,
    })
  })

And the code for the map.

map = new Map({
  layers: [ mapbox ],
  target: 'map',
  view: new View({
    center: [0, 0],
    zoom: 2,
    projection: 'EPSG:3857',
  }),
  controls: defaultControls({attribution:
false}).extend([attribution]),
});

Am I doing something wrong?

Thanks you!!!
_______________________________________________
Users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/openlayers-users

_______________________________________________
Users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: blurry tiles

Toni Hernandez Valles
Hello,

Me too. I added the zDirection:-1 to the layer source, and the issue
still persists. :-(




On Mon, 2020-05-04 at 15:48 -0600, Richard Greenwood wrote:

> I'm seeing something similar with Mapbox satellite tiles. I
> added zDirection: -1 to my source definition but it didn't have any
> effect.
>
> resolution 0.6237836388319881
>
> resolution 0.5518893502310329
>
>
> On Mon, May 4, 2020 at 2:14 PM Andreas Hocevar <
> [hidden email]> wrote:
> > By default, OpenLayers applies up- and downscaling to the tiles. To
> > avoid upscaling, configure the source with
> >
> >     zDirection: -1
> >
> > Andreas.
> >
> > On Mon, May 4, 2020 at 8:47 PM Toni Hernandez Valles <
> > [hidden email]> wrote:
> > > Helo everyone,
> > >
> > > I am using a vector tile from mapbox and I am getting bluring
> > > tiles
> > > with no apparent reason. Not for me, at least
> > >
> > > I have checked tiles directly to mapbox and the quality is
> > > perfect,
> > > but, when using tiles with OpenLayers the map quality gets lower.
> > >
> > > In this link (https://mapscloud.udg.edu/blurry_tiles.png) you can
> > > see
> > > the quality of the map image (on the left) and the quality of a
> > > single
> > > tile. Check the costline and the name "Roses" to see the
> > > difference.
> > >
> > >
> > > I have tried both tile sizes (256 and 512) with the same result.
> > >
> > > This is the code for the layer for size 256.
> > >
> > > var mapbox =  new TileLayer({
> > >     source: new SourceXYZ({
> > >       url: '
> > >
https://api.mapbox.com/styles/v1/mapesbasesigte/ck9olcn8017xc1it6mhv6myje/tiles/256/{z}/{x}/{y}?access_token=mytoken'

> > > ,
> > >     })
> > >   })
> > >
> > > And the code for the map.
> > >
> > > map = new Map({
> > >   layers: [ mapbox ],
> > >   target: 'map',
> > >   view: new View({
> > >     center: [0, 0],
> > >     zoom: 2,
> > >     projection: 'EPSG:3857',
> > >   }),
> > >   controls: defaultControls({attribution:
> > > false}).extend([attribution]),
> > > });
> > >
> > > Am I doing something wrong?
> > >
> > > Thanks you!!!
> > > _______________________________________________
> > > Users mailing list
> > > [hidden email]
> > > https://lists.osgeo.org/mailman/listinfo/openlayers-users
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> > https://lists.osgeo.org/mailman/listinfo/openlayers-users
>
>
_______________________________________________
Users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: blurry tiles

Andreas Hocevar
Using `zDirection: -1` is not always a good idea. Especially not if the tiles are already upscaled on the server.

You can look at the two maps below. Both use the Mapbox Satellite tileset. The first rendered in mapbox-gl, the second inOpenLayers (without a zDirection set). For me, they look and behave exactly the same:



Andreas.


On Tue, May 5, 2020 at 9:21 AM Toni Hernandez Valles <[hidden email]> wrote:
Hello,

Me too. I added the zDirection:-1 to the layer source, and the issue
still persists. :-(




On Mon, 2020-05-04 at 15:48 -0600, Richard Greenwood wrote:
> I'm seeing something similar with Mapbox satellite tiles. I
> added zDirection: -1 to my source definition but it didn't have any
> effect.
>
> resolution 0.6237836388319881
>
> resolution 0.5518893502310329
>
>
> On Mon, May 4, 2020 at 2:14 PM Andreas Hocevar <
> [hidden email]> wrote:
> > By default, OpenLayers applies up- and downscaling to the tiles. To
> > avoid upscaling, configure the source with
> >
> >     zDirection: -1
> >
> > Andreas.
> >
> > On Mon, May 4, 2020 at 8:47 PM Toni Hernandez Valles <
> > [hidden email]> wrote:
> > > Helo everyone,
> > >
> > > I am using a vector tile from mapbox and I am getting bluring
> > > tiles
> > > with no apparent reason. Not for me, at least
> > >
> > > I have checked tiles directly to mapbox and the quality is
> > > perfect,
> > > but, when using tiles with OpenLayers the map quality gets lower.
> > >
> > > In this link (https://mapscloud.udg.edu/blurry_tiles.png) you can
> > > see
> > > the quality of the map image (on the left) and the quality of a
> > > single
> > > tile. Check the costline and the name "Roses" to see the
> > > difference.
> > >
> > >
> > > I have tried both tile sizes (256 and 512) with the same result.
> > >
> > > This is the code for the layer for size 256.
> > >
> > > var mapbox =  new TileLayer({
> > >     source: new SourceXYZ({
> > >       url: '
> > >
https://api.mapbox.com/styles/v1/mapesbasesigte/ck9olcn8017xc1it6mhv6myje/tiles/256/{z}/{x}/{y}?access_token=mytoken'
> > > ,
> > >     })
> > >   })
> > >
> > > And the code for the map.
> > >
> > > map = new Map({
> > >   layers: [ mapbox ],
> > >   target: 'map',
> > >   view: new View({
> > >     center: [0, 0],
> > >     zoom: 2,
> > >     projection: 'EPSG:3857',
> > >   }),
> > >   controls: defaultControls({attribution:
> > > false}).extend([attribution]),
> > > });
> > >
> > > Am I doing something wrong?
> > >
> > > Thanks you!!!
> > > _______________________________________________
> > > Users mailing list
> > > [hidden email]
> > > https://lists.osgeo.org/mailman/listinfo/openlayers-users
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> > https://lists.osgeo.org/mailman/listinfo/openlayers-users
>
>

_______________________________________________
Users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: blurry tiles

Toni Hernandez Valles
Yes thet look exactly the same.

Although I am using de OL default resolutions, is it possible that my
OL map is not using the same zoom resolutions than mapbox?

Toni


On Tue, 2020-05-05 at 11:30 +0200, Andreas Hocevar wrote:
> Using `zDirection: -1` is not always a good idea. Especially not if
> the tiles are already upscaled on the server.
>
> You can look at the two maps below. Both use the Mapbox Satellite
> tileset. The first rendered in mapbox-gl, the second inOpenLayers
> (without a zDirection set). For me, they look and behave exactly the
> same:
>
>
https://api.mapbox.com/styles/v1/mapbox/satellite-v9.html?title=true&access_token=pk.eyJ1IjoibWFwYm94IiwiYSI6ImNpejY4M29iazA2Z2gycXA4N2pmbDZmangifQ.-g_vE53SD2WrJ6tFX7QHmA#17.4/47.078636/15.426918

>
> https://r55zn.csb.app/#/center/15.42692,47.07864/zoom/17.4
>
> Andreas.
>
>
> On Tue, May 5, 2020 at 9:21 AM Toni Hernandez Valles <
> [hidden email]> wrote:
> > Hello,
> >
> > Me too. I added the zDirection:-1 to the layer source, and the
> > issue
> > still persists. :-(
> >
> >
> >
> >
> > On Mon, 2020-05-04 at 15:48 -0600, Richard Greenwood wrote:
> > > I'm seeing something similar with Mapbox satellite tiles. I
> > > added zDirection: -1 to my source definition but it didn't have
> > any
> > > effect.
> > >
> > > resolution 0.6237836388319881
> > >
> > > resolution 0.5518893502310329
> > >
> > >
> > > On Mon, May 4, 2020 at 2:14 PM Andreas Hocevar <
> > > [hidden email]> wrote:
> > > > By default, OpenLayers applies up- and downscaling to the
> > tiles. To
> > > > avoid upscaling, configure the source with
> > > >
> > > >     zDirection: -1
> > > >
> > > > Andreas.
> > > >
> > > > On Mon, May 4, 2020 at 8:47 PM Toni Hernandez Valles <
> > > > [hidden email]> wrote:
> > > > > Helo everyone,
> > > > >
> > > > > I am using a vector tile from mapbox and I am getting bluring
> > > > > tiles
> > > > > with no apparent reason. Not for me, at least
> > > > >
> > > > > I have checked tiles directly to mapbox and the quality is
> > > > > perfect,
> > > > > but, when using tiles with OpenLayers the map quality gets
> > lower.
> > > > >
> > > > > In this link (https://mapscloud.udg.edu/blurry_tiles.png) you
> > can
> > > > > see
> > > > > the quality of the map image (on the left) and the quality of
> > a
> > > > > single
> > > > > tile. Check the costline and the name "Roses" to see the
> > > > > difference.
> > > > >
> > > > >
> > > > > I have tried both tile sizes (256 and 512) with the same
> > result.
> > > > >
> > > > > This is the code for the layer for size 256.
> > > > >
> > > > > var mapbox =  new TileLayer({
> > > > >     source: new SourceXYZ({
> > > > >       url: '
> > > > >
> >
https://api.mapbox.com/styles/v1/mapesbasesigte/ck9olcn8017xc1it6mhv6myje/tiles/256/{z}/{x}/{y}?access_token=mytoken'

> > > > > ,
> > > > >     })
> > > > >   })
> > > > >
> > > > > And the code for the map.
> > > > >
> > > > > map = new Map({
> > > > >   layers: [ mapbox ],
> > > > >   target: 'map',
> > > > >   view: new View({
> > > > >     center: [0, 0],
> > > > >     zoom: 2,
> > > > >     projection: 'EPSG:3857',
> > > > >   }),
> > > > >   controls: defaultControls({attribution:
> > > > > false}).extend([attribution]),
> > > > > });
> > > > >
> > > > > Am I doing something wrong?
> > > > >
> > > > > Thanks you!!!
> > > > > _______________________________________________
> > > > > Users mailing list
> > > > > [hidden email]
> > > > > https://lists.osgeo.org/mailman/listinfo/openlayers-users
> > > >
> > > > _______________________________________________
> > > > Users mailing list
> > > > [hidden email]
> > > > https://lists.osgeo.org/mailman/listinfo/openlayers-users
> > >
> > >
_______________________________________________
Users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/openlayers-users