app_dev.php is not opening

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

app_dev.php is not opening

naresh-2
Dear ALL,

   I have installed Mapbender3.0.4.1 on windows xp machine. I have followed the steps given in http://doc.mapbender3.org/en/book/installation.html#installation-example-for-windows. When i am visiting the link http://localhost/mapbender/app_dev.php -> the page is not showing it is  keep on loading. How to run/open the application.

The following info may be helpful to understand the issue

 1. http://localhost/mapbender3/config.php showing the following message.

 Your configuration looks good to run Symfony.

Even if we click on above hyper links the page was not loading.
2. while executing the command php.exe app/console init:acl it is shown the message Aborting: The table with name 'postgres:acl_classes' already exists

3. Attached  parameter.yml and config.yml file. ( where i have changed the paramers).

Please give suggestion/advise how to fix the issue and explore further map bender option     


Thanks&Regards,
Naresh



_______________________________________________
Mapbender_users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapbender_users

config.yml (2K) Download Attachment
parameters.yml (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: app_dev.php is not opening

Astrid Emde (WhereGroup)
Hello Naresh,

I think you tried to open the following link with mapbender3. You have firebug for your browser? You could check whether you get an error message there.
 
http://localhost/mapbender3/app_dev.php

Please have a look in you apache log-file too.

These are the first advises I can give.

Best regards Astrid


Am 23.04.2015 11:18, schrieb naresh:
Dear ALL,

   I have installed Mapbender3.0.4.1 on windows xp machine. I have followed the steps given in http://doc.mapbender3.org/en/book/installation.html#installation-example-for-windows. When i am visiting the link http://localhost/mapbender/app_dev.php -> the page is not showing it is  keep on loading. How to run/open the application.

The following info may be helpful to understand the issue

 1. http://localhost/mapbender3/config.php showing the following message.

 Your configuration looks good to run Symfony.

Even if we click on above hyper links the page was not loading.
2. while executing the command php.exe app/console init:acl it is shown the message Aborting: The table with name 'postgres:acl_classes' already exists

3. Attached  parameter.yml and config.yml file. ( where i have changed the paramers).

Please give suggestion/advise how to fix the issue and explore further map bender option     


Thanks&Regards,
Naresh




_______________________________________________
Mapbender_users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapbender_users


-- 

Mit freundlichen Grüßen

Astrid Emde
GIS-Consultant

-----------------------------------
Aufwind durch Wissen!
Qualifizierte OpenSource-Schulungen
bei der www.foss-academy.eu
-----------------------------------

 Astrid Emde
 WhereGroup GmbH & Co.KG
 Eifelstraße 7
 53119 Bonn
 Germany

 Fon: +49(0)228 90 90 38 - 19
 Fax: +49(0)228 90 90 38 - 11

 [hidden email]
 www.wheregroup.com

 Folgen Sie der WhereGroup auf twitter: http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
 pgp-public key:
 http://pgp.mit.edu:11371/pks/lookup?search=0x06DA52D72D515284
  Signierte und/oder verschlüsselte Nachrichten sind sehr willkommen
  Signed and/or encrypted mail is highly appreciated


_______________________________________________
Mapbender_users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapbender_users
SL
Reply | Threaded
Open this post in threaded view
|

Re: app_dev.php is not opening

SL
Hello Astrid,

I had the same problem which takes a long time to load app_dev.php and css
doest not load as well.

The error on browser:

Request
URL:http://localhost/mapbender/app_dev.php/application/manager/assets/css
Request Method:GET
Remote Address:127.0.0.1:80
Status Code: 500 Internal Server Error
Version:HTTP/1.1
Referrer Policy:no-referrer-when-downgrade

The error on error logs:

[2020-03-20 03:01:25] request.CRITICAL: Uncaught PHP Exception
Symfony\Component\Process\Exception\ProcessTimedOutException: "The process
""E:\mapbender\vendor\wheregroup\sassc-binaries\dist/sassc.exe"
"--load-path" "\\" "--style" "nested" "--load-path"
"E:\mapbender\app/../mapbender/src/Mapbender/CoreBundle/Resources/public/sass"
"--load-path" "E:\mapbender\app/../vendor/igosuki/compass-mixins/lib"
"--load-path" "E:\mapbender\app/../web" "C:\Windows\Temp\assD79.tmp""
exceeded the timeout of 60 seconds." at
E:\mapbender\vendor\symfony\symfony\src\Symfony\Component\Process\Process.php
line 1193 {"exception":"[object]
(Symfony\\Component\\Process\\Exception\\ProcessTimedOutException(code: 0):
The process
\"\"E:\\mapbender\\vendor\\wheregroup\\sassc-binaries\\dist/sassc.exe\"
\"--load-path\" \"\\\\\" \"--style\" \"nested\" \"--load-path\"
\"E:\\mapbender\\app/../mapbender/src/Mapbender/CoreBundle/Resources/public/sass\"
\"--load-path\" \"E:\\mapbender\\app/../vendor/igosuki/compass-mixins/lib\"
\"--load-path\" \"E:\\mapbender\\app/../web\"
\"C:\\Windows\\Temp\\assD79.tmp\"\" exceeded the timeout of 60 seconds. at
E:\\mapbender\\vendor\\symfony\\symfony\\src\\Symfony\\Component\\Process\\Process.php:1193)"}



--
Sent from: http://osgeo-org.1560.x6.nabble.com/mapbender-users-f4220788.html
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: app_dev.php is not opening

jmckenna
Administrator
Hello,

For Windows users we solved this by leveraging many tricks to speed up
the load for the MS4W distribution, such as the OPcache PHP extension
etc.  You can test the speed on the official demo server at
https://ms4w.dev/mapbender/app.php/  or download MS4W from https://ms4w.com

Hope that helps,

-jeff



--
Jeff McKenna
MapServer Consulting and Training Services
https://gatewaygeomatics.com/





On 2020-03-19 11:27 p.m., SL wrote:

> Hello Astrid,
>
> I had the same problem which takes a long time to load app_dev.php and css
> doest not load as well.
>
> The error on browser:
>
> Request
> URL:http://localhost/mapbender/app_dev.php/application/manager/assets/css
> Request Method:GET
> Remote Address:127.0.0.1:80
> Status Code: 500 Internal Server Error
> Version:HTTP/1.1
> Referrer Policy:no-referrer-when-downgrade
>
> The error on error logs:
>
> [2020-03-20 03:01:25] request.CRITICAL: Uncaught PHP Exception
> Symfony\Component\Process\Exception\ProcessTimedOutException: "The process
> ""E:\mapbender\vendor\wheregroup\sassc-binaries\dist/sassc.exe"
> "--load-path" "\\" "--style" "nested" "--load-path"
> "E:\mapbender\app/../mapbender/src/Mapbender/CoreBundle/Resources/public/sass"
> "--load-path" "E:\mapbender\app/../vendor/igosuki/compass-mixins/lib"
> "--load-path" "E:\mapbender\app/../web" "C:\Windows\Temp\assD79.tmp""
> exceeded the timeout of 60 seconds." at
> E:\mapbender\vendor\symfony\symfony\src\Symfony\Component\Process\Process.php
> line 1193 {"exception":"[object]
> (Symfony\\Component\\Process\\Exception\\ProcessTimedOutException(code: 0):
> The process
> \"\"E:\\mapbender\\vendor\\wheregroup\\sassc-binaries\\dist/sassc.exe\"
> \"--load-path\" \"\\\\\" \"--style\" \"nested\" \"--load-path\"
> \"E:\\mapbender\\app/../mapbender/src/Mapbender/CoreBundle/Resources/public/sass\"
> \"--load-path\" \"E:\\mapbender\\app/../vendor/igosuki/compass-mixins/lib\"
> \"--load-path\" \"E:\\mapbender\\app/../web\"
> \"C:\\Windows\\Temp\\assD79.tmp\"\" exceeded the timeout of 60 seconds. at
> E:\\mapbender\\vendor\\symfony\\symfony\\src\\Symfony\\Component\\Process\\Process.php:1193)"}
>
>
>



_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: app_dev.php is not opening

Astrid Emde (WhereGroup)
Hello,

in your log it says:
>> \"C:\\Windows\\Temp\\assD79.tmp\"\" exceeded the timeout of 60
>> seconds. at

So please check whether your Apache user can write into this directory.

Astrid

Am 2020-03-20 12:35, schrieb Jeff McKenna:

> Hello,
>
> For Windows users we solved this by leveraging many tricks to speed up
> the load for the MS4W distribution, such as the OPcache PHP extension
> etc.  You can test the speed on the official demo server at
> https://ms4w.dev/mapbender/app.php/  or download MS4W from
> https://ms4w.com
>
> Hope that helps,
>
> -jeff
>
>
>
> --
> Jeff McKenna
> MapServer Consulting and Training Services
> https://gatewaygeomatics.com/
>
>
>
>
>
> On 2020-03-19 11:27 p.m., SL wrote:
>> Hello Astrid,
>>
>> I had the same problem which takes a long time to load app_dev.php and
>> css
>> doest not load as well.
>>
>> The error on browser:
>>
>> Request
>> URL:http://localhost/mapbender/app_dev.php/application/manager/assets/css
>> Request Method:GET
>> Remote Address:127.0.0.1:80
>> Status Code: 500 Internal Server Error
>> Version:HTTP/1.1
>> Referrer Policy:no-referrer-when-downgrade
>>
>> The error on error logs:
>>
>> [2020-03-20 03:01:25] request.CRITICAL: Uncaught PHP Exception
>> Symfony\Component\Process\Exception\ProcessTimedOutException: "The
>> process
>> ""E:\mapbender\vendor\wheregroup\sassc-binaries\dist/sassc.exe"
>> "--load-path" "\\" "--style" "nested" "--load-path"
>> "E:\mapbender\app/../mapbender/src/Mapbender/CoreBundle/Resources/public/sass"
>> "--load-path" "E:\mapbender\app/../vendor/igosuki/compass-mixins/lib"
>> "--load-path" "E:\mapbender\app/../web" "C:\Windows\Temp\assD79.tmp""
>> exceeded the timeout of 60 seconds." at
>> E:\mapbender\vendor\symfony\symfony\src\Symfony\Component\Process\Process.php
>> line 1193 {"exception":"[object]
>> (Symfony\\Component\\Process\\Exception\\ProcessTimedOutException(code:
>> 0):
>> The process
>> \"\"E:\\mapbender\\vendor\\wheregroup\\sassc-binaries\\dist/sassc.exe\"
>> \"--load-path\" \"\\\\\" \"--style\" \"nested\" \"--load-path\"
>> \"E:\\mapbender\\app/../mapbender/src/Mapbender/CoreBundle/Resources/public/sass\"
>> \"--load-path\"
>> \"E:\\mapbender\\app/../vendor/igosuki/compass-mixins/lib\"
>> \"--load-path\" \"E:\\mapbender\\app/../web\"
>> \"C:\\Windows\\Temp\\assD79.tmp\"\" exceeded the timeout of 60
>> seconds. at
>> E:\\mapbender\\vendor\\symfony\\symfony\\src\\Symfony\\Component\\Process\\Process.php:1193)"}
>>
>>
>>
>
>
>
> _______________________________________________
> Mapbender_users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_users

--
Mit freundlichen Grüßen

Astrid Emde
GIS-Consultant

   Astrid Emde
   WhereGroup GmbH
   Eifelstraße 7
   53119 Bonn
   Germany

   Fon: +49(0)228 90 90 38 - 22
   Fax: +49(0)228 90 90 38 - 11

   [hidden email]
   www.wheregroup.com

   Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Geschäftsführer:
Olaf Knopp, Peter Stamm
Amtsgericht Bonn, HRB 9885
-------------------------------
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users