access data WFS and WCS

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

access data WFS and WCS

pjzgeo
Hi list

pywps supports input parameters in the Execute call, through WMC adn WFS? 

I am try severals forms, but does not work:


Uncodified the query WCS:


<Exception exceptionCode="InvalidParameterValue" locator="request"/>
</ExceptionReport>


Codifed the query WCS:

http%3A%2F%2Flocalhost%3A8080%2Fgeoserver%2Fwcs%3FSERVICE%3DWCS%26VERSION%3D2.0.1%26REQUEST%3DGetCoverage%26COVERAGEID%3Dtiger__demrepro%26FORMAT%3Dimage%2Ftiff]&responsedocument=slope=@asreference=True

<Exception exceptionCode="InvalidParameterValue" locator="request"/>
</ExceptionReport>

The /var/log/apache2/error.log

[Mon Feb 15 17:42:31 2016] [error] [client 127.0.0.1] PyWPS InvalidParameterValue: Locator: request; Value: None

Thanks in advanced

Pablo


_______________________________________________
pywps-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/pywps-dev
Reply | Threaded
Open this post in threaded view
|

Re: access data WFS and WCS

Jachym Cepicky
Hi,

yeah, it was working, I used that several times, BUT

1 - use codified version of the url
2 - omit [] brackets (it should work, but just for the case)
3 - if you are brave enough, try to debug what the problem could be in the source code level
4 - To me, this is kinnda "adnvanced" request, you should go with POST request, gives you more save input parsing
5 - Yes, there seems to be bug in execute get parser, the escaped values are unescaped, attributes of the input parameter are going to look like 


and next statemenet


does not work

2 options:

1 - go with POST request
2 - I've created ticket https://github.com/geopython/pywps/issues/79 hope to get to it

J

po 15. 2. 2016 v 21:45 odesílatel pablo zader <[hidden email]> napsal:
Hi list

pywps supports input parameters in the Execute call, through WMC adn WFS? 

I am try severals forms, but does not work:


Uncodified the query WCS:


<Exception exceptionCode="InvalidParameterValue" locator="request"/>
</ExceptionReport>


Codifed the query WCS:

http%3A%2F%2Flocalhost%3A8080%2Fgeoserver%2Fwcs%3FSERVICE%3DWCS%26VERSION%3D2.0.1%26REQUEST%3DGetCoverage%26COVERAGEID%3Dtiger__demrepro%26FORMAT%3Dimage%2Ftiff]&responsedocument=slope=@asreference=True

<Exception exceptionCode="InvalidParameterValue" locator="request"/>
</ExceptionReport>

The /var/log/apache2/error.log

[Mon Feb 15 17:42:31 2016] [error] [client 127.0.0.1] PyWPS InvalidParameterValue: Locator: request; Value: None

Thanks in advanced

Pablo

_______________________________________________
pywps-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/pywps-dev

_______________________________________________
pywps-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/pywps-dev