WmsInstance#source are inconsistent with each other, WmsSource must be private or protected

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

WmsInstance#source are inconsistent with each other, WmsSource must be private or protected

Mike1973
Hi Everyone,

I'm getting the following error message

The mappings Mapbender\WmsBundle\Entity\WmsSource#instances and Mapbender\WmsBundle\Entity\WmsInstance#source are inconsistent with each other.
Field 'getCapabilities' in class 'Mapbender\WmsBundle\Entity\WmsSource' must be private or protected. Public fields may break lazy-loading.
Field 'getMap' in class 'Mapbender\WmsBundle\Entity\WmsSource' must be private or protected. Public fields may break lazy-loading.

My WMS getcapabilities loads, but map layers are not visible.

Also, is there a way for me to disable the owsproxy3 bundle.
Have a feeling that this might be causing my WMS not to resolve correctly.

Thank you.