WMTS layer printing

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

WMTS layer printing

Ian Turton
I'm struggling to print a WMTS base layer from my GeoNetwork 3.0.x install
- I've laid out the setup and errors in this StackExchange question (
http://gis.stackexchange.com/q/212010/79) if any one has any experience of
this I'd love to hear from you.

Cheers

Ian

--
Ian Turton
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: WMTS layer printing

Jose Garcia
Hi Ian

From the docs I see this:

   - baseURL the ‘ResourceURL’ available in the WMTS capabilities.


And also found this example:
https://github.com/mapfish/mapfish-print-e2e-test/blob/master/src/main/webapp/data/www/geoext-print-examples/Print-WMTS-Layers-Using-WMTS-Version-1.0.0/index.html#L49

Looks like it's expecting the main URL of the WMTS service. Try this in
your case: https://xxx.xxxx.co.uk/services/xxxxxxx/wmts

Regards,
Jose García

On Mon, Sep 26, 2016 at 6:30 PM, Ian Turton <[hidden email]> wrote:

> I'm struggling to print a WMTS base layer from my GeoNetwork 3.0.x install
> - I've laid out the setup and errors in this StackExchange question (
> http://gis.stackexchange.com/q/212010/79) if any one has any experience of
> this I'd love to hear from you.
>
> Cheers
>
> Ian
>
> --
> Ian Turton
> ------------------------------------------------------------
> ------------------
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at http://sourceforge.net/
> projects/geonetwork
>



--













*Vriendelijke groeten / Kind regards,Jose García
<http://www.geocat.net/>Veenderweg 136721 WD BennekomThe NetherlandsT: +31
(0)318 416664 <+31318416664> <https://www.facebook.com/geocatbv>
<https://twitter.com/geocat_bv>
<https://plus.google.com/u/1/+GeocatNetbv/posts>Please consider the
environment before printing this email.*
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: WMTS layer printing

Ian Turton
On 27 September 2016 at 06:59, Jose Garcia <[hidden email]> wrote:

> Hi Ian
>
> From the docs I see this:
>
>    - baseURL the ‘ResourceURL’ available in the WMTS capabilities.
>
>
For a REST based WMTS this URL contains the {style} etc elements that
should be substituted before use as a URL/URI which is what MapFish seems
to  be objecting to.

>
> And also found this example: https://github.com/mapfish/mapfish-print-e2e-
> test/blob/master/src/main/webapp/data/www/geoext-print-
> examples/Print-WMTS-Layers-Using-WMTS-Version-1.0.0/index.html#L49
>
> Looks like it's expecting the main URL of the WMTS service. Try this in
> your case: https://xxx.xxxx.co.uk/services/xxxxxxx/wmts
>

That example is using KVP (which sadly my service doesn't support) so that
would be correct for that example.

Cheers

Ian
------------------------------------------------------------------------------
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork