Quantcast

WMSGetFeatureInfo issue

classic Classic list List threaded Threaded
3 messages Options
dr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

WMSGetFeatureInfo issue

dr
Hi OpenLayers dev team!

I have problem with WMSGetFeatureInfo control - e.features is undefined under IE 9 in following code:

new OpenLayers.Control.WMSGetFeatureInfo({
            autoActivate: true,
            infoFormat: 'application/vnd.ogc.gml',
            maxFeatures: 1000,
            layers: [lay_herbary, lay_all_tao_oopt],
            queryVisible: true,
            eventListeners: {
                'getfeatureinfo': function(e) {
                    alert(e.features.length);     <- undefined in IE
                }
                ....

This is screenshot of IE debugger:

As you can see - type of e.features is IXMLDOMDocument2 but Array expected.



_______________________________________________
Dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-dev
dr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WMSGetFeatureInfo issue

dr
I guess problem caused by broken attributes of features.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WMSGetFeatureInfo issue

Bart van den Eijnden (OSGIS)-2
In reply to this post by dr
Seems there is a parsing error. Is the XML returned valid?

Bart

-- 
Bart van den Eijnden
OSGIS - http://osgis.nl

On Nov 29, 2011, at 6:48 AM, Denis Rykov wrote:

Hi OpenLayers dev team!

I have problem with WMSGetFeatureInfo control - e.features is undefined under IE 9 in following code:

new OpenLayers.Control.WMSGetFeatureInfo({
            autoActivate: true,
            infoFormat: 'application/vnd.ogc.gml',
            maxFeatures: 1000,
            layers: [lay_herbary, lay_all_tao_oopt],
            queryVisible: true,
            eventListeners: {
                'getfeatureinfo': function(e) {
                    alert(e.features.length);     <- undefined in IE
                }
                ....

This is screenshot of IE debugger:

As you can see - type of e.features is IXMLDOMDocument2 but Array expected.


_______________________________________________
Dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-dev


_______________________________________________
Dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-dev
Loading...