WFS with 6.0.0 Beta RC2

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

WFS with 6.0.0 Beta RC2

Arnd Wippermann
Hi,

I'm trying to get WFS working with 6.0.0 Beta RC2.

If i use MapServer 5.6.5 a wfs post request returns the features.
If I use MapServer 6.0.0 the same post request responses with
...<gml:null>missing</gml:null>.

The BBOX coordinates, the mapfile projection and layer is in EPSG:3763.
In the WEB METADATA Block is set 'wfs_srs' 'EPSG:3763'
There is no reprojection needed.

Is there something I have to consider, when using MapServer Version 6.0.0
and WFS.

Arnd

POST

<wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS"
version="1.0.0" maxFeatures="100">
<wfs:Query typeName="default">
<ogc:Filter xmlns:ogc="http://www.opengis.net/ogc">
<ogc:BBOX>
<ogc:PropertyName>msgeometry</ogc:PropertyName>
<gml:Box xmlns:gml="http://www.opengis.net/gml" srsName="EPSG:3763">
<gml:coordinates decimal="." cs="," ts=" ">-535786.68671593,-509560.89777426
559489.72019154,364218.61581997</gml:coordinates>
</gml:Box>
</ogc:BBOX>
</ogc:Filter>
</wfs:Query>
</wfs:GetFeature>

RESPONSE MapServer 5.6.5

<?xml version='1.0' encoding="ISO-8859-1" ?>
<wfs:FeatureCollection
   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
   xmlns:wfs="http://www.opengis.net/wfs"
   xmlns:gml="http://www.opengis.net/gml"
   xmlns:ogc="http://www.opengis.net/ogc"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:schemaLocation="http://www.opengis.net/wfs
http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd 
                       http://mapserver.gis.umn.edu/mapserver
http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&amp;VERSI
ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUTPUTFORM
AT=XMLSCHEMA">
      <gml:boundedBy>
      <gml:Box srsName="EPSG:3763">
      <gml:coordinates>-21537.507741,-91486.277029
44944.469424,-56235.046915</gml:coordinates>
      </gml:Box>
      </gml:boundedBy>
    <gml:featureMember>
      <ms:default>
        <gml:boundedBy>
        <gml:Box srsName="EPSG:3763">
        <gml:coordinates>-21441.941044,-67958.139907
-11234.384166,-56235.046915</gml:coordinates>
        </gml:Box>
        </gml:boundedBy>
        <ms:msGeometry>
        <gml:Polygon srsName="EPSG:3763">
          <gml:outerBoundaryIs>
            <gml:LinearRing>
              <gml:coordinates>-21441.941044,-56235.046915
-11234.384166,-56256.314719 -16838.013555,-67958.139907
-21441.941044,-56235.046915 </gml:coordinates>
            </gml:LinearRing>
          </gml:outerBoundaryIs>
        </gml:Polygon>
        </ms:msGeometry>
        <ms:name>No 1</ms:name>
        <ms:descriptio>AREA</ms:descriptio>
      </ms:default>
    </gml:featureMember>
...


RESPONSE MapServer 6.0.0

<?xml version='1.0' encoding="ISO-8859-1" ?>
<wfs:FeatureCollection
   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
   xmlns:wfs="http://www.opengis.net/wfs"
   xmlns:gml="http://www.opengis.net/gml"
   xmlns:ogc="http://www.opengis.net/ogc"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:schemaLocation="http://www.opengis.net/wfs
http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd 
                       http://mapserver.gis.umn.edu/mapserver
http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&amp;VERSI
ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUTPUTFORM
AT=XMLSCHEMA">
   <gml:boundedBy>
      <gml:null>missing</gml:null>
   </gml:boundedBy>
</wfs:FeatureCollection>

LOG Entry

[Mon May 09 22:11:54 2011].666000 CGI Request 1 on process 3968
[Mon May 09 22:11:54 2011].666000 msQueryByFilter(): Search returned no
results. No matching record(s) found.
[Mon May 09 22:11:54 2011].713000 msProjectRect(): some points failed to
reproject, doing internal sampling.
[Mon May 09 22:11:54 2011].713000 mapserv request processing time (msLoadMap
not incl.): 0.047s
[Mon May 09 22:11:54 2011].713000 msFreeMap(): freeing map at 0184A9E8.






_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: WFS with 6.0.0 Beta RC2

alexander-petkov
I am getting the same behaviour with Mapserver 6.0.0. Previous 5.6.*
releases work fine with the same request. I am wondering whether I am
missing some new required declaration since 6.0.0 was released...

Alex

On Mon, May 9, 2011 at 2:44 PM, Arnd Wippermann <[hidden email]> wrote:

> Hi,
>
> I'm trying to get WFS working with 6.0.0 Beta RC2.
>
> If i use MapServer 5.6.5 a wfs post request returns the features.
> If I use MapServer 6.0.0 the same post request responses with
> ...<gml:null>missing</gml:null>.
>
> The BBOX coordinates, the mapfile projection and layer is in EPSG:3763.
> In the WEB METADATA Block is set 'wfs_srs' 'EPSG:3763'
> There is no reprojection needed.
>
> Is there something I have to consider, when using MapServer Version 6.0.0
> and WFS.
>
> Arnd
>
> POST
>
> <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS"
> version="1.0.0" maxFeatures="100">
> <wfs:Query typeName="default">
> <ogc:Filter xmlns:ogc="http://www.opengis.net/ogc">
> <ogc:BBOX>
> <ogc:PropertyName>msgeometry</ogc:PropertyName>
> <gml:Box xmlns:gml="http://www.opengis.net/gml" srsName="EPSG:3763">
> <gml:coordinates decimal="." cs="," ts=" ">-535786.68671593,-509560.89777426
> 559489.72019154,364218.61581997</gml:coordinates>
> </gml:Box>
> </ogc:BBOX>
> </ogc:Filter>
> </wfs:Query>
> </wfs:GetFeature>
>
> RESPONSE MapServer 5.6.5
>
> <?xml version='1.0' encoding="ISO-8859-1" ?>
> <wfs:FeatureCollection
>   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
>   xmlns:wfs="http://www.opengis.net/wfs"
>   xmlns:gml="http://www.opengis.net/gml"
>   xmlns:ogc="http://www.opengis.net/ogc"
>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>   xsi:schemaLocation="http://www.opengis.net/wfs
> http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd
>                       http://mapserver.gis.umn.edu/mapserver
> http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&amp;VERSI
> ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUTPUTFORM
> AT=XMLSCHEMA">
>      <gml:boundedBy>
>        <gml:Box srsName="EPSG:3763">
>                <gml:coordinates>-21537.507741,-91486.277029
> 44944.469424,-56235.046915</gml:coordinates>
>        </gml:Box>
>      </gml:boundedBy>
>    <gml:featureMember>
>      <ms:default>
>        <gml:boundedBy>
>                <gml:Box srsName="EPSG:3763">
>                        <gml:coordinates>-21441.941044,-67958.139907
> -11234.384166,-56235.046915</gml:coordinates>
>                </gml:Box>
>        </gml:boundedBy>
>        <ms:msGeometry>
>        <gml:Polygon srsName="EPSG:3763">
>          <gml:outerBoundaryIs>
>            <gml:LinearRing>
>              <gml:coordinates>-21441.941044,-56235.046915
> -11234.384166,-56256.314719 -16838.013555,-67958.139907
> -21441.941044,-56235.046915 </gml:coordinates>
>            </gml:LinearRing>
>          </gml:outerBoundaryIs>
>        </gml:Polygon>
>        </ms:msGeometry>
>        <ms:name>No 1</ms:name>
>        <ms:descriptio>AREA</ms:descriptio>
>      </ms:default>
>    </gml:featureMember>
> ...
>
>
> RESPONSE MapServer 6.0.0
>
> <?xml version='1.0' encoding="ISO-8859-1" ?>
> <wfs:FeatureCollection
>   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
>   xmlns:wfs="http://www.opengis.net/wfs"
>   xmlns:gml="http://www.opengis.net/gml"
>   xmlns:ogc="http://www.opengis.net/ogc"
>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>   xsi:schemaLocation="http://www.opengis.net/wfs
> http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd
>                       http://mapserver.gis.umn.edu/mapserver
> http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&amp;VERSI
> ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUTPUTFORM
> AT=XMLSCHEMA">
>   <gml:boundedBy>
>      <gml:null>missing</gml:null>
>   </gml:boundedBy>
> </wfs:FeatureCollection>
>
> LOG Entry
>
> [Mon May 09 22:11:54 2011].666000 CGI Request 1 on process 3968
> [Mon May 09 22:11:54 2011].666000 msQueryByFilter(): Search returned no
> results. No matching record(s) found.
> [Mon May 09 22:11:54 2011].713000 msProjectRect(): some points failed to
> reproject, doing internal sampling.
> [Mon May 09 22:11:54 2011].713000 mapserv request processing time (msLoadMap
> not incl.): 0.047s
> [Mon May 09 22:11:54 2011].713000 msFreeMap(): freeing map at 0184A9E8.
>
>
>
>
>
>
> _______________________________________________
> mapserver-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/mapserver-users
>
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: WFS with 6.0.0 Beta RC2

alexander-petkov
The interesting thing is that when a GET request is issued with the
same filter, the GML for the feature is returned as expected.
Does anybody have POST GetFeature requests working with Mapserver v6.0.0?

Thanks in advance,
Alex
On Mon, Jul 11, 2011 at 12:34 PM, Alexander Petkov <[hidden email]> wrote:

> I am getting the same behaviour with Mapserver 6.0.0. Previous 5.6.*
> releases work fine with the same request. I am wondering whether I am
> missing some new required declaration since 6.0.0 was released...
>
> Alex
>
> On Mon, May 9, 2011 at 2:44 PM, Arnd Wippermann <[hidden email]> wrote:
>> Hi,
>>
>> I'm trying to get WFS working with 6.0.0 Beta RC2.
>>
>> If i use MapServer 5.6.5 a wfs post request returns the features.
>> If I use MapServer 6.0.0 the same post request responses with
>> ...<gml:null>missing</gml:null>.
>>
>> The BBOX coordinates, the mapfile projection and layer is in EPSG:3763.
>> In the WEB METADATA Block is set 'wfs_srs' 'EPSG:3763'
>> There is no reprojection needed.
>>
>> Is there something I have to consider, when using MapServer Version 6.0.0
>> and WFS.
>>
>> Arnd
>>
>> POST
>>
>> <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS"
>> version="1.0.0" maxFeatures="100">
>> <wfs:Query typeName="default">
>> <ogc:Filter xmlns:ogc="http://www.opengis.net/ogc">
>> <ogc:BBOX>
>> <ogc:PropertyName>msgeometry</ogc:PropertyName>
>> <gml:Box xmlns:gml="http://www.opengis.net/gml" srsName="EPSG:3763">
>> <gml:coordinates decimal="." cs="," ts=" ">-535786.68671593,-509560.89777426
>> 559489.72019154,364218.61581997</gml:coordinates>
>> </gml:Box>
>> </ogc:BBOX>
>> </ogc:Filter>
>> </wfs:Query>
>> </wfs:GetFeature>
>>
>> RESPONSE MapServer 5.6.5
>>
>> <?xml version='1.0' encoding="ISO-8859-1" ?>
>> <wfs:FeatureCollection
>>   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
>>   xmlns:wfs="http://www.opengis.net/wfs"
>>   xmlns:gml="http://www.opengis.net/gml"
>>   xmlns:ogc="http://www.opengis.net/ogc"
>>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>   xsi:schemaLocation="http://www.opengis.net/wfs
>> http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd
>>                       http://mapserver.gis.umn.edu/mapserver
>> http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&amp;VERSI
>> ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUTPUTFORM
>> AT=XMLSCHEMA">
>>      <gml:boundedBy>
>>        <gml:Box srsName="EPSG:3763">
>>                <gml:coordinates>-21537.507741,-91486.277029
>> 44944.469424,-56235.046915</gml:coordinates>
>>        </gml:Box>
>>      </gml:boundedBy>
>>    <gml:featureMember>
>>      <ms:default>
>>        <gml:boundedBy>
>>                <gml:Box srsName="EPSG:3763">
>>                        <gml:coordinates>-21441.941044,-67958.139907
>> -11234.384166,-56235.046915</gml:coordinates>
>>                </gml:Box>
>>        </gml:boundedBy>
>>        <ms:msGeometry>
>>        <gml:Polygon srsName="EPSG:3763">
>>          <gml:outerBoundaryIs>
>>            <gml:LinearRing>
>>              <gml:coordinates>-21441.941044,-56235.046915
>> -11234.384166,-56256.314719 -16838.013555,-67958.139907
>> -21441.941044,-56235.046915 </gml:coordinates>
>>            </gml:LinearRing>
>>          </gml:outerBoundaryIs>
>>        </gml:Polygon>
>>        </ms:msGeometry>
>>        <ms:name>No 1</ms:name>
>>        <ms:descriptio>AREA</ms:descriptio>
>>      </ms:default>
>>    </gml:featureMember>
>> ...
>>
>>
>> RESPONSE MapServer 6.0.0
>>
>> <?xml version='1.0' encoding="ISO-8859-1" ?>
>> <wfs:FeatureCollection
>>   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
>>   xmlns:wfs="http://www.opengis.net/wfs"
>>   xmlns:gml="http://www.opengis.net/gml"
>>   xmlns:ogc="http://www.opengis.net/ogc"
>>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>   xsi:schemaLocation="http://www.opengis.net/wfs
>> http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd
>>                       http://mapserver.gis.umn.edu/mapserver
>> http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&amp;VERSI
>> ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUTPUTFORM
>> AT=XMLSCHEMA">
>>   <gml:boundedBy>
>>      <gml:null>missing</gml:null>
>>   </gml:boundedBy>
>> </wfs:FeatureCollection>
>>
>> LOG Entry
>>
>> [Mon May 09 22:11:54 2011].666000 CGI Request 1 on process 3968
>> [Mon May 09 22:11:54 2011].666000 msQueryByFilter(): Search returned no
>> results. No matching record(s) found.
>> [Mon May 09 22:11:54 2011].713000 msProjectRect(): some points failed to
>> reproject, doing internal sampling.
>> [Mon May 09 22:11:54 2011].713000 mapserv request processing time (msLoadMap
>> not incl.): 0.047s
>> [Mon May 09 22:11:54 2011].713000 msFreeMap(): freeing map at 0184A9E8.
>>
>>
>>
>>
>>
>>
>> _______________________________________________
>> mapserver-users mailing list
>> [hidden email]
>> http://lists.osgeo.org/mailman/listinfo/mapserver-users
>>
>
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

AW: [mapserver-users] WFS with 6.0.0 Beta RC2

Arnd Wippermann
Hi,

I have also problems with post request

Version 6.0.0 :
with DATA 'shapefile' in the mapfile MapServer found no or not all results,
http://gis.ibbeck.de/ginfo/apps/OLExamples/OL210/MapServer_WFS_Demo/MapServe
r_WFS_Demo.asp?connectionOGR=false&SLDsrcIdx=8

with CONNECTIONTYE ogr and CONNECTION 'shapefile' MapServer works as
expected.
http://gis.ibbeck.de/ginfo/apps/OLExamples/OL210/MapServer_WFS_Demo/MapServe
r_WFS_Demo.asp?connectionOGR=true&SLDsrcIdx=8

Arnd


-----Ursprüngliche Nachricht-----
Von: Alexander Petkov [mailto:[hidden email]]
Gesendet: Montag, 11. Juli 2011 22:45
An: Arnd Wippermann
Cc: [hidden email]
Betreff: Re: [mapserver-users] WFS with 6.0.0 Beta RC2

The interesting thing is that when a GET request is issued with the same
filter, the GML for the feature is returned as expected.
Does anybody have POST GetFeature requests working with Mapserver v6.0.0?

Thanks in advance,
Alex
On Mon, Jul 11, 2011 at 12:34 PM, Alexander Petkov <[hidden email]>
wrote:
> I am getting the same behaviour with Mapserver 6.0.0. Previous 5.6.*
> releases work fine with the same request. I am wondering whether I am
> missing some new required declaration since 6.0.0 was released...
>
> Alex
>
> On Mon, May 9, 2011 at 2:44 PM, Arnd Wippermann <[hidden email]>
wrote:

>> Hi,
>>
>> I'm trying to get WFS working with 6.0.0 Beta RC2.
>>
>> If i use MapServer 5.6.5 a wfs post request returns the features.
>> If I use MapServer 6.0.0 the same post request responses with
>> ...<gml:null>missing</gml:null>.
>>
>> The BBOX coordinates, the mapfile projection and layer is in EPSG:3763.
>> In the WEB METADATA Block is set 'wfs_srs' 'EPSG:3763'
>> There is no reprojection needed.
>>
>> Is there something I have to consider, when using MapServer Version
>> 6.0.0 and WFS.
>>
>> Arnd
>>
>> POST
>>
>> <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS"
>> version="1.0.0" maxFeatures="100">
>> <wfs:Query typeName="default">
>> <ogc:Filter xmlns:ogc="http://www.opengis.net/ogc">
>> <ogc:BBOX>
>> <ogc:PropertyName>msgeometry</ogc:PropertyName>
>> <gml:Box xmlns:gml="http://www.opengis.net/gml" srsName="EPSG:3763">
>> <gml:coordinates decimal="." cs="," ts="
>> ">-535786.68671593,-509560.89777426
>> 559489.72019154,364218.61581997</gml:coordinates>
>> </gml:Box>
>> </ogc:BBOX>
>> </ogc:Filter>
>> </wfs:Query>
>> </wfs:GetFeature>
>>
>> RESPONSE MapServer 5.6.5
>>
>> <?xml version='1.0' encoding="ISO-8859-1" ?> <wfs:FeatureCollection
>>   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
>>   xmlns:wfs="http://www.opengis.net/wfs"
>>   xmlns:gml="http://www.opengis.net/gml"
>>   xmlns:ogc="http://www.opengis.net/ogc"
>>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>   xsi:schemaLocation="http://www.opengis.net/wfs
>> http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd
>>                       http://mapserver.gis.umn.edu/mapserver
>> http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&am
>> p;VERSI
>> ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUT
>> PUTFORM
>> AT=XMLSCHEMA">
>>      <gml:boundedBy>
>>        <gml:Box srsName="EPSG:3763">
>>                <gml:coordinates>-21537.507741,-91486.277029
>> 44944.469424,-56235.046915</gml:coordinates>
>>        </gml:Box>
>>      </gml:boundedBy>
>>    <gml:featureMember>
>>      <ms:default>
>>        <gml:boundedBy>
>>                <gml:Box srsName="EPSG:3763">
>>                        <gml:coordinates>-21441.941044,-67958.139907
>> -11234.384166,-56235.046915</gml:coordinates>
>>                </gml:Box>
>>        </gml:boundedBy>
>>        <ms:msGeometry>
>>        <gml:Polygon srsName="EPSG:3763">
>>          <gml:outerBoundaryIs>
>>            <gml:LinearRing>
>>              <gml:coordinates>-21441.941044,-56235.046915
>> -11234.384166,-56256.314719 -16838.013555,-67958.139907
>> -21441.941044,-56235.046915 </gml:coordinates>
>>            </gml:LinearRing>
>>          </gml:outerBoundaryIs>
>>        </gml:Polygon>
>>        </ms:msGeometry>
>>        <ms:name>No 1</ms:name>
>>        <ms:descriptio>AREA</ms:descriptio>
>>      </ms:default>
>>    </gml:featureMember>
>> ...
>>
>>
>> RESPONSE MapServer 6.0.0
>>
>> <?xml version='1.0' encoding="ISO-8859-1" ?> <wfs:FeatureCollection
>>   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
>>   xmlns:wfs="http://www.opengis.net/wfs"
>>   xmlns:gml="http://www.opengis.net/gml"
>>   xmlns:ogc="http://www.opengis.net/ogc"
>>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>   xsi:schemaLocation="http://www.opengis.net/wfs
>> http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd
>>                       http://mapserver.gis.umn.edu/mapserver
>> http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&am
>> p;VERSI
>> ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUT
>> PUTFORM
>> AT=XMLSCHEMA">
>>   <gml:boundedBy>
>>      <gml:null>missing</gml:null>
>>   </gml:boundedBy>
>> </wfs:FeatureCollection>
>>
>> LOG Entry
>>
>> [Mon May 09 22:11:54 2011].666000 CGI Request 1 on process 3968 [Mon
>> May 09 22:11:54 2011].666000 msQueryByFilter(): Search returned no
>> results. No matching record(s) found.
>> [Mon May 09 22:11:54 2011].713000 msProjectRect(): some points failed
>> to reproject, doing internal sampling.
>> [Mon May 09 22:11:54 2011].713000 mapserv request processing time
>> (msLoadMap not incl.): 0.047s [Mon May 09 22:11:54 2011].713000
>> msFreeMap(): freeing map at 0184A9E8.
>>
>>
>>
>>
>>
>>
>> _______________________________________________
>> mapserver-users mailing list
>> [hidden email]
>> http://lists.osgeo.org/mailman/listinfo/mapserver-users
>>
>

_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: WFS with 6.0.0 Beta RC2

alexander-petkov
Using OGR data connection works with my POST GetFeature requests,
thanks a lot :)

Alex

On Mon, Jul 11, 2011 at 3:48 PM, Arnd Wippermann <[hidden email]> wrote:

> Hi,
>
> I have also problems with post request
>
> Version 6.0.0 :
> with DATA 'shapefile' in the mapfile MapServer found no or not all results,
> http://gis.ibbeck.de/ginfo/apps/OLExamples/OL210/MapServer_WFS_Demo/MapServe
> r_WFS_Demo.asp?connectionOGR=false&SLDsrcIdx=8
>
> with CONNECTIONTYE ogr and CONNECTION 'shapefile' MapServer works as
> expected.
> http://gis.ibbeck.de/ginfo/apps/OLExamples/OL210/MapServer_WFS_Demo/MapServe
> r_WFS_Demo.asp?connectionOGR=true&SLDsrcIdx=8
>
> Arnd
>
>
> -----Ursprüngliche Nachricht-----
> Von: Alexander Petkov [mailto:[hidden email]]
> Gesendet: Montag, 11. Juli 2011 22:45
> An: Arnd Wippermann
> Cc: [hidden email]
> Betreff: Re: [mapserver-users] WFS with 6.0.0 Beta RC2
>
> The interesting thing is that when a GET request is issued with the same
> filter, the GML for the feature is returned as expected.
> Does anybody have POST GetFeature requests working with Mapserver v6.0.0?
>
> Thanks in advance,
> Alex
> On Mon, Jul 11, 2011 at 12:34 PM, Alexander Petkov <[hidden email]>
> wrote:
>> I am getting the same behaviour with Mapserver 6.0.0. Previous 5.6.*
>> releases work fine with the same request. I am wondering whether I am
>> missing some new required declaration since 6.0.0 was released...
>>
>> Alex
>>
>> On Mon, May 9, 2011 at 2:44 PM, Arnd Wippermann <[hidden email]>
> wrote:
>>> Hi,
>>>
>>> I'm trying to get WFS working with 6.0.0 Beta RC2.
>>>
>>> If i use MapServer 5.6.5 a wfs post request returns the features.
>>> If I use MapServer 6.0.0 the same post request responses with
>>> ...<gml:null>missing</gml:null>.
>>>
>>> The BBOX coordinates, the mapfile projection and layer is in EPSG:3763.
>>> In the WEB METADATA Block is set 'wfs_srs' 'EPSG:3763'
>>> There is no reprojection needed.
>>>
>>> Is there something I have to consider, when using MapServer Version
>>> 6.0.0 and WFS.
>>>
>>> Arnd
>>>
>>> POST
>>>
>>> <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" service="WFS"
>>> version="1.0.0" maxFeatures="100">
>>> <wfs:Query typeName="default">
>>> <ogc:Filter xmlns:ogc="http://www.opengis.net/ogc">
>>> <ogc:BBOX>
>>> <ogc:PropertyName>msgeometry</ogc:PropertyName>
>>> <gml:Box xmlns:gml="http://www.opengis.net/gml" srsName="EPSG:3763">
>>> <gml:coordinates decimal="." cs="," ts="
>>> ">-535786.68671593,-509560.89777426
>>> 559489.72019154,364218.61581997</gml:coordinates>
>>> </gml:Box>
>>> </ogc:BBOX>
>>> </ogc:Filter>
>>> </wfs:Query>
>>> </wfs:GetFeature>
>>>
>>> RESPONSE MapServer 5.6.5
>>>
>>> <?xml version='1.0' encoding="ISO-8859-1" ?> <wfs:FeatureCollection
>>>   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
>>>   xmlns:wfs="http://www.opengis.net/wfs"
>>>   xmlns:gml="http://www.opengis.net/gml"
>>>   xmlns:ogc="http://www.opengis.net/ogc"
>>>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>>   xsi:schemaLocation="http://www.opengis.net/wfs
>>> http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd
>>>                       http://mapserver.gis.umn.edu/mapserver
>>> http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&am
>>> p;VERSI
>>> ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUT
>>> PUTFORM
>>> AT=XMLSCHEMA">
>>>      <gml:boundedBy>
>>>        <gml:Box srsName="EPSG:3763">
>>>                <gml:coordinates>-21537.507741,-91486.277029
>>> 44944.469424,-56235.046915</gml:coordinates>
>>>        </gml:Box>
>>>      </gml:boundedBy>
>>>    <gml:featureMember>
>>>      <ms:default>
>>>        <gml:boundedBy>
>>>                <gml:Box srsName="EPSG:3763">
>>>                        <gml:coordinates>-21441.941044,-67958.139907
>>> -11234.384166,-56235.046915</gml:coordinates>
>>>                </gml:Box>
>>>        </gml:boundedBy>
>>>        <ms:msGeometry>
>>>        <gml:Polygon srsName="EPSG:3763">
>>>          <gml:outerBoundaryIs>
>>>            <gml:LinearRing>
>>>              <gml:coordinates>-21441.941044,-56235.046915
>>> -11234.384166,-56256.314719 -16838.013555,-67958.139907
>>> -21441.941044,-56235.046915 </gml:coordinates>
>>>            </gml:LinearRing>
>>>          </gml:outerBoundaryIs>
>>>        </gml:Polygon>
>>>        </ms:msGeometry>
>>>        <ms:name>No 1</ms:name>
>>>        <ms:descriptio>AREA</ms:descriptio>
>>>      </ms:default>
>>>    </gml:featureMember>
>>> ...
>>>
>>>
>>> RESPONSE MapServer 6.0.0
>>>
>>> <?xml version='1.0' encoding="ISO-8859-1" ?> <wfs:FeatureCollection
>>>   xmlns:ms="http://mapserver.gis.umn.edu/mapserver"
>>>   xmlns:wfs="http://www.opengis.net/wfs"
>>>   xmlns:gml="http://www.opengis.net/gml"
>>>   xmlns:ogc="http://www.opengis.net/ogc"
>>>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>>   xsi:schemaLocation="http://www.opengis.net/wfs
>>> http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd
>>>                       http://mapserver.gis.umn.edu/mapserver
>>> http://dir/mapserv.exe?map=mapfile&amp;Service=WFS&amp;SERVICE=WFS&am
>>> p;VERSI
>>> ON=1.0.0&amp;REQUEST=DescribeFeatureType&amp;TYPENAME=default&amp;OUT
>>> PUTFORM
>>> AT=XMLSCHEMA">
>>>   <gml:boundedBy>
>>>      <gml:null>missing</gml:null>
>>>   </gml:boundedBy>
>>> </wfs:FeatureCollection>
>>>
>>> LOG Entry
>>>
>>> [Mon May 09 22:11:54 2011].666000 CGI Request 1 on process 3968 [Mon
>>> May 09 22:11:54 2011].666000 msQueryByFilter(): Search returned no
>>> results. No matching record(s) found.
>>> [Mon May 09 22:11:54 2011].713000 msProjectRect(): some points failed
>>> to reproject, doing internal sampling.
>>> [Mon May 09 22:11:54 2011].713000 mapserv request processing time
>>> (msLoadMap not incl.): 0.047s [Mon May 09 22:11:54 2011].713000
>>> msFreeMap(): freeing map at 0184A9E8.
>>>
>>>
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> mapserver-users mailing list
>>> [hidden email]
>>> http://lists.osgeo.org/mailman/listinfo/mapserver-users
>>>
>>
>
>
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users