WFS to shp

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

WFS to shp

Milena Nowotarska
Hello Developers,

playing with QGIS I saved a WFS layer to shapefile and noticed that
not all the features are present on the new shp layer.
I was using http://webservices.ionicsoft.com/unData/wfs/UN , layer
COUNTRY, saved it to country1.shp, as shown on attached printscreen.

I have no idea if that is WFS itself or the plugin problem, but
thought you might be interested :)
Made 3 tries, also loaded WMS layer again and the result was the same,
lit. the same features were missing.

Milena

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer

wfstoshp.PNG (59K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: WFS to shp

Giovanni Manghi
Hi,
it happens also if the source is a postgis layer, I know because I
noticed the same behavior while setting up a wfs server with sources
of different types. But it happens also with other desktop clients but
not always (sometimes they show correctly all the features where qgis
don't)... so I'm not sure is a qgis problem.
If someone want investigate further I can provide a wfs sever address
and source data in shp format.

-- Giovanni --

On Fri, May 29, 2009 at 12:33 AM, Milena Nowotarska
<[hidden email]> wrote:

> Hello Developers,
>
> playing with QGIS I saved a WFS layer to shapefile and noticed that
> not all the features are present on the new shp layer.
> I was using http://webservices.ionicsoft.com/unData/wfs/UN , layer
> COUNTRY, saved it to country1.shp, as shown on attached printscreen.
>
> I have no idea if that is WFS itself or the plugin problem, but
> thought you might be interested :)
> Made 3 tries, also loaded WMS layer again and the result was the same,
> lit. the same features were missing.
>
> Milena
>
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-developer
>
>
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

AW: WFS to shp

Hugentobler  Marco
In reply to this post by Milena Nowotarska
Hi Milena

This is fixed now in recent commits.
The problem was that those features had missing attributes, but the shapefile export rejects attributes with missing types. So now the wfs provider detects those cases and inserts empty strings for missing attribute values.

Regards,
Marco


-----Urspr√ľngliche Nachricht-----
Von: [hidden email] im Auftrag von Milena Nowotarska
Gesendet: Fr 29.05.2009 01:33
An: [hidden email]
Betreff: [Qgis-developer] WFS to shp
 
Hello Developers,

playing with QGIS I saved a WFS layer to shapefile and noticed that
not all the features are present on the new shp layer.
I was using http://webservices.ionicsoft.com/unData/wfs/UN , layer
COUNTRY, saved it to country1.shp, as shown on attached printscreen.

I have no idea if that is WFS itself or the plugin problem, but
thought you might be interested :)
Made 3 tries, also loaded WMS layer again and the result was the same,
lit. the same features were missing.

Milena

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer