WFS plugin under linux

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

WFS plugin under linux

Yves Jacolin
Hello,

I would like to test the WFS plugin under Linux. I build QGIS (SVN version)
and success (I think) to install it : the WFS plugin appear in the plugin
list, I enabled it but nothing appears : no new item or icone.

Does the WFS plugin can be used under linux? How can I use it?

Thanks,

Y.
--
Yves Jacolin
-------------
http://yjacolin.gloobe.org
http://softlibre.gloobe.org
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: WFS plugin under linux

Hugentobler  Marco
Hi Yves,

WFS plugin works on Linux out of the box (at least it does for me). Are you
sure the application picks the right plugin library? It looks as if loading
of the plugin fails. Could you paste the output of 'ldd libwfsplugin.so ' ?

Regards,
Marco

Am Samstag, 24. März 2007 11:02 schrieb Yves Jacolin:

> Hello,
>
> I would like to test the WFS plugin under Linux. I build QGIS (SVN version)
> and success (I think) to install it : the WFS plugin appear in the plugin
> list, I enabled it but nothing appears : no new item or icone.
>
> Does the WFS plugin can be used under linux? How can I use it?
>
> Thanks,
>
> Y.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: WFS plugin under linux

pcav
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I confirm, it works out of the box, both for packaged (debian) and
self-compiled qgis.
pc

Marco Hugentobler ha scritto:
> Hi Yves,
>
> WFS plugin works on Linux out of the box (at least it does for me). Are you
> sure the application picks the right plugin library? It looks as if loading
> of the plugin fails. Could you paste the output of 'ldd libwfsplugin.so ' ?
>
> Regards,
> Marco
- --
Paolo Cavallini
email+jabber: [hidden email] PGP: http://www.faunalia.it/pgp/
www.faunalia.it
Piazza Garibaldi 5 - 56025 Pontedera (PI), Italy   Tel: (+39)348-3801953
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGBWlf/NedwLUzIr4RAlGYAJsFnbJOcCgP8t1qbtZ+23LQq3H8pgCghq6q
TQ2+tuRtYffr5053Qw1SmWk=
=nbIA
-----END PGP SIGNATURE-----
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: WFS plugin under linux

Yves Jacolin
In reply to this post by Hugentobler Marco
Le Samedi 24 Mars 2007 15:44, Marco Hugentobler a écrit :

> Hi Yves,
>
> WFS plugin works on Linux out of the box (at least it does for me). Are you
> sure the application picks the right plugin library? It looks as if loading
> of the plugin fails. Could you paste the output of 'ldd libwfsplugin.so ' ?
>
> Regards,
> Marco
>
> Am Samstag, 24. März 2007 11:02 schrieb Yves Jacolin:
> > Hello,
> >
> > I would like to test the WFS plugin under Linux. I build QGIS (SVN
> > version) and success (I think) to install it : the WFS plugin appear in
> > the plugin list, I enabled it but nothing appears : no new item or icone.
> >
> > Does the WFS plugin can be used under linux? How can I use it?
> >
> > Thanks,
> >
> > Y.
Hi,

Here more information:
* when building qgis with cmake I use this command: /usr/local/cmake/bin/cmake
-DQT_QMAKE_EXECUTABLE:=/usr/local/Trolltech/Qt-4.2.2/bin/qmake
-DGRASS_PREFIX:=/usr/local/grass-6.2.1/
* I build the wfs plugin and copy the file in the /usr/lib/qgis/
* the ldd libwfsplugin.so command only give information when I am in
the /usr/lib/qgis/:
linux-gate.so.1 =>  (0xffffe000)
        libQt3Support.so.4
=> /usr/local/Trolltech/Qt-4.2.2/lib/libQt3Support.so.4 (0xb7c8c000)
        libQtSvg.so.4 => /usr/local/Trolltech/Qt-4.2.2/lib/libQtSvg.so.4
(0xb7c46000)
        libQtGui.so.4 => /usr/local/Trolltech/Qt-4.2.2/lib/libQtGui.so.4
(0xb7582000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0xb7579000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0xb7560000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0xb7558000)
        libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0xb754f000)
        libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0xb754b000)
        libXcursor.so.1 => /usr/X11R6/lib/libXcursor.so.1 (0xb7542000)
        libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0xb753f000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0xb7530000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xb7464000)
        libQtXml.so.4 => /usr/local/Trolltech/Qt-4.2.2/lib/libQtXml.so.4
(0xb7422000)
        libQtNetwork.so.4
=> /usr/local/Trolltech/Qt-4.2.2/lib/libQtNetwork.so.4 (0xb73c7000)
        libQtCore.so.4 => /usr/local/Trolltech/Qt-4.2.2/lib/libQtCore.so.4
(0xb7246000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb7214000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7210000)
        libqgis_core.so
=> /mnt/data2/SIG/Qgis/qgis_unstable/src/core/libqgis_core.so (0xb7034000)
        libqgis_gui.so
=> /mnt/data2/SIG/Qgis/qgis_unstable/src/gui/libqgis_gui.so (0xb6fe8000)
        libproj.so.0 => /usr/local/lib/libproj.so.0 (0xb6fb3000)
        libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xb6f60000)
        libgeos.so.2 => /usr/local/lib/libgeos.so.2 (0xb6e66000)
        libgdal.so.1 => /usr/local/lib/libgdal.so.1 (0xb6930000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6854000)
        libm.so.6 => /lib/tls/libm.so.6 (0xb682f000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb6824000)
        libc.so.6 => /lib/tls/libc.so.6 (0xb66f2000)
        libQtSql.so.4 => /usr/local/Trolltech/Qt-4.2.2/lib/libQtSql.so.4
(0xb66ba000)
        libpng.so.3 => /usr/local/lib/libpng.so.3 (0xb6695000)
        libXfixes.so.3 => /usr/X11R6/lib/libXfixes.so.3 (0xb6690000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6627000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb65f7000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb65e4000)
        libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0xb6561000)
        /lib/ld-linux.so.2 (0x80000000)
        libgeos_c.so.1 => /usr/local/lib/libgeos_c.so.1 (0xb6554000)
        libodbc.so.1 => /usr/lib/libodbc.so.1 (0xb64eb000)
        libodbcinst.so.1 => /usr/lib/libodbcinst.so.1 (0xb64d9000)
        libNCSEcw.so.0 => /usr/local/lib/libNCSEcw.so.0 (0xb63a6000)
        libNCSCnet.so.0 => /usr/local/lib/libNCSCnet.so.0 (0xb6392000)
        libNCSUtil.so.0 => /usr/local/lib/libNCSUtil.so.0 (0xb6371000)
        libjasper-1.701.so.1 => /usr/lib/libjasper-1.701.so.1 (0xb6325000)
        libogdi31.so => /usr/local/lib/libogdi31.so (0xb6307000)
        libungif.so.4 => /usr/lib/libungif.so.4 (0xb62fe000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb62de000)
        libgeotiff.so.1.2.2 => /usr/lib/libgeotiff.so.1.2.2 (0xb610e000)
        libtiff.so.3 => /usr/lib/libtiff.so.3 (0xb60be000)
        libpng12.so.0 => /usr/local/lib/libpng12.so.0 (0xb609b000)
        libpq.so.4 => /usr/lib/libpq.so.4 (0xb607f000)
        librt.so.1 => /lib/tls/librt.so.1 (0xb6075000)
        libcurl.so.3 => /usr/lib/libcurl.so.3 (0xb6034000)
        libidn.so.11 => /usr/lib/libidn.so.11 (0xb6004000)
        libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0xb5fd3000)
        libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0xb5ec9000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0xb5ea8000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0xb5e7a000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb5e68000)
        libnsl.so.1 => /lib/libnsl.so.1 (0xb5e54000)

Thanks for your hlep,

Y.

--
Yves Jacolin
-------------
http://yjacolin.gloobe.org
http://softlibre.gloobe.org
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: WFS plugin under linux

Yves Jacolin
In reply to this post by pcav
Well, I build again my source, and I find this error withe the cMake :
providers/wfs : -Werror removed for qgswfsprovider.cpp for now - please get
rid of any compiler warnings!

My command:
/usr/local/cmake/bin/cmake
-DQT_QMAKE_EXECUTABLE:=/usr/local/Trolltech/Qt-4.2.2/bin/qmake
-DGRASS_PREFIX:=/usr/local/grass-6.2.1/

Thanks,

This error occurs in a ubuntu distrib as well. Mine is a mandriva 2006.

Y.
Le Samedi 24 Mars 2007 19:10, Paolo Cavallini a écrit :

> I confirm, it works out of the box, both for packaged (debian) and
> self-compiled qgis.
> pc
>
> Marco Hugentobler ha scritto:
> > Hi Yves,
> >
> > WFS plugin works on Linux out of the box (at least it does for me). Are
> > you sure the application picks the right plugin library? It looks as if
> > loading of the plugin fails. Could you paste the output of 'ldd
> > libwfsplugin.so ' ?
> >
> > Regards,
> > Marco

--
Yves Jacolin
-------------
http://yjacolin.gloobe.org
http://softlibre.gloobe.org
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: WFS plugin under linux

Gavin Macaulay-2
Yves,

That is a warning, not an error and will not stop you compiling qgis.

Gavin

Yves Jacolin wrote:

> Well, I build again my source, and I find this error withe the cMake :
> providers/wfs : -Werror removed for qgswfsprovider.cpp for now - please get
> rid of any compiler warnings!
>
> My command:
> /usr/local/cmake/bin/cmake
> -DQT_QMAKE_EXECUTABLE:=/usr/local/Trolltech/Qt-4.2.2/bin/qmake
> -DGRASS_PREFIX:=/usr/local/grass-6.2.1/
>
> Thanks,
>
> This error occurs in a ubuntu distrib as well. Mine is a mandriva 2006.
>
> Y.
> Le Samedi 24 Mars 2007 19:10, Paolo Cavallini a écrit :
>> I confirm, it works out of the box, both for packaged (debian) and
>> self-compiled qgis.
>> pc
>>
>> Marco Hugentobler ha scritto:
>>> Hi Yves,
>>>
>>> WFS plugin works on Linux out of the box (at least it does for me). Are
>>> you sure the application picks the right plugin library? It looks as if
>>> loading of the plugin fails. Could you paste the output of 'ldd
>>> libwfsplugin.so ' ?
>>>
>>> Regards,
>>> Marco
>

_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: WFS plugin under linux

Yves Jacolin
Hello,

Indeed, my compilation doesn't stop, but the WFS plugin does not appear when I
enabled it in the plugin list. I would like to test it.

Have you got an idea why icons and menu don't appear ?

Regards,

Y.
Le Mardi 27 Mars 2007 02:46, gavin macaulay a écrit :

> Yves,
>
> That is a warning, not an error and will not stop you compiling qgis.
>
> Gavin
>
> Yves Jacolin wrote:
> > Well, I build again my source, and I find this error withe the cMake :
> > providers/wfs : -Werror removed for qgswfsprovider.cpp for now - please
> > get rid of any compiler warnings!
> >
> > My command:
> > /usr/local/cmake/bin/cmake
> > -DQT_QMAKE_EXECUTABLE:=/usr/local/Trolltech/Qt-4.2.2/bin/qmake
> > -DGRASS_PREFIX:=/usr/local/grass-6.2.1/
> >
> > Thanks,
> >
> > This error occurs in a ubuntu distrib as well. Mine is a mandriva 2006.
> >
> > Y.
> >
> > Le Samedi 24 Mars 2007 19:10, Paolo Cavallini a écrit :
> >> I confirm, it works out of the box, both for packaged (debian) and
> >> self-compiled qgis.
> >> pc
> >>
> >> Marco Hugentobler ha scritto:
> >>> Hi Yves,
> >>>
> >>> WFS plugin works on Linux out of the box (at least it does for me). Are
> >>> you sure the application picks the right plugin library? It looks as if
> >>> loading of the plugin fails. Could you paste the output of 'ldd
> >>> libwfsplugin.so ' ?
> >>>
> >>> Regards,
> >>> Marco

--
Yves Jacolin
---
http://yjacolin.gloobe.org
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user