VectorLayerDefinition opacity doesn't work

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

VectorLayerDefinition opacity doesn't work

gary
Hi All,
LayerDefinition Schemas describe 「Opacity」 at which to display the rendered
data
but i VectorLayerDefinition opacity doesn't work
and 「Opacity」 not available in maestro

https://github.com/jumpinjackie/mapguide-maestro/blob/0414780364c9852865a460d0df3f3c658a547042/OSGeo.MapGuide.MaestroAPI/Schemas/LayerDefinition-1.0.0.xsd

<http://osgeo-org.1560.x6.nabble.com/file/t382458/LayerDefinition_p123.png>



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: VectorLayerDefinition opacity doesn't work

Jackie Ng
Hmm, I looked at the server rendering code to see where layer definition
opacity is actually used and I got ... nothing. So that's why nothing's
happening.

- Jackie



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: VectorLayerDefinition opacity doesn't work

gary
thanks for your reply Jackie .

the 「Opacity」 will be implemented or not in feature plan?
In my case, symbol layer can set opacity in openlayer ,
but i want coordinate data do not send to client side.

each layer can set Opacity in openlayer
https://openlayers.org/en/latest/apidoc/ol.layer.Base.html#setOpacity



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: VectorLayerDefinition opacity doesn't work

Jackie Ng
There are no current plans to implement server-side layer opacity.

- Jackie



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users