Vagrant VMs for OSSIM / OMAR - missing services

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Vagrant VMs for OSSIM / OMAR - missing services

Jo Walsh-4
dear OSSIM community,

I'm trying to evaluate OMAR and having difficulty with the Vagrant VM version of the OMAR web services.
I hope the OSSIM list may also be the right forum for OMAR questions.

https://github.com/ossimlabs/ossim-vagrant

I can 'vagrant up' and bring up the collection of VMs; however when I visit http://192.168.2.200/omar-app/omar on the HTTP server I get Service Temporarily Unavailable. I see in /etc/httpd/conf.d that the webserver is trying to proxy requests to port 8080 on the OMAR VM - 192.168.2.120 - but when I "vagrant ssh omarApp" and run netstat as root, i don't see anything connected to port 8080. 

I wondered whether the salt stage had failed - it certainly seemed to hang for a long time on initially bringing up the VMs - and how i'd check or re-initialise that.

Any pointers would be much appreciated. 

While I'm here, I remain confused as to how the radiantblue github repos and the ossimlabs github repos for OSSIM/OMAR are related?

cheers,


Jo




------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Vagrant VMs for OSSIM / OMAR - missing services

Garrett Potts-5
Hello Jo:

I am not sure how far master is off from DEV.  I have not merged the DEV branch into master lately.   Usually done about once a week.

You can "git checkout dev” and try to bring up the machines again.  It will take a while for it downloads the image first time and then after that it will load the sal-call then it will setup the RPM’s on each box.   The java RPMS are a fat jar and the RPM could be “big” and take a little while per machine.  Depends on the net connection.

Here is the main docs for what the vagrant is installing: http://ossimlabs.s3-website-us-east-1.amazonaws.com/omardocs/

Take care

Garrett
 

On Jun 9, 2016, at 5:12 AM, Jo Walsh <[hidden email]> wrote:

dear OSSIM community,

I'm trying to evaluate OMAR and having difficulty with the Vagrant VM version of the OMAR web services.
I hope the OSSIM list may also be the right forum for OMAR questions.

https://github.com/ossimlabs/ossim-vagrant

I can 'vagrant up' and bring up the collection of VMs; however when I visit http://192.168.2.200/omar-app/omar on the HTTP server I get Service Temporarily Unavailable. I see in /etc/httpd/conf.d that the webserver is trying to proxy requests to port 8080 on the OMAR VM - 192.168.2.120 - but when I "vagrant ssh omarApp" and run netstat as root, i don't see anything connected to port 8080. 

I wondered whether the salt stage had failed - it certainly seemed to hang for a long time on initially bringing up the VMs - and how i'd check or re-initialise that.

Any pointers would be much appreciated. 

While I'm here, I remain confused as to how the radiantblue github repos and the ossimlabs github repos for OSSIM/OMAR are related?

cheers,


Jo



------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer


------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Vagrant VMs for OSSIM / OMAR - missing services

Jo Walsh-4
Garrett, thank you for your response!

I did check out the dev branch before running 'vagrant up'. (Following the instructions at https://github.com/ossimlabs/ossim-vagrant)

Included below the output I see for salt while running 'vagrant up'- does this look healthy? The process hangs for a period of quite a few minutes after "Calling state.highstate in local mode... (this may take a while)". 

I tried running salt-call manually with the init.sls that I found for the appropriate service in /srv/salt and I see complaints about DNS errors for the salt master. Oddly this doesn't seem to be happening on the httpd host. 

[vagrant@wms-app log]$ sudo salt-call /srv/salt/wmsApp/init.sls

[ERROR   ] DNS lookup of 'salt' failed.

[ERROR   ] Master hostname: 'salt' not found. Retrying in 30 seconds

... in /var/log/messages on hosts other than httpd I keep seeing the same errors in /var/log/messages

Jun  9 10:53:15 wms-app salt-minion: [ERROR   ] DNS lookup of 'salt' failed.

Jun  9 10:53:15 wms-app salt-minion: [ERROR   ] Master hostname: 'salt' not found. Retrying in 30 seconds

If I go into /etc/hosts and add 'salt' as an alias for localhost then salt-call gets as far as this before appearing to hang; but I'm not at all sure that this is the right thing to do, unsure what I'm doing with salt, I wasn't familiar with it before today :/

[INFO    ] Generating keys: /etc/salt/pki/minion 

Output from 'vagrant up':

==> wmtsApp: Running provisioner: salt...

Checking if salt-minion is installed

salt-minion was not found.

Checking if salt-call is installed

salt-call was not found.

Bootstrapping Salt... (this may take a while)

Salt successfully installed!

run_overstate set to false. Not running state.overstate.

Calling state.highstate in local mode... (this may take a while)

orchestrate is nil. Not running state.orchestrate.

I'll give the direct install from RPMs a go, but the vagrant setup did look really useful for getting one's head around OMAR...

cheers,


Jo


On Thu, Jun 9, 2016 at 2:51 PM, Potts, Garrett <[hidden email]> wrote:
Hello Jo:

I am not sure how far master is off from DEV.  I have not merged the DEV branch into master lately.   Usually done about once a week.

You can "git checkout dev” and try to bring up the machines again.  It will take a while for it downloads the image first time and then after that it will load the sal-call then it will setup the RPM’s on each box.   The java RPMS are a fat jar and the RPM could be “big” and take a little while per machine.  Depends on the net connection.

Here is the main docs for what the vagrant is installing: http://ossimlabs.s3-website-us-east-1.amazonaws.com/omardocs/

Take care

Garrett
 

On Jun 9, 2016, at 5:12 AM, Jo Walsh <[hidden email]> wrote:

dear OSSIM community,

I'm trying to evaluate OMAR and having difficulty with the Vagrant VM version of the OMAR web services.
I hope the OSSIM list may also be the right forum for OMAR questions.

https://github.com/ossimlabs/ossim-vagrant

I can 'vagrant up' and bring up the collection of VMs; however when I visit http://192.168.2.200/omar-app/omar on the HTTP server I get Service Temporarily Unavailable. I see in /etc/httpd/conf.d that the webserver is trying to proxy requests to port 8080 on the OMAR VM - 192.168.2.120 - but when I "vagrant ssh omarApp" and run netstat as root, i don't see anything connected to port 8080. 

I wondered whether the salt stage had failed - it certainly seemed to hang for a long time on initially bringing up the VMs - and how i'd check or re-initialise that.

Any pointers would be much appreciated. 

While I'm here, I remain confused as to how the radiantblue github repos and the ossimlabs github repos for OSSIM/OMAR are related?

cheers,


Jo



------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer



------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Vagrant VMs for OSSIM / OMAR - missing services

Garrett Potts-5
Hello Jo:

Seems you are having problems with vagrant auto salt installation.   I have never had that before.  We have had several people try it and the only errors we sometimes get is when we are updating the yum repo at the same time the vagrant is provisioning the machine.  I would remove the salt from /etc/hosts file and try it again but do it at a smaller scale by just doing a :

vagrant up postgres


And just try to bring up one machine.


If not you can follow the salt configuration to do the machines manually by disabling the salt in the machine definition and then just bring it up and ssh into the machine.

Take care


Garrett

On Jun 9, 2016, at 11:17 AM, Jo Walsh <[hidden email]> wrote:

Garrett, thank you for your response!

I did check out the dev branch before running 'vagrant up'. (Following the instructions at https://github.com/ossimlabs/ossim-vagrant)

Included below the output I see for salt while running 'vagrant up'- does this look healthy? The process hangs for a period of quite a few minutes after "Calling state.highstate in local mode... (this may take a while)". 

I tried running salt-call manually with the init.sls that I found for the appropriate service in /srv/salt and I see complaints about DNS errors for the salt master. Oddly this doesn't seem to be happening on the httpd host. 

[vagrant@wms-app log]$ sudo salt-call /srv/salt/wmsApp/init.sls

[ERROR   ] DNS lookup of 'salt' failed.

[ERROR   ] Master hostname: 'salt' not found. Retrying in 30 seconds

... in /var/log/messages on hosts other than httpd I keep seeing the same errors in /var/log/messages

Jun  9 10:53:15 wms-app salt-minion: [ERROR   ] DNS lookup of 'salt' failed.

Jun  9 10:53:15 wms-app salt-minion: [ERROR   ] Master hostname: 'salt' not found. Retrying in 30 seconds

If I go into /etc/hosts and add 'salt' as an alias for localhost then salt-call gets as far as this before appearing to hang; but I'm not at all sure that this is the right thing to do, unsure what I'm doing with salt, I wasn't familiar with it before today :/

[INFO    ] Generating keys: /etc/salt/pki/minion 

Output from 'vagrant up':

==> wmtsApp: Running provisioner: salt...

Checking if salt-minion is installed

salt-minion was not found.

Checking if salt-call is installed

salt-call was not found.

Bootstrapping Salt... (this may take a while)

Salt successfully installed!

run_overstate set to false. Not running state.overstate.

Calling state.highstate in local mode... (this may take a while)

orchestrate is nil. Not running state.orchestrate.

I'll give the direct install from RPMs a go, but the vagrant setup did look really useful for getting one's head around OMAR...

cheers,


Jo


On Thu, Jun 9, 2016 at 2:51 PM, Potts, Garrett <[hidden email]> wrote:
Hello Jo:

I am not sure how far master is off from DEV.  I have not merged the DEV branch into master lately.   Usually done about once a week.

You can "git checkout dev” and try to bring up the machines again.  It will take a while for it downloads the image first time and then after that it will load the sal-call then it will setup the RPM’s on each box.   The java RPMS are a fat jar and the RPM could be “big” and take a little while per machine.  Depends on the net connection.

Here is the main docs for what the vagrant is installing: http://ossimlabs.s3-website-us-east-1.amazonaws.com/omardocs/

Take care

Garrett
 

On Jun 9, 2016, at 5:12 AM, Jo Walsh <[hidden email]> wrote:

dear OSSIM community,

I'm trying to evaluate OMAR and having difficulty with the Vagrant VM version of the OMAR web services.
I hope the OSSIM list may also be the right forum for OMAR questions.

https://github.com/ossimlabs/ossim-vagrant

I can 'vagrant up' and bring up the collection of VMs; however when I visit http://192.168.2.200/omar-app/omar on the HTTP server I get Service Temporarily Unavailable. I see in /etc/httpd/conf.d that the webserver is trying to proxy requests to port 8080 on the OMAR VM - 192.168.2.120 - but when I "vagrant ssh omarApp" and run netstat as root, i don't see anything connected to port 8080. 

I wondered whether the salt stage had failed - it certainly seemed to hang for a long time on initially bringing up the VMs - and how i'd check or re-initialise that.

Any pointers would be much appreciated. 

While I'm here, I remain confused as to how the radiantblue github repos and the ossimlabs github repos for OSSIM/OMAR are related?

cheers,


Jo



------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer


------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer


------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Loading...