Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

naresh
Dear All,

I have deployed the GeoNode 2.4 version by following  the instructions


ISSUE : When I am uploading shapefile(polygon), it is taking the default point SLD. Hence when I am viewing the Uploaded Shapfeil(polygon) as WMS in Map/Layer View , it is displaying as point.

Kindly help me to resolve this issue. 

GeoNode Deployed system configuration are

OS:RHEL 7.2, 64 bit , GeoNode2.4 version

Please let me know any other information required further to understand the issue.

Thanks&Regards,
Naresh.N

_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users
Reply | Threaded
Open this post in threaded view
|

Re: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

Stefan Steiniger
Hi,

In geoserver you should be able to assign whatever custom made sld file tova layer. If that solution is ok, although perhaps annoying if one does it for each upload.

Cheers
Stefan



On Mon, Apr 8, 2019, 07:29 Naresh N, <[hidden email]> wrote:
Dear All,

I have deployed the GeoNode 2.4 version by following  the instructions


ISSUE : When I am uploading shapefile(polygon), it is taking the default point SLD. Hence when I am viewing the Uploaded Shapfeil(polygon) as WMS in Map/Layer View , it is displaying as point.

Kindly help me to resolve this issue. 

GeoNode Deployed system configuration are

OS:RHEL 7.2, 64 bit , GeoNode2.4 version

Please let me know any other information required further to understand the issue.

Thanks&Regards,
Naresh.N
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users

_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users
Reply | Threaded
Open this post in threaded view
|

Re: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

naresh
In reply to this post by naresh
Hello All,
Thanks for responding. Please find the attached Shapefile of polygon. After Uploading any shapfiile of type polygon/line, in GeoNode Map/Layer viewer, only point is visible. I have verified the code/db, the issue is point SLD is applied for uploaded data independent of feature type . And also in Layer/Map Viewer ---> EDIT --> CREATE option is disabled.

Please kindly help us in GeoNode which part of code/file verifies feature/Geometry type(Polygon/lIne/point) of Shapefile and assigns corresponding default SLD  

Kindly help us to resolve the issues


Thanks&Regards,
Naresh.N

On Tue, Apr 9, 2019 at 2:58 AM juliermeopensourcedeveloper [via OSGeo.org] <[hidden email]> wrote:
Hi Naresh,
Could you provide the shapefile you are having problem?
Kind regards
Julierme

On Mon, 8 Apr 2019 at 08:28 Naresh N <[hidden email]> wrote:
Dear All,

I have deployed the GeoNode 2.4 version by following  the instructions


ISSUE : When I am uploading shapefile(polygon), it is taking the default point SLD. Hence when I am viewing the Uploaded Shapfeil(polygon) as WMS in Map/Layer View , it is displaying as point.

Kindly help me to resolve this issue. 

GeoNode Deployed system configuration are

OS:RHEL 7.2, 64 bit , GeoNode2.4 version

Please let me know any other information required further to understand the issue.

Thanks&Regards,
Naresh.N
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



To unsubscribe from GeoNode, click here.
NAML

_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users

4-9-2019-7696297.zip (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

juliermeopensourcedeveloper
Hi Naresh,

Thank you for providing the shapefile. Your shapefile is actually a polygon feature type. Open it in QGis and you will see that. What is making you a little bit confuse is the feature scale. For small scale, your polygon looks like a point feature, but it is actually a polygon.

I hope it helps

Julierme

On Tue, Apr 9, 2019 at 7:34 AM Naresh N <[hidden email]> wrote:
Hello All,
Thanks for responding. Please find the attached Shapefile of polygon. After Uploading any shapfiile of type polygon/line, in GeoNode Map/Layer viewer, only point is visible. I have verified the code/db, the issue is point SLD is applied for uploaded data independent of feature type . And also in Layer/Map Viewer ---> EDIT --> CREATE option is disabled.

Please kindly help us in GeoNode which part of code/file verifies feature/Geometry type(Polygon/lIne/point) of Shapefile and assigns corresponding default SLD  

Kindly help us to resolve the issues


Thanks&Regards,
Naresh.N

On Tue, Apr 9, 2019 at 2:58 AM juliermeopensourcedeveloper [via OSGeo.org] <[hidden email]> wrote:
Hi Naresh,
Could you provide the shapefile you are having problem?
Kind regards
Julierme

On Mon, 8 Apr 2019 at 08:28 Naresh N <[hidden email]> wrote:
Dear All,

I have deployed the GeoNode 2.4 version by following  the instructions


ISSUE : When I am uploading shapefile(polygon), it is taking the default point SLD. Hence when I am viewing the Uploaded Shapfeil(polygon) as WMS in Map/Layer View , it is displaying as point.

Kindly help me to resolve this issue. 

GeoNode Deployed system configuration are

OS:RHEL 7.2, 64 bit , GeoNode2.4 version

Please let me know any other information required further to understand the issue.

Thanks&Regards,
Naresh.N
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



To unsubscribe from GeoNode, click here.
NAML
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users

_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users
Reply | Threaded
Open this post in threaded view
|

Re: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

Jose Cáceres
In reply to this post by naresh
Hi Naresh,

As mentioned by Julierme, you feature is a polygon, and I can edit it just fine in a Geonode deploy, so I don't think that the problem you are having is related to the shapefile. You can see it on a map in here:


Kind regards, 



Mailtrack Remitente notificado con
Mailtrack 09/04/19 11:49:16

On Tue, Apr 9, 2019 at 4:34 AM Naresh N <[hidden email]> wrote:
Hello All,
Thanks for responding. Please find the attached Shapefile of polygon. After Uploading any shapfiile of type polygon/line, in GeoNode Map/Layer viewer, only point is visible. I have verified the code/db, the issue is point SLD is applied for uploaded data independent of feature type . And also in Layer/Map Viewer ---> EDIT --> CREATE option is disabled.

Please kindly help us in GeoNode which part of code/file verifies feature/Geometry type(Polygon/lIne/point) of Shapefile and assigns corresponding default SLD  

Kindly help us to resolve the issues


Thanks&Regards,
Naresh.N

On Tue, Apr 9, 2019 at 2:58 AM juliermeopensourcedeveloper [via OSGeo.org] <[hidden email]> wrote:
Hi Naresh,
Could you provide the shapefile you are having problem?
Kind regards
Julierme

On Mon, 8 Apr 2019 at 08:28 Naresh N <[hidden email]> wrote:
Dear All,

I have deployed the GeoNode 2.4 version by following  the instructions


ISSUE : When I am uploading shapefile(polygon), it is taking the default point SLD. Hence when I am viewing the Uploaded Shapfeil(polygon) as WMS in Map/Layer View , it is displaying as point.

Kindly help me to resolve this issue. 

GeoNode Deployed system configuration are

OS:RHEL 7.2, 64 bit , GeoNode2.4 version

Please let me know any other information required further to understand the issue.

Thanks&Regards,
Naresh.N
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



To unsubscribe from GeoNode, click here.
NAML
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users


--
José David Cáceres
Ingeniero Ambiental
Máster en Tecnologías de la Información Geográfica

_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users
Reply | Threaded
Open this post in threaded view
|

Re: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

Jose Cáceres
Hi Naresh,

Just a followed up on my previous email, you need to be logged in, in order to edit a feature layer.

Kind regards,

José



Mailtrack Remitente notificado con
Mailtrack 09/04/19 11:59:24

On Tue, Apr 9, 2019 at 11:51 AM Jose Cáceres <[hidden email]> wrote:
Hi Naresh,

As mentioned by Julierme, you feature is a polygon, and I can edit it just fine in a Geonode deploy, so I don't think that the problem you are having is related to the shapefile. You can see it on a map in here:


Kind regards, 



Mailtrack Remitente notificado con
Mailtrack 09/04/19 11:49:16

On Tue, Apr 9, 2019 at 4:34 AM Naresh N <[hidden email]> wrote:
Hello All,
Thanks for responding. Please find the attached Shapefile of polygon. After Uploading any shapfiile of type polygon/line, in GeoNode Map/Layer viewer, only point is visible. I have verified the code/db, the issue is point SLD is applied for uploaded data independent of feature type . And also in Layer/Map Viewer ---> EDIT --> CREATE option is disabled.

Please kindly help us in GeoNode which part of code/file verifies feature/Geometry type(Polygon/lIne/point) of Shapefile and assigns corresponding default SLD  

Kindly help us to resolve the issues


Thanks&Regards,
Naresh.N

On Tue, Apr 9, 2019 at 2:58 AM juliermeopensourcedeveloper [via OSGeo.org] <[hidden email]> wrote:
Hi Naresh,
Could you provide the shapefile you are having problem?
Kind regards
Julierme

On Mon, 8 Apr 2019 at 08:28 Naresh N <[hidden email]> wrote:
Dear All,

I have deployed the GeoNode 2.4 version by following  the instructions


ISSUE : When I am uploading shapefile(polygon), it is taking the default point SLD. Hence when I am viewing the Uploaded Shapfeil(polygon) as WMS in Map/Layer View , it is displaying as point.

Kindly help me to resolve this issue. 

GeoNode Deployed system configuration are

OS:RHEL 7.2, 64 bit , GeoNode2.4 version

Please let me know any other information required further to understand the issue.

Thanks&Regards,
Naresh.N
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



To unsubscribe from GeoNode, click here.
NAML
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users


--
José David Cáceres
Ingeniero Ambiental
Máster en Tecnologías de la Información Geográfica


--
José David Cáceres
Ingeniero Ambiental
Máster en Tecnologías de la Información Geográfica

_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users
Reply | Threaded
Open this post in threaded view
|

Re: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

naresh
In reply to this post by naresh
Dear All,

kindly help to resolve the issue  'Uploading Shapefile of type polygon/line in GeoNode 2.4  showing as Point Layer in Map/ Viewer section'

Please answer my following  doubts and hep to resolve the issue
1. Is GeoNode 2.4 compatible with PostgreSQL 10.7 and PostGIS 2.5.2
2. Uploaded Shapefile of type Polygon in  PostgreSQL Database table  showing the_geom attribute data type as  as Geometry (PgAdmin4). and even in GeoServer Layer  interface 'the_geom' attribute data type showing as Geometry. How to correct ' the{_geom' attribute data type based on features type in Shapefile . Which part of the code in GeoNode verifies  and assigns the attribute type of Shapefile.

Kindly help me to fix the issue and please let me  know any other information required.


Thanks&Regards,
Naresh.N

On Wed, Apr 10, 2019 at 2:35 PM Naresh N <[hidden email]> wrote:

Dear Simone,

Please kindly see the trailing mail and help me to solve the issue. I have already posted in GeoNode discussion forum, not able to solve the isssue.

Kindly help in this regard.

Thanks&Regards,
Naresh
---------- Forwarded message ---------
From: Naresh N <[hidden email]>
Date: Mon, Apr 8, 2019 at 4:58 PM
Subject: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View
To: geonode-users lists.osgeo.org <[hidden email]>, Alessio Fabiani <[hidden email]>, Simone Dalmasso <[hidden email]>


Dear All,

I have deployed the GeoNode 2.4 version by following  the instructions


ISSUE : When I am uploading shapefile(polygon), it is taking the default point SLD. Hence when I am viewing the Uploaded Shapfeil(polygon) as WMS in Map/Layer View , it is displaying as point.

Kindly help me to resolve this issue. 

GeoNode Deployed system configuration are

OS:RHEL 7.2, 64 bit , GeoNode2.4 version

Please let me know any other information required further to understand the issue.

Thanks&Regards,
Naresh.N

_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users
Reply | Threaded
Open this post in threaded view
|

Re: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View

naresh
Dear Simone/All

Kindly help to resolve the issue 'Uploading Shapefile of type polygon/line in GeoNode 2.4  showing as Point Layer in Map/ Viewer section'

Uploaded Shapefile type of polygon/line though GeoNode Interface, it is displaying features as points.  I could able to understand by debugging the flow of the code, GeoServer(2.7.4) assigning default point SLD for uploaded shapefile of type polygon/line.
Please find the attached screenshot of GeoServer embedded in GeoNode.  It shows the_geom type as Geometry  instead of showing as  Multipolygon/MultiLine.

Please help us to find which is the code responsible in GeoServer/GeoNode decides the_geom type?

Please let me know any other information required further to understand the issue

Note:1. For testing  I have used higher version of GeoServer(2.13.1)  and uploaded shapefile , then the_geom type is showing as expected based on uploaded Shpefile type as  Multipolygon/MultiLine and found no issues. I think it is issue of GeoServer 2.7.4 and PostgresQL 10/PostGIS 2.5.2
         2. Deployed System Details of GeoNode 2.4
              RHEL 7.2, 64 bit
              PostgresQL: 10.0
              PostGIS: 2.5.2
              GeoServer : 2.7.4  ( the geoserver.war file which is packaged with GeoNode is used)


Thanks&Regards,
Naresh.N

On Mon, Apr 15, 2019 at 3:24 PM Naresh N <[hidden email]> wrote:
Dear All,

kindly help to resolve the issue  'Uploading Shapefile of type polygon/line in GeoNode 2.4  showing as Point Layer in Map/ Viewer section'

Please answer my following  doubts and hep to resolve the issue
1. Is GeoNode 2.4 compatible with PostgreSQL 10.7 and PostGIS 2.5.2
2. Uploaded Shapefile of type Polygon in  PostgreSQL Database table  showing the_geom attribute data type as  as Geometry (PgAdmin4). and even in GeoServer Layer  interface 'the_geom' attribute data type showing as Geometry. How to correct ' the{_geom' attribute data type based on features type in Shapefile . Which part of the code in GeoNode verifies  and assigns the attribute type of Shapefile.

Kindly help me to fix the issue and please let me  know any other information required.


Thanks&Regards,
Naresh.N

On Wed, Apr 10, 2019 at 2:35 PM Naresh N <[hidden email]> wrote:

Dear Simone,

Please kindly see the trailing mail and help me to solve the issue. I have already posted in GeoNode discussion forum, not able to solve the isssue.

Kindly help in this regard.

Thanks&Regards,
Naresh
---------- Forwarded message ---------
From: Naresh N <[hidden email]>
Date: Mon, Apr 8, 2019 at 4:58 PM
Subject: Uploading Shapefile(Polygon features) - Displaying as Point in GeoNode Map/layer View
To: geonode-users lists.osgeo.org <[hidden email]>, Alessio Fabiani <[hidden email]>, Simone Dalmasso <[hidden email]>


Dear All,

I have deployed the GeoNode 2.4 version by following  the instructions


ISSUE : When I am uploading shapefile(polygon), it is taking the default point SLD. Hence when I am viewing the Uploaded Shapfeil(polygon) as WMS in Map/Layer View , it is displaying as point.

Kindly help me to resolve this issue. 

GeoNode Deployed system configuration are

OS:RHEL 7.2, 64 bit , GeoNode2.4 version

Please let me know any other information required further to understand the issue.

Thanks&Regards,
Naresh.N

_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users

geonode.PNG (72K) Download Attachment