Upgrade help

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade help

Gal Zsolt
Hello to everybody

I make on upgrade on Linux  from 3.0.6.3 to 3.0.7.4.

Mapbender work but vesion number is same 3.0.6.3, and I don't see my applications.

Where and what I do wrong? 

From the upgrade process, I don't understand the 

# merge parameters.yml, config.yml and if used mapbender.yml

I don't understand how to do this? I copy the old to new but how to merge?

How must I log to Linux to make the upgrade?

I will appreciate any help and thanks for it.

Zsolt



_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade help

Astrid Emde (WhereGroup)
Hello Zsolt,

Am 2018-09-21 06:04, schrieb Gal Zsolt:
> Hello to everybody
>
> I make on upgrade on Linux  from 3.0.6.3 to 3.0.7.4.

Did you follow the upgrade description:
https://doc.mapbender.org/en/installation/update.html


> Mapbender work but vesion number is same 3.0.6.3, and I don't see my
> applications.

If you still use the parameters.yml from your 3.0.6.3 installation you
will find the version number that is defined in the file.

Check parameters.yml-dist file for the version and edit it in your
parameters.yml file.

> Where and what I do wrong?
>
> From the upgrade process, I don't understand the
>
> # merge parameters.yml, config.yml and if used mapbender.yml
>
> I don't understand how to do this? I copy the old to new but how to
> merge?

Check whether there are new variables or definitions in the files. It
always can happen, that we define new variables in the configuration
files. Therefore you have to make sure, that they are in your file
aswell.

> How must I log to Linux to make the upgrade?

see https://doc.mapbender.org/en/installation/update.html

> I will appreciate any help and thanks for it.

Also make sure to
* update your database with app/console doctrine:schema:update --force
* export the web directory app/console assets:install web
* clear cache
* have a look at your application in developer mode app_dev.php
* use F12 to check for errors

Best

Astrid
> Zsolt
> _______________________________________________
> Mapbender_users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_users

--
Mit freundlichen Grüßen

Astrid Emde
Senior GIS-Consultant

************************************************************
INTERGEO 2018
16.- 18. Oktober 2018 in Frankfurt am Main
Treffen Sie die WhereGroup an Stand 12.0A.29 in Halle 12.0
************************************************************

  Astrid Emde
  WhereGroup GmbH & Co.KG
  Eifelstraße 7
  53119 Bonn
  Germany

  Fon: +49(0)228 90 90 38 - 22
  Fax: +49(0)228 90 90 38 - 11

  [hidden email]
  www.wheregroup.com

  Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users