Unable to install PostGIS2 on Cent OS 7

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to install PostGIS2 on Cent OS 7

Jibran Khan

Hello,

 

I have been using Windows based machine for all my work and recently I started using Cent OS 7 Linux based environment. Thus, I am a complete newbie to CentOS based installations.

 

I have been trying to install PostgreSQL 9.5 and PostGIS 2.2 on my new Cent OS 7 (x64) based machine using this link:

 

http://www.postgresonline.com/journal/archives/362-An-almost-idiots-guide-to-install-PostgreSQL-9.5,-PostGIS-2.2-and-pgRouting-2.1.0-with-Yum.html#PostGIS

 

I have installed PostgreSQL 9.5 Server and PgAdmin-III GUI as well as configured it and it all works well. However, I am struggling to install PostGIS 2.2 as I am running into dependencies problems. EPEL repo provides goes version 3.4.2 while Postgis2_95.2.2.2-3.rhel7.x86_64 (pgdg95) requires geos version >= 3.5.0.

 

When I run this command:

 

#yum  install postgis2_95-client.x86_64

 

The persistent error is:

 

--> Finished Dependency Resolution

Error: Package: postgis2_95-2.2.2-3.rhel7.x86_64 (pgdg95)

           Requires: geos >= 3.5.0

           Installed: geos-3.4.2-2.el7.x86_64 (@epel)

               geos = 3.4.2-2.el7

           Available: geos-3.2.2-2.el6.x86_64 (elgis)

               geos = 3.2.2-2.el6

           Available: geos-3.3.0-1.el6.x86_64 (elgis)

               geos = 3.3.0-1.el6

           Available: geos-3.3.1-2.el6.x86_64 (elgis)

               geos = 3.3.1-2.el6

           Available: geos-3.3.6-1_0.el6.x86_64 (elgis)

               geos = 3.3.6-1_0.el6

           Available: geos-3.3.8-2.el6.x86_64 (elgis)

               geos = 3.3.8-2.el6

           Available: geos-3.4.2-1.rhel7.x86_64 (pgdg94)

               geos = 3.4.2-1.rhel7

 

 

Could anyone help me to resolve this error?

 

Thanks in advance!

 

Best,

 

Jibran Khan,

PhD Student,

Atmospheric Modeling Section (ATMO),

Department of Environmental Science (ENVS),

Aarhus University (AU),

Frederiksborgvej 399, P.O. Box 358,

DK-4000 Roskilde, Denmark.

Phone: +45 871 59029

Web: http://pure.au.dk/portal/en/jibran@...

ATMO: http://envs.au.dk/en/about-the-department/sections/atmospheric-modeling/

Google Scholar: https://scholar.google.dk/citations?user=tUffwOIAAAAJ&hl=en

RG: https://www.researchgate.net/profile/Jibran_Khan

Email: [hidden email] ; [hidden email]

 


_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install PostGIS2 on Cent OS 7

Devrim GÜNDÜZ-2

Hi,

On Tue, 2016-10-18 at 15:18 +0000, Jibran Khan wrote:
>
> I have been trying to install PostgreSQL 9.5 and PostGIS 2.2 on my new Cent
> OS 7 (x64) based machine using this link:

<snip>

>                geos = 3.3.8-2.el6
>            Available: geos-3.4.2-1.rhel7.x86_64 (pgdg94)
>                geos = 3.4.2-1.rhel7

I think there is a repo conf problem here. I can't see pgdg95 in the list you
sent, so either it is disabled, or so. Please make sure that you configured
PostgreSQL 9.5 repo correctly.

Regards,

--
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users

signature.asc (836 bytes) Download Attachment