Umstieg MB 2.1 auf 2.2

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Umstieg MB 2.1 auf 2.2

Jäger, Frank (KRZ)
Hallo Leute,
ich beschäftige mich mit der Frage, wie ich von Mapbender 2.1 (MySQL) nach Mapbender 2.2 (PostGIS) umstellen kann, ohne meine Daten zu verlieren.  Wir haben unter 2.1 jede Menge GUIs, User und WMS eingerichtet (für viele Mandanten), die ich gerne weiter benutzen möchte.

Die Start-Version von MB 2.2 mit den 4 GUIs aus dem SQL-Script funktioniert.

Die Übertragung der Daten von MySQL (2.1) nach PostGIS (2.2) habe ich formal inzwischen auch hinbekommen.
Meine Erfahrungen habe ich festgehalten auf:  
http://www.mapbender.org/index.php/Mysql2postgis


Jedoch wird unter MB 2.2 mit den Daten aus MB 2.1 z.B. der "TreeGDE" nicht angezeigt.

Ein mögliche Ursache:

gui_element.e_src:
  alt 2.1: "../html/mod_sync_treefolder.php?sessionID"
  neu 2.2: "../html/mod_sync_treefolder.php?sessionID&e_id_css=treeGDE"
 

Wenn ich aber den neuen Anhang "&e_id_css=treeGDE" in der Admin-GUI ergänze, knallt es:

  Unknown column 'var_type' in 'field list'
  Fatal error: Cannot break/continue 1 level in /data/mbtest/http/php/mod_editElements.php on line 245

Uuuups -
Irgendwie müssen wohl noch Einträge in die neue Tabelle "gui_element_vars" kommen.


Frage:

Gibt es ein Script um die Daten von MB 2.1 für MB 2.2 aufzubereiten?
Wie kann ich sonst vorgehen?
Gibt es ein Release-Wechsel-PHP, das ich noch nicht gefunden habe?
Es kann doch nicht sein, dass man bei jedem Release-Wechsel wieder von vorn beginnt?



Mit freundlichen Grüßen
Frank Jäger

Kommunales Rechenzentrum
Minden-Ravensberg/Lippe


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
<a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=click">http://ads.osdn.com/?ad_idv28&alloc_id845&op=click
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users
Reply | Threaded
Open this post in threaded view
|

AW: Umstieg MB 2.1 auf 2.2

Jäger, Frank (KRZ)
Dann antworte ich mir mal selbst   ;-)


Ich habe ein Tool gefunden:
 
http://<mein_Server>/<mapbender_2.2>/tools/update_standard_guis.php
 
Klingt gut, aber ...
dies Programm scheint aber noch nicht auf die Version 2.2 umgestellt zu sein.
Es sucht noch nach der alten Conf-Datei für MySQL:  "mysql.conf".
Mit Version 2.2 sind die einzelnen Conf-Dateien zu einer zentralen Conf-Datei zusammen gefasst worden.
Die mysql.conf gibt es nicht mehr. Außerdem teste ich mit PostGIS und nicht mit MySQL.
 
Warning: main(../../conf/mysql.conf): failed to open stream: No such file or directory in /data/mbneu/http/tools/update_standard_guis.php on line 42



-----Ursprüngliche Nachricht-----
Von: [hidden email]
[mailto:[hidden email]]Im Auftrag von
Jäger, Frank (KRZ)
Gesendet: Mittwoch, 16. November 2005 17:35
An: [hidden email]
Cc: Astrid Emde (E-Mail)
Betreff: [Mapbender-users] Umstieg MB 2.1 auf 2.2


Hallo Leute,
ich beschäftige mich mit der Frage, wie ich von Mapbender 2.1 (MySQL) nach Mapbender 2.2 (PostGIS) umstellen kann, ohne meine Daten zu verlieren.  Wir haben unter 2.1 jede Menge GUIs, User und WMS eingerichtet (für viele Mandanten), die ich gerne weiter benutzen möchte.

Die Start-Version von MB 2.2 mit den 4 GUIs aus dem SQL-Script funktioniert.

Die Übertragung der Daten von MySQL (2.1) nach PostGIS (2.2) habe ich formal inzwischen auch hinbekommen.
Meine Erfahrungen habe ich festgehalten auf:  
http://www.mapbender.org/index.php/Mysql2postgis


Jedoch wird unter MB 2.2 mit den Daten aus MB 2.1 z.B. der "TreeGDE" nicht angezeigt.

Ein mögliche Ursache:

gui_element.e_src:
  alt 2.1: "../html/mod_sync_treefolder.php?sessionID"
  neu 2.2: "../html/mod_sync_treefolder.php?sessionID&e_id_css=treeGDE"
 

Wenn ich aber den neuen Anhang "&e_id_css=treeGDE" in der Admin-GUI ergänze, knallt es:

  Unknown column 'var_type' in 'field list'
  Fatal error: Cannot break/continue 1 level in /data/mbtest/http/php/mod_editElements.php on line 245

Uuuups -
Irgendwie müssen wohl noch Einträge in die neue Tabelle "gui_element_vars" kommen.


Frage:

Gibt es ein Script um die Daten von MB 2.1 für MB 2.2 aufzubereiten?
Wie kann ich sonst vorgehen?
Gibt es ein Release-Wechsel-PHP, das ich noch nicht gefunden habe?
Es kann doch nicht sein, dass man bei jedem Release-Wechsel wieder von vorn beginnt?



Mit freundlichen Grüßen
Frank Jäger

Kommunales Rechenzentrum
Minden-Ravensberg/Lippe


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
<a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick">http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
<a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=click">http://ads.osdn.com/?ad_idv28&alloc_id845&op=click
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users
Reply | Threaded
Open this post in threaded view
|

Re: AW: Umstieg MB 2.1 auf 2.2

Astrid Emde
Hallo Liste,

es liegt nur noch eine Konfigurationsdatei vor - mapbender.conf.

Die Dateien mapbender_setup.php und update_standard_guis.php wurden noch
nicht für den Mapbender 2.2 angepaßt. Derzeit liegt noch kein Skript für
den Umzug von Mapbender 2.1 nach 2.2 vor.

Die Dokumentation zu Mapbender 2.2 ist noch nicht vollständig, soll aber
in den nächsten tagen folgen. Im Mapbender Wiki liegt bereits eine
Dokumentation der Installation von Mapbender 2.2 vor.

http://www.mapbender.org/index.php/Installation

GUIs aus Mapbender 2.1 können nicht 1:1 übernommen werden. beim Umzug
einer GUI sollten Sie sich an den mitgelieferten Standard-GUIs
orientieren (gui,gui1). Eine wesentliche Änderung ist, dass den
Elementen einer GUI noch element_vars zugeordnet werden können. Über die
Element var wird z. b. der Style bestimmt (css-Dateien) und es könne
Variablen übergeben werden. So müssen nicht mehr die Dateien des
Mapbender angepaßt werden, stattdessen werden die Variablen anders
belegt. Anschaulich wird dieses z. b. am Element legend.

Die Bugs im Mapbender 2.2, die gemeldet wurden - v. a. für PostgreSQL
-werde ich versuchen bis Freitag zu bearbeiten.

Sollten noch weitere Fehler auffallen, bitte unbedingt an die Liste
schicken.

Schönen Gruß Astrid Emde


Jäger, Frank (KRZ) schrieb:

> Dann antworte ich mir mal selbst   ;-)
>
>
> Ich habe ein Tool gefunden:
>  
> http://<mein_Server>/<mapbender_2.2>/tools/update_standard_guis.php
>  
> Klingt gut, aber ...
> dies Programm scheint aber noch nicht auf die Version 2.2 umgestellt zu sein.
> Es sucht noch nach der alten Conf-Datei für MySQL:  "mysql.conf".
> Mit Version 2.2 sind die einzelnen Conf-Dateien zu einer zentralen Conf-Datei zusammen gefasst worden.
> Die mysql.conf gibt es nicht mehr. Außerdem teste ich mit PostGIS und nicht mit MySQL.
>  
> Warning: main(../../conf/mysql.conf): failed to open stream: No such file or directory in /data/mbneu/http/tools/update_standard_guis.php on line 42
>
>
>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email]
> [mailto:[hidden email]]Im Auftrag von
> Jäger, Frank (KRZ)
> Gesendet: Mittwoch, 16. November 2005 17:35
> An: [hidden email]
> Cc: Astrid Emde (E-Mail)
> Betreff: [Mapbender-users] Umstieg MB 2.1 auf 2.2
>
>
> Hallo Leute,
> ich beschäftige mich mit der Frage, wie ich von Mapbender 2.1 (MySQL) nach Mapbender 2.2 (PostGIS) umstellen kann, ohne meine Daten zu verlieren.  Wir haben unter 2.1 jede Menge GUIs, User und WMS eingerichtet (für viele Mandanten), die ich gerne weiter benutzen möchte.
>
> Die Start-Version von MB 2.2 mit den 4 GUIs aus dem SQL-Script funktioniert.
>
> Die Übertragung der Daten von MySQL (2.1) nach PostGIS (2.2) habe ich formal inzwischen auch hinbekommen.
> Meine Erfahrungen habe ich festgehalten auf:  
> http://www.mapbender.org/index.php/Mysql2postgis
>
>
> Jedoch wird unter MB 2.2 mit den Daten aus MB 2.1 z.B. der "TreeGDE" nicht angezeigt.
>
> Ein mögliche Ursache:
>
> gui_element.e_src:
>   alt 2.1: "../html/mod_sync_treefolder.php?sessionID"
>   neu 2.2: "../html/mod_sync_treefolder.php?sessionID&e_id_css=treeGDE"
>  
>
> Wenn ich aber den neuen Anhang "&e_id_css=treeGDE" in der Admin-GUI ergänze, knallt es:
>
>   Unknown column 'var_type' in 'field list'
>   Fatal error: Cannot break/continue 1 level in /data/mbtest/http/php/mod_editElements.php on line 245
>
> Uuuups -
> Irgendwie müssen wohl noch Einträge in die neue Tabelle "gui_element_vars" kommen.
>
>
> Frage:
>
> Gibt es ein Script um die Daten von MB 2.1 für MB 2.2 aufzubereiten?
> Wie kann ich sonst vorgehen?
> Gibt es ein Release-Wechsel-PHP, das ich noch nicht gefunden habe?
> Es kann doch nicht sein, dass man bei jedem Release-Wechsel wieder von vorn beginnt?
>
>
>
> Mit freundlichen Grüßen
> Frank Jäger
>
> Kommunales Rechenzentrum
> Minden-Ravensberg/Lippe
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
> Register for a JBoss Training Course.  Free Certification Exam
> for All Training Attendees Through End of 2005. For more info visit:
> <a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick">http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick
> _______________________________________________
> Mapbender-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbender-users
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
> Register for a JBoss Training Course.  Free Certification Exam
> for All Training Attendees Through End of 2005. For more info visit:
> <a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=click">http://ads.osdn.com/?ad_idv28&alloc_id845&op=click
> _______________________________________________
> Mapbender-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbender-users


--

Mit freundlichen Grüßen

Astrid Emde

----------------------------------

  Astrid Emde
  CCGIS GbR
  Siemensstraße 8
  53121 Bonn
  Germany

----------------------------------
   [hidden email]
          www.ccgis.de
----------------------------------
  Tel.:      ++49 (0) 228 90826 19
  Fax.:      ++49 (0) 228 90826 11
  Zentrale:  ++49 (0) 228 90826 0
----------------------------------


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
http://ads.osdn.com/?ad_id=7628&alloc_id=16845&op=click
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users
Reply | Threaded
Open this post in threaded view
|

AW: Umstieg MB 2.1 auf 2.2

Jäger, Frank (KRZ)
In reply to this post by Jäger, Frank (KRZ)
... unbedingt an die Liste schicken ....

Ja gerne.

Nachdem meine Bemühungen, die vorhandenen Daten aus MySQL/Mabbender-2.1 nach PostGIS/Mabbender-2.2 zu übernehmen nicht zu einem Ergebnis geführt haben, wollte ich mir wenigstens eine kleine Testumgebung MB2.2 mit eigenen WMS aufbauen.
Datenbank = PostGIS
Ausgangspunkt: DB geladen aus mitgelieferten SQL-Scripten der Version 2.2.

Versuch 1 (WMS direkt in GUI laden)

- Kopie von gui1_de unter dem Namen gui_krz
- beide WMS daraus entfernt
- eigenen WMS "Übersicht" hochgeladen in gui_krz
- Wird angezeigt als "0 - Germany"  (falsch, müsste heißen "0 - Bünde")
- WMS-GUI-Einstellungen:
   * 0     Name und Titel stammen aus eigenem WMS
   * 1 - x Layer stammen aus Germany-Demo


Versuch 2 (WMS zunächst in Container laden)

- neue gui wms_krz (ohne Elemente) als wms-Container
- eigenen WMS darin hochgeladen
- wird angezeigt als "0 - Germany"  (falsch, müsste heißen "0 - Bünde")
- WMS-GUI-Einstellungen:
  * 0,1,2,3         aus eigenem wms, wobei 1 = 3
  * 4 und folgende  Layer aus Germany-Demo
- EPSG nicht einstellbar (Drop-Down enthält keine Werte)

Siehe Screenshot aus Anlage file: screen_admin_mb22.jpg




-----Ursprüngliche Nachricht-----
Von: [hidden email]
[mailto:[hidden email]]Im Auftrag von
Astrid Emde
Gesendet: Donnerstag, 17. November 2005 10:47
An: [hidden email]
Betreff: Re: AW: [Mapbender-users] Umstieg MB 2.1 auf 2.2


Hallo Liste,

es liegt nur noch eine Konfigurationsdatei vor - mapbender.conf.

Die Dateien mapbender_setup.php und update_standard_guis.php wurden noch
nicht für den Mapbender 2.2 angepaßt. Derzeit liegt noch kein Skript für
den Umzug von Mapbender 2.1 nach 2.2 vor.

Die Dokumentation zu Mapbender 2.2 ist noch nicht vollständig, soll aber
in den nächsten tagen folgen. Im Mapbender Wiki liegt bereits eine
Dokumentation der Installation von Mapbender 2.2 vor.

http://www.mapbender.org/index.php/Installation

GUIs aus Mapbender 2.1 können nicht 1:1 übernommen werden. beim Umzug
einer GUI sollten Sie sich an den mitgelieferten Standard-GUIs
orientieren (gui,gui1). Eine wesentliche Änderung ist, dass den
Elementen einer GUI noch element_vars zugeordnet werden können. Über die
Element var wird z. b. der Style bestimmt (css-Dateien) und es könne
Variablen übergeben werden. So müssen nicht mehr die Dateien des
Mapbender angepaßt werden, stattdessen werden die Variablen anders
belegt. Anschaulich wird dieses z. b. am Element legend.

Die Bugs im Mapbender 2.2, die gemeldet wurden - v. a. für PostgreSQL
-werde ich versuchen bis Freitag zu bearbeiten.

Sollten noch weitere Fehler auffallen, bitte unbedingt an die Liste
schicken.

Schönen Gruß Astrid Emde


Jäger, Frank (KRZ) schrieb:

> Dann antworte ich mir mal selbst   ;-)
>
>
> Ich habe ein Tool gefunden:
>  
> http://<mein_Server>/<mapbender_2.2>/tools/update_standard_guis.php
>  
> Klingt gut, aber ...
> dies Programm scheint aber noch nicht auf die Version 2.2 umgestellt zu sein.
> Es sucht noch nach der alten Conf-Datei für MySQL:  "mysql.conf".
> Mit Version 2.2 sind die einzelnen Conf-Dateien zu einer zentralen Conf-Datei zusammen gefasst worden.
> Die mysql.conf gibt es nicht mehr. Außerdem teste ich mit PostGIS und nicht mit MySQL.
>  
> Warning: main(../../conf/mysql.conf): failed to open stream: No such file or directory in /data/mbneu/http/tools/update_standard_guis.php on line 42
>
>
>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email]
> [mailto:[hidden email]]Im Auftrag von
> Jäger, Frank (KRZ)
> Gesendet: Mittwoch, 16. November 2005 17:35
> An: [hidden email]
> Cc: Astrid Emde (E-Mail)
> Betreff: [Mapbender-users] Umstieg MB 2.1 auf 2.2
>
>
> Hallo Leute,
> ich beschäftige mich mit der Frage, wie ich von Mapbender 2.1 (MySQL) nach Mapbender 2.2 (PostGIS) umstellen kann, ohne meine Daten zu verlieren.  Wir haben unter 2.1 jede Menge GUIs, User und WMS eingerichtet (für viele Mandanten), die ich gerne weiter benutzen möchte.
>
> Die Start-Version von MB 2.2 mit den 4 GUIs aus dem SQL-Script funktioniert.
>
> Die Übertragung der Daten von MySQL (2.1) nach PostGIS (2.2) habe ich formal inzwischen auch hinbekommen.
> Meine Erfahrungen habe ich festgehalten auf:  
> http://www.mapbender.org/index.php/Mysql2postgis
>
>
> Jedoch wird unter MB 2.2 mit den Daten aus MB 2.1 z.B. der "TreeGDE" nicht angezeigt.
>
> Ein mögliche Ursache:
>
> gui_element.e_src:
>   alt 2.1: "../html/mod_sync_treefolder.php?sessionID"
>   neu 2.2: "../html/mod_sync_treefolder.php?sessionID&e_id_css=treeGDE"
>  
>
> Wenn ich aber den neuen Anhang "&e_id_css=treeGDE" in der Admin-GUI ergänze, knallt es:
>
>   Unknown column 'var_type' in 'field list'
>   Fatal error: Cannot break/continue 1 level in /data/mbtest/http/php/mod_editElements.php on line 245
>
> Uuuups -
> Irgendwie müssen wohl noch Einträge in die neue Tabelle "gui_element_vars" kommen.
>
>
> Frage:
>
> Gibt es ein Script um die Daten von MB 2.1 für MB 2.2 aufzubereiten?
> Wie kann ich sonst vorgehen?
> Gibt es ein Release-Wechsel-PHP, das ich noch nicht gefunden habe?
> Es kann doch nicht sein, dass man bei jedem Release-Wechsel wieder von vorn beginnt?
>
>
>
> Mit freundlichen Grüßen
> Frank Jäger
>
> Kommunales Rechenzentrum
> Minden-Ravensberg/Lippe
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
> Register for a JBoss Training Course.  Free Certification Exam
> for All Training Attendees Through End of 2005. For more info visit:
> <a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick">http://ads.osdn.com/?ad_idv28&alloc_id845&op=ick
> _______________________________________________
> Mapbender-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbender-users
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
> Register for a JBoss Training Course.  Free Certification Exam
> for All Training Attendees Through End of 2005. For more info visit:
> <a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=click">http://ads.osdn.com/?ad_idv28&alloc_id845&op=click
> _______________________________________________
> Mapbender-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbender-users

--

Mit freundlichen Grüßen

Astrid Emde

----------------------------------

  Astrid Emde
  CCGIS GbR
  Siemensstraße 8
  53121 Bonn
  Germany

----------------------------------
   [hidden email]
          www.ccgis.de
----------------------------------
  Tel.:      ++49 (0) 228 90826 19
  Fax.:      ++49 (0) 228 90826 11
  Zentrale:  ++49 (0) 228 90826 0
----------------------------------


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
http://ads.osdn.com/?ad_id=7628&alloc_id=16845&op=click
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users

screen_admin_mb22.jpg (53K) Download Attachment