Quantcast

Trouble with Geowebcache 1.3 in Geoserver 2.1.3 custom projection 23031

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Trouble with Geowebcache 1.3 in Geoserver 2.1.3 custom projection 23031

Agustí Escobar Rúbies
Hello everyone:


I recently upgraded GeoServer to version 2.1.3 revision 16668. Apparently this upgraded also the bundled Geowebcache, which is now 1.3-RC2, built 2011-12-21 11:31:51.

Before the upgrade I was serving a set of layers through gwc, using a customized geowebcache.xml which allowed me to serve these layers using 23031:EPSG projection.

After the upgrade, these layers ceased to work. It seems that the structure of geowebcache.xml has changed, and my customized file no longer works.

I tried to update it to a version which is compatible with 1.3.0, and finally I have produced a file that GeoWebCache seems to like; however, i can't serve my layer using my custom 23031 projection.

This is my geowebcache configuration file:

<?xml version="1.0" encoding="utf-8"?>
<gwcConfiguration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://geowebcache.org/schema/1.3.0/geowebcache.xsd" xmlns="http://geowebcache.org/schema/1.3.0">
        <version>1.3.0</version>
        <backendTimeout>120</backendTimeout>
        <cacheBypassAllowed>true</cacheBypassAllowed>
        <gridSets>  
                <gridSet>
                        <name>EPSG:23031</name>
                        <srs><number>23031</number></srs>
                        <extent>
                                <coords>
                                        <double>238730.0252</double>
                                        <double>4276730.7754</double>
                                        <double>761269.9748</double>
                                        <double>7434723.1222</double>
                                </coords>
                        </extent>
                        <resolutions>
                                <double>550.0</double>
                                <double>275.0</double>
                                <double>100.0</double>
                                <double>50.0</double>
                                <double>25.0</double>
                                <double>10.0</double>
                                <double>5.0</double>
                                <double>2.0</double>
                                <double>1.0</double>
                                <double>0.5</double>
                        </resolutions>
                        <metersPerUnit>1</metersPerUnit>
                        <tileHeight>256</tileHeight>
                        <tileWidth>256</tileWidth>
                </gridSet>  
        </gridSets>
        <layers>
                <wmsLayer>  
                        <name>XXXXXXXXXXXXXXXXX</name>
                        <mimeFormats>
                                <string>image/png</string>
                        </mimeFormats>
                        <gridSubsets>
                                <gridSubset>
                                        <gridSetName>EPSG:23031</gridSetName>
                                        <extent>
                                                <coords>
                                                        <double>258000</double>
                                                        <double>4485000</double>
                                                        <double>536000</double>
                                                        <double>4752000</double>
                                                </coords>
                                        </extent>
                                </gridSubset>
                        </gridSubsets>  
                        <wmsUrl>
                                <string>http://XXXXXXXXXXXXX/geoserver/wms</string>
                        </wmsUrl>
                </wmsLayer>  
        </layers>
</gwcConfiguration>


And this is an excerpt from the geoserver logs, in which geoserver/gwc seem to like the config file:

....
2012-01-31 15:47:14,494 INFO [config.XMLConfiguration] - Will look for geowebcache.xml in 'C:\DataDir_GeoServer\gwc'
2012-01-31 15:47:14,510 DEBUG [layer.TileLayerDispatcher] - Thread initLayers(), initializing
2012-01-31 15:47:14,510 DEBUG [layer.TileLayerDispatcher] - Reading service information.
2012-01-31 15:47:14,510 INFO [config.XMLConfiguration] - Found configuration file in C:\DataDir_GeoServer\gwc
2012-01-31 15:47:14,541 INFO [config.XMLConfiguration] - Configuration file validated fine.
2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Initializing GridSets from C:\DataDir_GeoServer\gwc
2012-01-31 15:47:14,572 DEBUG [config.XMLConfiguration] - Reading EPSG:23031
2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Read GridSet EPSG:23031
2012-01-31 15:47:14,572 DEBUG [grid.GridSetBroker] - Adding EPSG:23031
2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Initializing layers from C:\DataDir_GeoServer\gwc
....


I'm out of ideas. What am I doing wrong?

Thanks in advance,




------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Trouble with Geowebcache 1.3 in Geoserver 2.1.3 custom projection 23031

geowolf
On Tue, Jan 31, 2012 at 4:21 PM, Agustí Escobar Rúbies <[hidden email]> wrote:
Hello everyone:


I recently upgraded GeoServer to version 2.1.3 revision 16668. Apparently this upgraded also the bundled Geowebcache, which is now 1.3-RC2, built 2011-12-21 11:31:51.

What was the GeoServer version you were using before?

Cheers
Andrea
 
--
-------------------------------------------------------
Ing. Andrea Aime
GeoSolutions S.A.S.
Tech lead

Via Poggio alle Viti 1187
55054  Massarosa (LU)
Italy

phone: +39 0584 962313
fax:      +39 0584 962313
mob:    +39 339 8844549

http://www.geo-solutions.it
http://geo-solutions.blogspot.com/
http://www.youtube.com/user/GeoSolutionsIT
http://www.linkedin.com/in/andreaaime
http://twitter.com/geowolf

-------------------------------------------------------

------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Trouble with Geowebcache 1.3 in Geoserver 2.1.3custom projection 23031

Agustí Escobar Rúbies

Hi,

I think it was GeoServer 2.0.2.

Cheers,



De: [hidden email] [[hidden email]] en nombre de Andrea Aime [[hidden email]]

Enviado el: martes, 31 de enero de 2012 18:07

Para: Agustí Escobar Rúbies

CC: [hidden email]

Asunto: Re: [Geoserver-users] Trouble with Geowebcache 1.3 in Geoserver 2.1.3custom projection 23031









On Tue, Jan 31, 2012 at 4:21 PM, Agustí Escobar Rúbies
<[hidden email]> wrote:


Hello everyone:





I recently upgraded GeoServer to version 2.1.3 revision 16668. Apparently this upgraded also the bundled Geowebcache, which is now 1.3-RC2, built 2011-12-21 11:31:51.







What was the GeoServer version you were using before?





Cheers

Andrea

 

--

-------------------------------------------------------

Ing. Andrea Aime

GeoSolutions S.A.S.

Tech lead



Via Poggio alle Viti 1187

55054  Massarosa (LU)

Italy



phone: +39 0584 962313

fax:      +39 0584 962313

mob:    +39 339 8844549



http://www.geo-solutions.it

http://geo-solutions.blogspot.com/

http://www.youtube.com/user/GeoSolutionsIT

http://www.linkedin.com/in/andreaaime

http://twitter.com/geowolf



-------------------------------------------------------





------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Trouble with Geowebcache 1.3 in Geoserver 2.1.3custom projection 23031

Agustí Escobar Rúbies
In reply to this post by geowolf

Hello all,

Some more data about this subject: although the reference system
EPSG:23031 doesn't appear in the GWC demo and appears to be unavailable
if you try to access it like this:

http://XXXXXXXX/geoserver/gwc/service/wms?LAYERS=XXX%3AXXXXXX&STYLES=&TRANSPARENT=true&FORMAT=image%2Fpng&WIDTH=256&HEIGHT=256&TILED=true&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&EXCEPTIONS=application%2Fvnd.ogc.se_inimage&SRS=EPSG%3A23031&BBOX=258000,4625800,398800,4766600

(gwc responds to this with 400: Unable to match requested SRS EPSG:23031
to those supported by layer)

However, if i take a look at GWC Home-> WMS 1.1.1 GetCapabilities
document, the following entries relevant to my layer appear:

The layer:

<Layer>
<Name>XXXXXXXXXXXXX</Name>
<Title>XXXXXXXXXXXXX</Title>
<SRS>EPSG:23031</SRS>
<BoundingBox SRS="EPSG:23031" minx="238730.0252" miny="4276730.7754"
maxx="761295.1452" maxy="7434750.8714"/>
</Layer>

And the tilesets:

<TileSet>
<SRS>EPSG:23031</SRS>
<BoundingBox SRS="EPSG:23031" minx="238730.0252" miny="4276730.7754"
maxx="761295.1452" maxy="7434750.8714"/>
<Resolutions>0.154 0.077 0.027999999999999997 0.013999999999999999
0.006999999999999999 0.0027999999999999995 0.0013999999999999998 5.6E-4
2.8E-4 1.4E-4 </Resolutions>
<Width>256</Width>
<Height>256</Height>
<Format>image/gif</Format>
<Layers>XXXXXXXXXXXXXXXXX</Layers><Styles/>
</TileSet>.

.. and so on for the different formats.

The Layer tag seems to lack the queryable attribute (<Layer
queryable="1">). So it would seem that the capability is there, somehow.

Any ideas?

Thanks in advance,





El 31/01/2012 18:07, Andrea Aime escribió:

> On Tue, Jan 31, 2012 at 4:21 PM, Agustí Escobar Rúbies
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hello everyone:
>
>
>     I recently upgraded GeoServer to version 2.1.3 revision 16668.
>     Apparently this upgraded also the bundled Geowebcache, which is
>     now 1.3-RC2, built 2011-12-21 11:31:51.
>
>
> What was the GeoServer version you were using before?
>
> Cheers
> Andrea
> --
> -------------------------------------------------------
> Ing. Andrea Aime
> GeoSolutions S.A.S.
> Tech lead
>
> Via Poggio alle Viti 1187
> 55054  Massarosa (LU)
> Italy
>
> phone: +39 0584 962313
> fax:      +39 0584 962313
> mob:    +39 339 8844549
>
> http://www.geo-solutions.it
> http://geo-solutions.blogspot.com/
> http://www.youtube.com/user/GeoSolutionsIT
> http://www.linkedin.com/in/andreaaime
> http://twitter.com/geowolf
>
> -------------------------------------------------------



------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Trouble with Geowebcache 1.3 in Geoserver 2.1.3 custom projection 23031

Gabriel Roldan
In reply to this post by Agustí Escobar Rúbies
Would you send the original geowebcache.xml?
The layers in there were configured to serve geoserver layers or wms layers?

The're was a re-estructuring of the geowebcache.xsd schema so that the
validation phase at load time can be done better, but none of them
should actually affect the runtime behaivor because the xstream
library, used to load the config, doesn't care about the schema.

It'd be good if you send your geoserver 2.0.0 geowebcache.xml file to
take a look at it.

Cheers,
Gabriel

On Tue, Jan 31, 2012 at 12:21 PM, Agustí Escobar Rúbies
<[hidden email]> wrote:

> Hello everyone:
>
>
> I recently upgraded GeoServer to version 2.1.3 revision 16668. Apparently this upgraded also the bundled Geowebcache, which is now 1.3-RC2, built 2011-12-21 11:31:51.
>
> Before the upgrade I was serving a set of layers through gwc, using a customized geowebcache.xml which allowed me to serve these layers using 23031:EPSG projection.
>
> After the upgrade, these layers ceased to work. It seems that the structure of geowebcache.xml has changed, and my customized file no longer works.
>
> I tried to update it to a version which is compatible with 1.3.0, and finally I have produced a file that GeoWebCache seems to like; however, i can't serve my layer using my custom 23031 projection.
>
> This is my geowebcache configuration file:
>
> <?xml version="1.0" encoding="utf-8"?>
> <gwcConfiguration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://geowebcache.org/schema/1.3.0/geowebcache.xsd" xmlns="http://geowebcache.org/schema/1.3.0">
>        <version>1.3.0</version>
>        <backendTimeout>120</backendTimeout>
>        <cacheBypassAllowed>true</cacheBypassAllowed>
>        <gridSets>
>                <gridSet>
>                        <name>EPSG:23031</name>
>                        <srs><number>23031</number></srs>
>                        <extent>
>                                <coords>
>                                        <double>238730.0252</double>
>                                        <double>4276730.7754</double>
>                                        <double>761269.9748</double>
>                                        <double>7434723.1222</double>
>                                </coords>
>                        </extent>
>                        <resolutions>
>                                <double>550.0</double>
>                                <double>275.0</double>
>                                <double>100.0</double>
>                                <double>50.0</double>
>                                <double>25.0</double>
>                                <double>10.0</double>
>                                <double>5.0</double>
>                                <double>2.0</double>
>                                <double>1.0</double>
>                                <double>0.5</double>
>                        </resolutions>
>                        <metersPerUnit>1</metersPerUnit>
>                        <tileHeight>256</tileHeight>
>                        <tileWidth>256</tileWidth>
>                </gridSet>
>        </gridSets>
>        <layers>
>                <wmsLayer>
>                        <name>XXXXXXXXXXXXXXXXX</name>
>                        <mimeFormats>
>                                <string>image/png</string>
>                        </mimeFormats>
>                        <gridSubsets>
>                                <gridSubset>
>                                        <gridSetName>EPSG:23031</gridSetName>
>                                        <extent>
>                                                <coords>
>                                                        <double>258000</double>
>                                                        <double>4485000</double>
>                                                        <double>536000</double>
>                                                        <double>4752000</double>
>                                                </coords>
>                                        </extent>
>                                </gridSubset>
>                        </gridSubsets>
>                        <wmsUrl>
>                                <string>http://XXXXXXXXXXXXX/geoserver/wms</string>
>                        </wmsUrl>
>                </wmsLayer>
>        </layers>
> </gwcConfiguration>
>
>
> And this is an excerpt from the geoserver logs, in which geoserver/gwc seem to like the config file:
>
> ....
> 2012-01-31 15:47:14,494 INFO [config.XMLConfiguration] - Will look for geowebcache.xml in 'C:\DataDir_GeoServer\gwc'
> 2012-01-31 15:47:14,510 DEBUG [layer.TileLayerDispatcher] - Thread initLayers(), initializing
> 2012-01-31 15:47:14,510 DEBUG [layer.TileLayerDispatcher] - Reading service information.
> 2012-01-31 15:47:14,510 INFO [config.XMLConfiguration] - Found configuration file in C:\DataDir_GeoServer\gwc
> 2012-01-31 15:47:14,541 INFO [config.XMLConfiguration] - Configuration file validated fine.
> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Initializing GridSets from C:\DataDir_GeoServer\gwc
> 2012-01-31 15:47:14,572 DEBUG [config.XMLConfiguration] - Reading EPSG:23031
> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Read GridSet EPSG:23031
> 2012-01-31 15:47:14,572 DEBUG [grid.GridSetBroker] - Adding EPSG:23031
> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Initializing layers from C:\DataDir_GeoServer\gwc
> ....
>
>
> I'm out of ideas. What am I doing wrong?
>
> Thanks in advance,
>
>
>
>
> ------------------------------------------------------------------------------
> Keep Your Developer Skills Current with LearnDevNow!
> The most comprehensive online learning library for Microsoft developers
> is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
> Metro Style Apps, more. Free future releases when you subscribe now!
> http://p.sf.net/sfu/learndevnow-d2d
> _______________________________________________
> Geoserver-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geoserver-users



--
Gabriel Roldan
OpenGeo - http://opengeo.org
Expert service straight from the developers.
------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Trouble with Geowebcache 1.3 in Geoserver 2.1.3custom projection 23031

Agustí Escobar Rúbies

Here's the original geowebcache.xml:

<?xml version="1.0" encoding="utf-8"?>
<gwcConfiguration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                   
xsi:noNamespaceSchemaLocation="http://geowebcache.org/schema/1.1.5/geowebcache.xsd"
                   xmlns="http://geowebcache.org/schema/1.1.5">
<version>1.1.5</version>
<backendTimeout>120</backendTimeout>
<cacheBypassAllowed>true</cacheBypassAllowed>
<layers>
<!-- HABITATS_GEOMETRIA -->
<wmsLayer>
<name>XXXXX:HABITATS_GEOMETRIA</name>
<mimeFormats>
<string>image/png</string>
</mimeFormats>
<grids>
<entry>
<srs>
<number>23031</number>
</srs>
<grid>
<srs>
<number>23031</number>
</srs>
<dataBounds>
<coords>
<double>258000</double>
<double>4485000</double>
<double>536000</double>
<double>4752000</double>
</coords>
</dataBounds>
<gridBounds>
<coords>
<double>258000</double>
<double>4485000</double>
<double>536000</double>
<double>4752000</double>
</coords>
</gridBounds>
<resolutions>
<double>550.0</double>
<double>275.0</double>
<double>100.0</double>
<double>50.0</double>
<double>25.0</double>
<double>10.0</double>
<double>5.0</double>
<double>2.0</double>
<double>1.0</double>
<double>0.5</double>
</resolutions>
</grid>
</entry>
</grids>
<wmsUrl>
<string>http://XXXXXXXXXX/geoserver/wms</string>
</wmsUrl>
<wmsLayers>SIPAN:HABITATS_GEOMETRIA</wmsLayers>
<wmsStyles>HABITATS_GEOMETRIA</wmsStyles>
<tiled>false</tiled>
<transparent>false</transparent>
<bgColor></bgColor>
<palette></palette>
<expireCache>7200</expireCache>
<expireClients>240</expireClients>
</wmsLayer>
</layers>
</gwcConfiguration>




El 01/02/2012 16:08, Gabriel Roldan escribió:

> Would you send the original geowebcache.xml?
> The layers in there were configured to serve geoserver layers or wms layers?
>
> The're was a re-estructuring of the geowebcache.xsd schema so that the
> validation phase at load time can be done better, but none of them
> should actually affect the runtime behaivor because the xstream
> library, used to load the config, doesn't care about the schema.
>
> It'd be good if you send your geoserver 2.0.0 geowebcache.xml file to
> take a look at it.
>
> Cheers,
> Gabriel
>
> On Tue, Jan 31, 2012 at 12:21 PM, Agustí Escobar Rúbies
> <[hidden email]>  wrote:
>> Hello everyone:
>>
>>
>> I recently upgraded GeoServer to version 2.1.3 revision 16668. Apparently this upgraded also the bundled Geowebcache, which is now 1.3-RC2, built 2011-12-21 11:31:51.
>>
>> Before the upgrade I was serving a set of layers through gwc, using a customized geowebcache.xml which allowed me to serve these layers using 23031:EPSG projection.
>>
>> After the upgrade, these layers ceased to work. It seems that the structure of geowebcache.xml has changed, and my customized file no longer works.
>>
>> I tried to update it to a version which is compatible with 1.3.0, and finally I have produced a file that GeoWebCache seems to like; however, i can't serve my layer using my custom 23031 projection.
>>
>> This is my geowebcache configuration file:
>>
>> <?xml version="1.0" encoding="utf-8"?>
>> <gwcConfiguration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://geowebcache.org/schema/1.3.0/geowebcache.xsd" xmlns="http://geowebcache.org/schema/1.3.0">
>>         <version>1.3.0</version>
>>         <backendTimeout>120</backendTimeout>
>>         <cacheBypassAllowed>true</cacheBypassAllowed>
>>         <gridSets>
>>                 <gridSet>
>>                         <name>EPSG:23031</name>
>>                         <srs><number>23031</number></srs>
>>                         <extent>
>>                                 <coords>
>>                                         <double>238730.0252</double>
>>                                         <double>4276730.7754</double>
>>                                         <double>761269.9748</double>
>>                                         <double>7434723.1222</double>
>>                                 </coords>
>>                         </extent>
>>                         <resolutions>
>>                                 <double>550.0</double>
>>                                 <double>275.0</double>
>>                                 <double>100.0</double>
>>                                 <double>50.0</double>
>>                                 <double>25.0</double>
>>                                 <double>10.0</double>
>>                                 <double>5.0</double>
>>                                 <double>2.0</double>
>>                                 <double>1.0</double>
>>                                 <double>0.5</double>
>>                         </resolutions>
>>                         <metersPerUnit>1</metersPerUnit>
>>                         <tileHeight>256</tileHeight>
>>                         <tileWidth>256</tileWidth>
>>                 </gridSet>
>>         </gridSets>
>>         <layers>
>>                 <wmsLayer>
>>                         <name>XXXXXXXXXXXXXXXXX</name>
>>                         <mimeFormats>
>>                                 <string>image/png</string>
>>                         </mimeFormats>
>>                         <gridSubsets>
>>                                 <gridSubset>
>>                                         <gridSetName>EPSG:23031</gridSetName>
>>                                         <extent>
>>                                                 <coords>
>>                                                         <double>258000</double>
>>                                                         <double>4485000</double>
>>                                                         <double>536000</double>
>>                                                         <double>4752000</double>
>>                                                 </coords>
>>                                         </extent>
>>                                 </gridSubset>
>>                         </gridSubsets>
>>                         <wmsUrl>
>>                                 <string>http://XXXXXXXXXXXXX/geoserver/wms</string>
>>                         </wmsUrl>
>>                 </wmsLayer>
>>         </layers>
>> </gwcConfiguration>
>>
>>
>> And this is an excerpt from the geoserver logs, in which geoserver/gwc seem to like the config file:
>>
>> ....
>> 2012-01-31 15:47:14,494 INFO [config.XMLConfiguration] - Will look for geowebcache.xml in 'C:\DataDir_GeoServer\gwc'
>> 2012-01-31 15:47:14,510 DEBUG [layer.TileLayerDispatcher] - Thread initLayers(), initializing
>> 2012-01-31 15:47:14,510 DEBUG [layer.TileLayerDispatcher] - Reading service information.
>> 2012-01-31 15:47:14,510 INFO [config.XMLConfiguration] - Found configuration file in C:\DataDir_GeoServer\gwc
>> 2012-01-31 15:47:14,541 INFO [config.XMLConfiguration] - Configuration file validated fine.
>> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Initializing GridSets from C:\DataDir_GeoServer\gwc
>> 2012-01-31 15:47:14,572 DEBUG [config.XMLConfiguration] - Reading EPSG:23031
>> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Read GridSet EPSG:23031
>> 2012-01-31 15:47:14,572 DEBUG [grid.GridSetBroker] - Adding EPSG:23031
>> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Initializing layers from C:\DataDir_GeoServer\gwc
>> ....
>>
>>
>> I'm out of ideas. What am I doing wrong?
>>
>> Thanks in advance,
>>
>>
>>
>>
>> ------------------------------------------------------------------------------
>> Keep Your Developer Skills Current with LearnDevNow!
>> The most comprehensive online learning library for Microsoft developers
>> is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
>> Metro Style Apps, more. Free future releases when you subscribe now!
>> http://p.sf.net/sfu/learndevnow-d2d
>> _______________________________________________
>> Geoserver-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/geoserver-users
>
>



------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Trouble with Geowebcache 1.3 in Geoserver 2.1.3custom projection 23031

Agustí Escobar Rúbies
In reply to this post by Gabriel Roldan

Another piece of information:

These are the errors that geoserver logs when you upgrade it to 2.1.3
and it founds the old geowebcache.xml (sorry for not sending it before,
i couldn't find it immediately and had to reproduce it in another
machine in almost identical conditions):

2012-02-01 17:50:35,296 INFO [config.XMLConfiguration] - Found
configuration file in C:\DataDir_GeoServer\gwc
2012-02-01 17:50:35,296 INFO [config.XMLConfiguration] - Updating
configuration from 1.1.5 to 1.2.0
2012-02-01 17:50:35,311 INFO [config.XMLConfiguration] - Updating
configuration from 1.2.0 to 1.2.1
2012-02-01 17:50:35,311 INFO [config.XMLConfiguration] - Updating
configuration from 1.2.1 to 1.2.2
2012-02-01 17:50:35,327 INFO [config.XMLConfiguration] - Updating
configuration from 1.2.2 to 1.2.4
2012-02-01 17:50:35,342 INFO [config.XMLConfiguration] - Updating
configuration from 1.2.4 to 1.2.5
2012-02-01 17:50:35,342 INFO [config.XMLConfiguration] - Updating
configuration from 1.2.5 to 1.2.6
2012-02-01 17:50:35,358 INFO [config.XMLConfiguration] - Updating
configuration from 1.2.6 to 1.3.0
2012-02-01 17:50:35,389 WARN [config.XMLConfiguration] -
********************************************************************************
2012-02-01 17:50:35,389 WARN [config.XMLConfiguration] - *** GWC
configuration validation error: cvc-complex-type.2.4.a: Invalid content
was found starting with element 'version'. One of
'{"http://geowebcache.org/schema/1.3.0":version,
"http://geowebcache.org/schema/1.3.0":backendTimeout,
"http://geowebcache.org/schema/1.3.0":cacheBypassAllowed,
"http://geowebcache.org/schema/1.3.0":runtimeStats,
"http://geowebcache.org/schema/1.3.0":serviceInformation,
"http://geowebcache.org/schema/1.3.0":httpUsername,
"http://geowebcache.org/schema/1.3.0":httpPassword,
"http://geowebcache.org/schema/1.3.0":proxyUrl,
"http://geowebcache.org/schema/1.3.0":formatModifiers,
"http://geowebcache.org/schema/1.3.0":gridSets,
"http://geowebcache.org/schema/1.3.0":layers}' is expected.
2012-02-01 17:50:35,389 WARN [config.XMLConfiguration] - *** Will try to
use configuration anyway. Please check the order of declared elements
against the schema.
2012-02-01 17:50:35,389 WARN [config.XMLConfiguration] -
********************************************************************************
2012-02-01 17:50:35,405 INFO [config.XMLConfiguration] - Initializing
GridSets from C:\DataDir_GeoServer\gwc
2012-02-01 17:50:35,405 INFO [config.XMLConfiguration] - Initializing
layers from C:\DataDir_GeoServer\gwc
2012-02-01 17:50:35,405 INFO [config.XMLConfiguration] - Initializing
TileLayer 'XXXXXX:HABITATS_GEOMETRIA'
2012-02-01 17:50:35,405 DEBUG [config.XMLConfiguration] - Not using HTTP
credentials for XXXXX:HABITATS_GEOMETRIA
2012-02-01 17:50:35,405 DEBUG [wms.WMSLayer] - Setting sourceHelper on
XXXXX:HABITATS_GEOMETRIA
2012-02-01 17:50:35,405 WARN [grid.GridSetFactory] - GridSet EPSG:23031
was defined without metersPerUnit. Assuming 1m per SRS unit for WMTS
scale output.
.....





El 01/02/2012 16:08, Gabriel Roldan escribió:

> Would you send the original geowebcache.xml?
> The layers in there were configured to serve geoserver layers or wms layers?
>
> The're was a re-estructuring of the geowebcache.xsd schema so that the
> validation phase at load time can be done better, but none of them
> should actually affect the runtime behaivor because the xstream
> library, used to load the config, doesn't care about the schema.
>
> It'd be good if you send your geoserver 2.0.0 geowebcache.xml file to
> take a look at it.
>
> Cheers,
> Gabriel
>
> On Tue, Jan 31, 2012 at 12:21 PM, Agustí Escobar Rúbies
> <[hidden email]>  wrote:
>> Hello everyone:
>>
>>
>> I recently upgraded GeoServer to version 2.1.3 revision 16668. Apparently this upgraded also the bundled Geowebcache, which is now 1.3-RC2, built 2011-12-21 11:31:51.
>>
>> Before the upgrade I was serving a set of layers through gwc, using a customized geowebcache.xml which allowed me to serve these layers using 23031:EPSG projection.
>>
>> After the upgrade, these layers ceased to work. It seems that the structure of geowebcache.xml has changed, and my customized file no longer works.
>>
>> I tried to update it to a version which is compatible with 1.3.0, and finally I have produced a file that GeoWebCache seems to like; however, i can't serve my layer using my custom 23031 projection.
>>
>> This is my geowebcache configuration file:
>>
>> <?xml version="1.0" encoding="utf-8"?>
>> <gwcConfiguration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://geowebcache.org/schema/1.3.0/geowebcache.xsd" xmlns="http://geowebcache.org/schema/1.3.0">
>>         <version>1.3.0</version>
>>         <backendTimeout>120</backendTimeout>
>>         <cacheBypassAllowed>true</cacheBypassAllowed>
>>         <gridSets>
>>                 <gridSet>
>>                         <name>EPSG:23031</name>
>>                         <srs><number>23031</number></srs>
>>                         <extent>
>>                                 <coords>
>>                                         <double>238730.0252</double>
>>                                         <double>4276730.7754</double>
>>                                         <double>761269.9748</double>
>>                                         <double>7434723.1222</double>
>>                                 </coords>
>>                         </extent>
>>                         <resolutions>
>>                                 <double>550.0</double>
>>                                 <double>275.0</double>
>>                                 <double>100.0</double>
>>                                 <double>50.0</double>
>>                                 <double>25.0</double>
>>                                 <double>10.0</double>
>>                                 <double>5.0</double>
>>                                 <double>2.0</double>
>>                                 <double>1.0</double>
>>                                 <double>0.5</double>
>>                         </resolutions>
>>                         <metersPerUnit>1</metersPerUnit>
>>                         <tileHeight>256</tileHeight>
>>                         <tileWidth>256</tileWidth>
>>                 </gridSet>
>>         </gridSets>
>>         <layers>
>>                 <wmsLayer>
>>                         <name>XXXXXXXXXXXXXXXXX</name>
>>                         <mimeFormats>
>>                                 <string>image/png</string>
>>                         </mimeFormats>
>>                         <gridSubsets>
>>                                 <gridSubset>
>>                                         <gridSetName>EPSG:23031</gridSetName>
>>                                         <extent>
>>                                                 <coords>
>>                                                         <double>258000</double>
>>                                                         <double>4485000</double>
>>                                                         <double>536000</double>
>>                                                         <double>4752000</double>
>>                                                 </coords>
>>                                         </extent>
>>                                 </gridSubset>
>>                         </gridSubsets>
>>                         <wmsUrl>
>>                                 <string>http://XXXXXXXXXXXXX/geoserver/wms</string>
>>                         </wmsUrl>
>>                 </wmsLayer>
>>         </layers>
>> </gwcConfiguration>
>>
>>
>> And this is an excerpt from the geoserver logs, in which geoserver/gwc seem to like the config file:
>>
>> ....
>> 2012-01-31 15:47:14,494 INFO [config.XMLConfiguration] - Will look for geowebcache.xml in 'C:\DataDir_GeoServer\gwc'
>> 2012-01-31 15:47:14,510 DEBUG [layer.TileLayerDispatcher] - Thread initLayers(), initializing
>> 2012-01-31 15:47:14,510 DEBUG [layer.TileLayerDispatcher] - Reading service information.
>> 2012-01-31 15:47:14,510 INFO [config.XMLConfiguration] - Found configuration file in C:\DataDir_GeoServer\gwc
>> 2012-01-31 15:47:14,541 INFO [config.XMLConfiguration] - Configuration file validated fine.
>> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Initializing GridSets from C:\DataDir_GeoServer\gwc
>> 2012-01-31 15:47:14,572 DEBUG [config.XMLConfiguration] - Reading EPSG:23031
>> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Read GridSet EPSG:23031
>> 2012-01-31 15:47:14,572 DEBUG [grid.GridSetBroker] - Adding EPSG:23031
>> 2012-01-31 15:47:14,572 INFO [config.XMLConfiguration] - Initializing layers from C:\DataDir_GeoServer\gwc
>> ....
>>
>>
>> I'm out of ideas. What am I doing wrong?
>>
>> Thanks in advance,
>>
>>
>>
>>
>> ------------------------------------------------------------------------------
>> Keep Your Developer Skills Current with LearnDevNow!
>> The most comprehensive online learning library for Microsoft developers
>> is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
>> Metro Style Apps, more. Free future releases when you subscribe now!
>> http://p.sf.net/sfu/learndevnow-d2d
>> _______________________________________________
>> Geoserver-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/geoserver-users
>
>



------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Loading...