Travis Builds broken?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Travis Builds broken?

Seth G-2
Hi all,

The Travis MapServer builds seem to be failing at the moment with the following error:

E: Unable to locate package postgresql-9.1-postgis-2.1
E: Couldn't find any package by glob 'postgresql-9.1-postgis-2.1'
E: Couldn't find any package by regex 'postgresql-9.1-postgis-2.1'
E: Unable to locate package postgresql-9.1-postgis-2.1-scripts
E: Couldn't find any package by glob 'postgresql-9.1-postgis-2.1-scripts'
E: Couldn't find any package by regex 'postgresql-9.1-postgis-2.1-scripts'

The command "sudo apt-get install protobuf-c-compiler libprotobuf-c0-dev bison flex python-lxml libfribidi-dev swig cmake librsvg2-dev colordiff postgis postgresql-9.1 postgresql-9.1-postgis-2.1 postgresql-9.1-postgis-2.1-scripts libpq-dev libpng12-dev libjpeg-dev libgif-dev libgeos-dev libgd2-xpm-dev libfreetype6-dev libfcgi-dev libcurl4-gnutls-dev libcairo2-dev libgdal1-dev libproj-dev libxml2-dev python-dev php5-dev libexempi-dev lcov lftp" failed and exited with 100 during .

For example - https://travis-ci.org/mapserver/mapserver/builds/393190616

Have the postgis packages been removed from the repository?

Regards,

Seth



--
web:http://geographika.co.uk
twitter: @geographika
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: Travis Builds broken?

Sebastiaan Couwenberg
On 06/18/2018 07:15 AM, Seth G wrote:
> Have the postgis packages been removed from the repository?

Yes, the ubuntugis-unstable PPA has no packages for precise any more, see:

 https://lists.osgeo.org/pipermail/ubuntu/2018-June/001746.html

The Travis environment should be upgraded to a non-EOL release (i.e.
trusty or later).

Kind Regards,

Bas
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: Travis Builds broken?

Even Rouault-2
In reply to this post by Seth G-2
On lundi 18 juin 2018 07:15:30 CEST Seth G wrote:
> Hi all,
>
> The Travis MapServer builds seem to be failing at the moment with the
> following error:

I've ca PR to fix this:
https://github.com/mapserver/mapserver/pull/5615

Even

--
Spatialys - Geospatial professional services
http://www.spatialys.com
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: Travis Builds broken?

Seth G-2
Thanks Sebastian for the details, and Even for the PR.
Will be good to get the CI running again for the week of the 7.2 release!

--
web:http://geographika.co.uk
twitter: @geographika

On Mon, Jun 18, 2018, at 6:21 PM, Even Rouault wrote:

> On lundi 18 juin 2018 07:15:30 CEST Seth G wrote:
> > Hi all,
> >
> > The Travis MapServer builds seem to be failing at the moment with the
> > following error:
>
> I've ca PR to fix this:
> https://github.com/mapserver/mapserver/pull/5615
>
> Even
>
> --
> Spatialys - Geospatial professional services
> http://www.spatialys.com
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev