Quantcast

Tooltip with null value with Fusion(Internet Explorer)

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Tooltip with null value with Fusion(Internet Explorer)

Jose Cerrejon
I updated today the SVN and show a null value (see capture attached).

With Firefox works ok.

Machine: Server 2003, Mapguide 2.1, fusion SVN (26/04/10)

IE Null Value
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tooltip with null value with Fusion(Internet Explorer)

Jose Cerrejon
More info: This is the code in the browser (Internet Explorer). You can see the null text, now I'm exploring what is the cause of this null value.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML Strict//EN"><META http-equiv="Content-Type" content="text/html; charset=utf-8">
 
<HTML><BODY>
 
<DIV style="DISPLAY: none; TOP: 175px; LEFT: 457px" id="Maptip" class="maptipContainer" _eventCacheID="Maptip_eventCacheID_7">
null
<DIV class="maptipContent">
<DIV>
Farmacia<BR />Dirección: Luis Montoto, 56
</DIV>
<IFRAME style="WIDTH: 138px; HEIGHT: 36px" class="maptipShim" scrolling="no" frameborder="0"></IFRAME>
</DIV>
</DIV>
 
</BODY></HTML>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tooltip with null value with Fusion(Internet Explorer)

Michael Adair
Jose,

If you look at the firebug console, what is the response from the
QUERYMAPFEATRURES request?  That should be the same for IE/FF and you
should be able to see your null value there.  If not, I would step
through the _display() method of MapTip with a debugger to see where the
null is being set.

Mike

Jose Cerrejon wrote:

> More info: This is the code in the browser (Internet Explorer). You can see
> the null text, now I'm exploring what is the cause of this null value.
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML Strict//EN"><META
> http-equiv="Content-Type" content="text/html; charset=utf-8">
>  
> <HTML><BODY>
>  
> <DIV style="DISPLAY: none; TOP: 175px; LEFT: 457px" id="Maptip"
> class="maptipContainer" _eventCacheID="Maptip_eventCacheID_7">
> null
> <DIV class="maptipContent">
> <DIV>
> Farmacia<BR />Dirección: Luis Montoto, 56
> </DIV>
> <IFRAME style="WIDTH: 138px; HEIGHT: 36px" class="maptipShim" scrolling="no"
> frameborder="0"></IFRAME>
> </DIV>
> </DIV>
>  
> </BODY></HTML>
>
>
>  

--
   Michael Adair
   Senior Software Architect
   DM Solutions Group Inc.

   Office: (613) 565-5056 x26
   [hidden email]
   http://www.dmsolutions.ca
   http://research.dmsolutions.ca


_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tooltip with null value with Fusion(Internet Explorer)

Jose Cerrejon
The problem is the jxtheme.uncompressed.css from the turquoiseyellow theme...
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tooltip with null value with Fusion(Internet Explorer)

frosty1_4me
What was the solution to this issue?  I'm having the same prolblem with the Aqua theme.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tooltip with null value with Fusion(Internet Explorer)

GordonL
Correct this bug by fixing the Widget.
maptip.js - around line 191

if(this.domObj.style.visibility != 'visible' || oMapTip.t != this.szTip ){
this.domObj.innerHTML = null;

change to:
if(this.domObj.style.visibility != 'visible' || oMapTip.t != this.szTip ){
this.domObj.innerHTML = '';

of course you may have to search and replace in the compressed fusion js file.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tooltip with null value with Fusion(Internet Explorer)

Trevor Wekel
Hi Gordon,

Is this issue corrected in the MapGuide 2.2 RC3 build?  If not, can you log a defect for Fusion 2.2 and attach the patch?

Thanks,
Trevor

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of GordonL
Sent: March 7, 2011 8:22 PM
To: [hidden email]
Subject: [mapguide-users] Re: Tooltip with null value with Fusion(Internet Explorer)

Correct this bug by fixing the Widget.
maptip.js - around line 191


if(this.domObj.style.visibility != 'visible' || oMapTip.t != this.szTip ){
this.domObj.innerHTML = null;


change to:

if(this.domObj.style.visibility != 'visible' || oMapTip.t != this.szTip ){
this.domObj.innerHTML = '';


of course you may have to search and replace in the compressed fusion js
file.

--
View this message in context: http://osgeo-org.1803224.n2.nabble.com/Tooltip-with-null-value-with-Fusion-Internet-Explorer-tp4961399p6099994.html
Sent from the MapGuide Users mailing list archive at Nabble.com.
_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users


_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tooltip with null value with Fusion(Internet Explorer)

GordonL
Hi Trevor,
no this was not corrected.  It is still an issue.  I had to find the maptip.js and replace the Null with "" in the latest build.

(and the same with the fusion compressed js)

thanks
gordon


Loading...