Timeout when asking for a tile

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Timeout when asking for a tile

manel.clos
Hi,

I recently had a problem with a WMS Service serving a CAD file which takes ages to render tiles. The problem is TileCache (urllib2) timeouts after 30 seconds. I manually changed the code to increase the timeout:

Client.py:58
    response = self.client.open(urlrequest, timeout=120)

Will you accept a patch to set the timeout on layers configuration?

[layer_name]
type=WMS
timeout=120



Manel Clos
UMAT - 972419417
Ajuntament de Girona
_______________________________________________
Tilecache mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/tilecache
Reply | Threaded
Open this post in threaded view
|

Re: Timeout when asking for a tile

christopher.schmidt

On Apr 30, 2010, at 3:24 AM, ext [hidden email] wrote:

> Hi,
>
> I recently had a problem with a WMS Service serving a CAD file which takes ages to render tiles. The problem is TileCache (urllib2) timeouts after 30 seconds. I manually changed the code to increase the timeout:
>
> Client.py:58
>    response = self.client.open(urlrequest, timeout=120)
>
> Will you accept a patch to set the timeout on layers configuration?
>
> [layer_name]
> type=WMS
> timeout=120

Sure.

-- Chris_______________________________________________
Tilecache mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/tilecache
Reply | Threaded
Open this post in threaded view
|

RE: Timeout when asking for a tile

manel.clos
Hi,

I couldn't find a bug database link in the tilecache.org website, so sending it here.

Patch is against trunk.

I've checked layer definitions with and without the timeout parameter and they work ok.


> -----Mensaje original-----
> De: [hidden email]
> [mailto:[hidden email]]
> Enviado el: viernes, 30 de abril de 2010 15:36
> Para: Clos Crespo, Manel
> CC: [hidden email]
> Asunto: Re: [Tilecache] Timeout when asking for a tile
>
>
> On Apr 30, 2010, at 3:24 AM, ext [hidden email] wrote:
>
> > Hi,
> >
> > I recently had a problem with a WMS Service serving a CAD
> file which takes ages to render tiles. The problem is
> TileCache (urllib2) timeouts after 30 seconds. I manually
> changed the code to increase the timeout:
> >
> > Client.py:58
> >    response = self.client.open(urlrequest, timeout=120)
> >
> > Will you accept a patch to set the timeout on layers configuration?
> >
> > [layer_name]
> > type=WMS
> > timeout=120
>
> Sure.
>
> -- Chris
>

_______________________________________________
Tilecache mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/tilecache

tilecache_wms_timeout.patch (4K) Download Attachment