The new Firefox 3.6 does not work with mapbuilder. Any suggestions?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

The new Firefox 3.6 does not work with mapbuilder. Any suggestions?

John Mitchell
Hi,

The new Firefox 3.6 does not work with mapbuilder. 

Any suggestions?

Thanks,

John J. Mitchell

------------------------------------------------------------------------------
The Planet: dedicated and managed hosting, cloud storage, colocation
Stay online with enterprise data centers and the best network in the business
Choose flexible plans and management services without long-term contracts
Personal 24x7 support from experience hosting pros just a phone call away.
http://p.sf.net/sfu/theplanet-com
_______________________________________________
mapbuilder-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbuilder-devel
Reply | Threaded
Open this post in threaded view
|

Re: The new Firefox 3.6 does not work with mapbuilder. Any suggestions?

Rober corona
Hi John,

I have had the same problem. I have changed two files: MapBuilder.js and Config.js.
In MapBuilder.js:
Replace two lines:

 (75) this.checkScriptsLoaded=function() {
 (76)  //if (document.readyState!=null){
    if ((document.readyState)&&(navigator.userAgent.toLowerCase().indexOf("ie") > -1)){

  (135)    case MB_LOAD_CONFIG:
  (136)      //if(document.readyState){
  (137)       if ((document.readyState)&&(navigator.userAgent.toLowerCase().indexOf("ie") > -1)){
     
In Config.js:
To the final of the file:

/**
* Initialise the global config object for Mozilla browsers.
*/

if (navigator.userAgent.toLowerCase().indexOf("ie") > -1){
}else{
  mapbuilder.setLoadState(MB_LOAD_CONFIG);
  config=new Config(mbConfigUrl);
  config[config.id] = config;
  config.loadConfigScripts();
}

Bye.