Testing PROJ 5.0.0 release candidates

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Testing PROJ 5.0.0 release candidates

jmckenna
Administrator
Hi all,

I am wondering if anyone else has tested the PROJ 5 release candidates
(http://lists.maptools.org/pipermail/proj/2018-February/008045.html).  I
am testing RC5 on Windows, with MapServer branch-7-0 and GDAL 2.2.3, and
no problems with GDAL (reprojections with ogr2ogr etc), but any attempt
to reproject with MapServer returns a blank map image and the following
error in the logs:

msProjectRect(): Projection library error. All points failed to reproject.

Has anyone else tested this yet on any platforms?  Please let me know.

Thanks,

-jeff






_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: Testing PROJ 5.0.0 release candidates

jmckenna
Administrator
Update: MapServer and PROJ v5 were in fact reprojecting my test map, but
I was confused because (I was testing MS4W packages Mapbender and
GeoMOOSE demos) in fact the GeoMOOSE demo opening map was totally blank
(it should be a parcels line layer).  I went down rabbit holes trying to
find what was happening with PROJ v5 not displaying that data in
GeoMOOSE and MapServer......when in fact if I zoom out a bit the layer
is displayed properly (meaning the data extents have changed in the
displayed EPSG:3857 with PROJ v5).

I'll report to GeoMOOSE team.

Of course it could only be a mistake in my testing environment.

Sorry for all this noise here.

-jeff




On 2018-02-23 5:18 PM, Jeff McKenna wrote:

> Hi all,
>
> I am wondering if anyone else has tested the PROJ 5 release candidates
> (http://lists.maptools.org/pipermail/proj/2018-February/008045.html).  I
> am testing RC5 on Windows, with MapServer branch-7-0 and GDAL 2.2.3, and
> no problems with GDAL (reprojections with ogr2ogr etc), but any attempt
> to reproject with MapServer returns a blank map image and the following
> error in the logs:
>
> msProjectRect(): Projection library error. All points failed to reproject.
>
> Has anyone else tested this yet on any platforms?  Please let me know.
>
> Thanks,
>
> -jeff
>
>
>
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: Testing PROJ 5.0.0 release candidates

jmckenna
Administrator
For others interest: here is the upcoming release notes that explains
the PROJ API changes (we should still be able to use the old proj_api.h
API, as my tests have done, or tried):
http://lists.maptools.org/pipermail/proj/2018-February/007966.html

TODO: examine implementing proj.h API with MapServer.

Again sorry for all this noise, I just felt it was important to give
some feedback to PROJ team before that release.

Have a good weekend all,

-jeff




On 2018-02-24 7:40 PM, Jeff McKenna wrote:

> Update: MapServer and PROJ v5 were in fact reprojecting my test map, but
> I was confused because (I was testing MS4W packages Mapbender and
> GeoMOOSE demos) in fact the GeoMOOSE demo opening map was totally blank
> (it should be a parcels line layer).  I went down rabbit holes trying to
> find what was happening with PROJ v5 not displaying that data in
> GeoMOOSE and MapServer......when in fact if I zoom out a bit the layer
> is displayed properly (meaning the data extents have changed in the
> displayed EPSG:3857 with PROJ v5).
>
> I'll report to GeoMOOSE team.
>
> Of course it could only be a mistake in my testing environment.
>
> Sorry for all this noise here.
>
> -jeff
>
>
>
>
> On 2018-02-23 5:18 PM, Jeff McKenna wrote:
>> Hi all,
>>
>> I am wondering if anyone else has tested the PROJ 5 release candidates
>> (http://lists.maptools.org/pipermail/proj/2018-February/008045.html).  
>> I am testing RC5 on Windows, with MapServer branch-7-0 and GDAL 2.2.3,
>> and no problems with GDAL (reprojections with ogr2ogr etc), but any
>> attempt to reproject with MapServer returns a blank map image and the
>> following error in the logs:
>>
>> msProjectRect(): Projection library error. All points failed to
>> reproject.
>>
>> Has anyone else tested this yet on any platforms?  Please let me know.
>>
>> Thanks,
>>
>> -jeff
>>
>>

--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: Testing PROJ 5.0.0 release candidates

Michael Smith
Nice job Jeff, good to know the new PROJ release works fine with mapserver.

Mike


--
Michael Smith
Remote Sensing/GIS Center
US Army Corps of Engineers


On 2/24/18, 7:00 PM, "mapserver-dev on behalf of Jeff McKenna" <[hidden email] on behalf of [hidden email]> wrote:

    For others interest: here is the upcoming release notes that explains
    the PROJ API changes (we should still be able to use the old proj_api.h
    API, as my tests have done, or tried):
    http://lists.maptools.org/pipermail/proj/2018-February/007966.html
   
    TODO: examine implementing proj.h API with MapServer.
   
    Again sorry for all this noise, I just felt it was important to give
    some feedback to PROJ team before that release.
   
    Have a good weekend all,
   
    -jeff
   
   
   
   
    On 2018-02-24 7:40 PM, Jeff McKenna wrote:
    > Update: MapServer and PROJ v5 were in fact reprojecting my test map, but
    > I was confused because (I was testing MS4W packages Mapbender and
    > GeoMOOSE demos) in fact the GeoMOOSE demo opening map was totally blank
    > (it should be a parcels line layer).  I went down rabbit holes trying to
    > find what was happening with PROJ v5 not displaying that data in
    > GeoMOOSE and MapServer......when in fact if I zoom out a bit the layer
    > is displayed properly (meaning the data extents have changed in the
    > displayed EPSG:3857 with PROJ v5).
    >
    > I'll report to GeoMOOSE team.
    >
    > Of course it could only be a mistake in my testing environment.
    >
    > Sorry for all this noise here.
    >
    > -jeff
    >
    >
    >
    >
    > On 2018-02-23 5:18 PM, Jeff McKenna wrote:
    >> Hi all,
    >>
    >> I am wondering if anyone else has tested the PROJ 5 release candidates
    >> (http://lists.maptools.org/pipermail/proj/2018-February/008045.html).  
    >> I am testing RC5 on Windows, with MapServer branch-7-0 and GDAL 2.2.3,
    >> and no problems with GDAL (reprojections with ogr2ogr etc), but any
    >> attempt to reproject with MapServer returns a blank map image and the
    >> following error in the logs:
    >>
    >> msProjectRect(): Projection library error. All points failed to
    >> reproject.
    >>
    >> Has anyone else tested this yet on any platforms?  Please let me know.
    >>
    >> Thanks,
    >>
    >> -jeff
    >>
    >>
   
    --
    Jeff McKenna
    MapServer Consulting and Training Services
    http://www.gatewaygeomatics.com/
    _______________________________________________
    mapserver-dev mailing list
    [hidden email]
    https://lists.osgeo.org/mailman/listinfo/mapserver-dev


_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: Testing PROJ 5.0.0 release candidates

jmckenna
Administrator
In reply to this post by jmckenna
MapServer devs should take note that I was correct in my initial
testing: PROJ 5.0.0 breaks all transformations to and from the Google
"Web Mercator" projection (there is about a 10km shift).  You can read
my full report here and its long thread while testing RC5 and RC6 in
GDAL, MapServer, and PROJ (I tested on Ubuntu 14.04 and Windows):
http://lists.maptools.org/pipermail/proj/2018-February/008082.html

The fix will be available in the PROJ 5.0.1 release (early April).  I
encourage everyone to provide feedback directly to the PROJ team if you
can (there is also a Github ticket if you want to follow along, provide
testing feedback or comments: https://github.com/OSGeo/proj.4/issues/834 )

Thanks,

-jeff



On 2018-02-24 7:40 PM, Jeff McKenna wrote:

> Update: MapServer and PROJ v5 were in fact reprojecting my test map, but
> I was confused because (I was testing MS4W packages Mapbender and
> GeoMOOSE demos) in fact the GeoMOOSE demo opening map was totally blank
> (it should be a parcels line layer).  I went down rabbit holes trying to
> find what was happening with PROJ v5 not displaying that data in
> GeoMOOSE and MapServer......when in fact if I zoom out a bit the layer
> is displayed properly (meaning the data extents have changed in the
> displayed EPSG:3857 with PROJ v5).
>
> I'll report to GeoMOOSE team.
>
> Of course it could only be a mistake in my testing environment.
>
> Sorry for all this noise here.
>
> -jeff
>
>
>
>
> On 2018-02-23 5:18 PM, Jeff McKenna wrote:
>> Hi all,
>>
>> I am wondering if anyone else has tested the PROJ 5 release candidates
>> (http://lists.maptools.org/pipermail/proj/2018-February/008045.html).  
>> I am testing RC5 on Windows, with MapServer branch-7-0 and GDAL 2.2.3,
>> and no problems with GDAL (reprojections with ogr2ogr etc), but any
>> attempt to reproject with MapServer returns a blank map image and the
>> following error in the logs:
>>
>> msProjectRect(): Projection library error. All points failed to
>> reproject.
>>
>> Has anyone else tested this yet on any platforms?  Please let me know.
>>
>> Thanks,
>>
>> -jeff
>>
>>
--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev