Stuck Getting Started

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Stuck Getting Started

Rich Shepard
   It's been about 6 years since I last used GRASS (4.3), but it makes no
sense that I cannot get started on a project now. I'm using the svn download
from several days ago.

   1.) Created the database /usr4/grassdata

   2.) Within /usr4/ started grass: grass64

   3.) Tclgrass display comes up and asks again for the database; I enter
  that.

   4.) Click on 'Create new location using projection data'.

   5.) The antiquated text entry window displays. I again enter the database,
  the new location name (ORdem10), and the mapset (rbs).

   6.) I'm shown the list of coordinate systems and select D; enter the name
  'Oregon Conformal Conic' (which cannot be edited if I mistype a
  letter), and answer 'y' because it's correct.

   7.) Please enter a one line description for location <ORdem10>

> Oregon Conformal Conic
=====================================================
Oregon Conformal Conic
=====================================================
ok? (y/n) [y]
ERROR: region for current mapset is not set
        run "g.region"

ERROR: "/usr/local/grass-6.4.0RC5/etc/set_data" exited abnormally. Press
<enter> to continue.

   Can't enter the datum, ellipsoid, and other parameters to define this
dataset.

   Where do I start looking for the reason?

Rich
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Mark Seibel
You may find it easier to use the "EPSG codes" button, and pick the
code to match your projection/coordinate system.

There is the epsg and esri projection files.  In Karmic Koaloa
Kubuntu, they reside in /usr/share/proj/

Mark

On Fri, Nov 13, 2009 at 1:16 PM, Rich Shepard <[hidden email]> wrote:

>  It's been about 6 years since I last used GRASS (4.3), but it makes no
> sense that I cannot get started on a project now. I'm using the svn download
> from several days ago.
>
>  1.) Created the database /usr4/grassdata
>
>  2.) Within /usr4/ started grass: grass64
>
>  3.) Tclgrass display comes up and asks again for the database; I enter
>        that.
>
>  4.) Click on 'Create new location using projection data'.
>
>  5.) The antiquated text entry window displays. I again enter the database,
>        the new location name (ORdem10), and the mapset (rbs).
>
>  6.) I'm shown the list of coordinate systems and select D; enter the name
>        'Oregon Conformal Conic' (which cannot be edited if I mistype a
>        letter), and answer 'y' because it's correct.
>
>  7.) Please enter a one line description for location <ORdem10>
>
>> Oregon Conformal Conic
>
> =====================================================
> Oregon Conformal Conic
> =====================================================
> ok? (y/n) [y] ERROR: region for current mapset is not set
>       run "g.region"
>
> ERROR: "/usr/local/grass-6.4.0RC5/etc/set_data" exited abnormally. Press
> <enter> to continue.
>
>  Can't enter the datum, ellipsoid, and other parameters to define this
> dataset.
>
>  Where do I start looking for the reason?
>
> Rich
> _______________________________________________
> grass-user mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/grass-user
>
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Paul Kelly
In reply to this post by Rich Shepard
On Fri, 13 Nov 2009, Rich Shepard wrote:

> ok? (y/n) [y] ERROR: region for current mapset is not set
>       run "g.region"
>
> ERROR: "/usr/local/grass-6.4.0RC5/etc/set_data" exited abnormally. Press
> <enter> to continue.
>
>  Can't enter the datum, ellipsoid, and other parameters to define this
> dataset.
>
>  Where do I start looking for the reason?

This sounds to me like a known bug in 6.4.0 RC5
<http://trac.osgeo.org/grass/ticket/648> - maybe try the latest 6.4 SVN
snapshot instead of RC5?

Paul
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Rich Shepard
On Fri, 13 Nov 2009, Paul Kelly wrote:

> This sounds to me like a known bug in 6.4.0 RC5
> <http://trac.osgeo.org/grass/ticket/648> - maybe try the latest 6.4 SVN
> snapshot instead of RC5?

Paul,

   After initially building and installing the stable 6.4.0RC5, I was advised
to grab the svn trunk instead. I did so on Nov 10th. That's the code I built
and installed. Perhaps I need to uninstall and redo the process.

Thanks,

Rich

--
Richard B. Shepard, Ph.D.               |  Integrity            Credibility
Applied Ecosystem Services, Inc.        |            Innovation
<http://www.appl-ecosys.com>     Voice: 503-667-4517      Fax: 503-667-8863
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Rich Shepard
In reply to this post by Paul Kelly
On Fri, 13 Nov 2009, Paul Kelly wrote:

> This sounds to me like a known bug in 6.4.0 RC5
> <http://trac.osgeo.org/grass/ticket/648> - maybe try the latest 6.4 SVN
> snapshot instead of RC5?

Paul,

   Just tried to download the latest code < svn checkout
https://svn.osgeo.org/grass/grass/tags/release_20090609_grass_6_4_0RC5
grass640_rc5> and I already have revision 39721 checked out. So I must be
using the latest.

   In what file is the code for the initial text display in which the
database, location, and map set is specified?

Thanks,

Rich

_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Paul Kelly
On Fri, 13 Nov 2009, Rich Shepard wrote:

> On Fri, 13 Nov 2009, Paul Kelly wrote:
>
>> This sounds to me like a known bug in 6.4.0 RC5
>> <http://trac.osgeo.org/grass/ticket/648> - maybe try the latest 6.4 SVN
>> snapshot instead of RC5?
>
> Paul,
>
>  Just tried to download the latest code < svn checkout
> https://svn.osgeo.org/grass/grass/tags/release_20090609_grass_6_4_0RC5
> grass640_rc5> and I already have revision 39721 checked out. So I must be
> using the latest.

As far as I understand it that just means you are using the latest version
of the version tagged release_20090609_grass_6_4_0RC5 - for the latest 6.4
SVN you want the 6.4 branch rather than any specific tagged version:
https://svn.osgeo.org/grass/grass/branches/releasebranch_6_4
should be the one I think.

Paul
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Rich Shepard
On Fri, 13 Nov 2009, Paul Kelly wrote:

> As far as I understand it that just means you are using the latest version
> of the version tagged release_20090609_grass_6_4_0RC5 - for the latest 6.4
> SVN you want the 6.4 branch rather than any specific tagged version:
> https://svn.osgeo.org/grass/grass/branches/releasebranch_6_4 should be the
> one I think.

Paul,

   Hokay ... did the svn -co to a new directory and at the end I'm told that
I've checked out revision 39721. That's the same revision as before. So I
was using the latest code when I ran into that brick wall.

   I'll take a look at the bug report, too.

Rich
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Rich Shepard
In reply to this post by Paul Kelly
On Fri, 13 Nov 2009, Paul Kelly wrote:

> This sounds to me like a known bug in 6.4.0 RC5
> <http://trac.osgeo.org/grass/ticket/648> - maybe try the latest 6.4 SVN
> snapshot instead of RC5?

Paul,

   Yup. That's the bug I hit. And did so in the latest svn 6.4 branch
download (build 39721).

Rich
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Rich Shepard
In reply to this post by Paul Kelly
On Fri, 13 Nov 2009, Paul Kelly wrote:

> This sounds to me like a known bug in 6.4.0 RC5
> <http://trac.osgeo.org/grass/ticket/648> - maybe try the latest 6.4 SVN
> snapshot instead of RC5?

Paul,

   I forgot to mention that I hit this bug regardless of the UI: tcl or
python.

Rich
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Paul Kelly
In reply to this post by Rich Shepard
On Fri, 13 Nov 2009, Rich Shepard wrote:

> On Fri, 13 Nov 2009, Paul Kelly wrote:
>
>> As far as I understand it that just means you are using the latest version
>> of the version tagged release_20090609_grass_6_4_0RC5 - for the latest 6.4
>> SVN you want the 6.4 branch rather than any specific tagged version:
>> https://svn.osgeo.org/grass/grass/branches/releasebranch_6_4 should be the
>> one I think.
>
> Paul,
>
>  Hokay ... did the svn -co to a new directory and at the end I'm told that
> I've checked out revision 39721. That's the same revision as before. So I
> was using the latest code when I ran into that brick wall.

Sorry don't think I was clear enough - any branch, tag or version that you
update from SVN at this moment in time will show revision 39721, as that
is simply the latest change to have been made anywhere in the entire SVN
tree.

Paul

_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started

Rich Shepard
On Fri, 13 Nov 2009, Paul Kelly wrote:

> Sorry don't think I was clear enough - any branch, tag or version that you
> update from SVN at this moment in time will show revision 39721, as that
> is simply the latest change to have been made anywhere in the entire SVN
> tree.

Paul,

   Ah! Now I'm on the same page as you are. I'll build and install and see if
that makes a difference.

Thanks,

Rich
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: Stuck Getting Started -- FIXED

Rich Shepard
In reply to this post by Paul Kelly
On Fri, 13 Nov 2009, Paul Kelly wrote:

> Sorry don't think I was clear enough - any branch, tag or version that you
> update from SVN at this moment in time will show revision 39721, as that
> is simply the latest change to have been made anywhere in the entire SVN
> tree.

Paul,

   The latest code fixed the problem. Using the wxPython UI I was able to
specify the data base and name the location and map set. Entering the
projection information went well, except there is no widget to enter units.
That bit me running r.in.gdal from within the GUI. That's another thread.

Many thanks,

Rich
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user