String cannot be cast to LinearRing

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

String cannot be cast to LinearRing

Ryan Gosse
Email signature WIP
Hi,

I’m trying to write a plugin for GeoNetwork and got stuck on this error from my extract-gml.xsl file (https://pastebin.com/vR1DDhkx) when I try to ingest this record (https://pastebin.com/bxcJisbh). This is the stacktrace: https://pastebin.com/4LiYeEua. I’m not really sure what’s going wrong. I tried multiple formats for capturing the polygon (like the one’s in here: https://github.com/geonetwork/core-geonetwork/blob/master/schemas/iso19139/src/main/plugin/iso19139/extract-gml.xsl) and they all give me the same error. Any help would be great!

Thanks,
Ryan Gosse

MERIDIAN on blue circle containing many numbers, with an orange wave pulse to the right.
Ryan Gosse
Data and Infrastructure Manager
MERIDIAN - Marine Environmental Research Infrastructure for Data Integration and Application Network
Institute for Big Data Analytics, Faculty of Computer Sciences, Dalhousie University
p: + 1 902 494 1812 m: +1 902 880 1863
a: 6050 University Ave, Halifax, NS, B3H 4R2, Canada
w: https://meridian.cs.dal.ca e: [hidden email]


_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork