Shapefile problem

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Shapefile problem

Blaz
When i open my shapefile with TatukGis Viewer i can see it perfectly. But when i load it into GeoServer (add a new FeatureStores and then new FeatureType) and try to display it in uDig (using wfs import from my local GeoServer) i can not see a thing. uDig puts exclamation sign infront of the imported shapefile. Am i doing something wrong? I set Feature Type SRS to 4326. I checked other FeatureTypes and they worked. Is it normal that Min Long,  Min Lat... are huge numbers, like: 5012202.219176441?

And if i test:

http://localhost:8080/geoserver/wfs?request=getfeature&service=wfs&version=1.0.0&typename=test_shapefile

i get proper gml that i can open in TatukGIS and see the correct result!!
Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: Shapefile problem

Chris Tweedie-2
It looks like the shapefile you are trying to use are in a projected
coordinate system. If there is a prj file I would open that up to
determine what system the file is actually in and then use the relevant
EPSG code in the FeatureType ... using 4326 is definitely wrong :)

Chris

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of
GeoUser
Sent: Monday, 3 July 2006 4:46 PM
To: [hidden email]
Subject: [Geoserver-users] Shapefile problem


When i open my shapefile with TatukGis Viewer i can see it perfectly.
But
when i load it into GeoServer (add a new FeatureStores and then new
FeatureType) and try to display it in uDig (using wfs import from my
local
GeoServer) i can not see a thing. uDig puts exclamation sign infront of
the
imported shapefile. Am i doing something wrong? I set Feature Type to
4326.
I checked other FeatureTypes and they worked. Is it normal that Min
Long,
Min Lat... are huge numbers, like: 5012202.219176441?

And if i test:

http://localhost:8080/geoserver/wfs?request=getfeature&service=wfs&versi
on=1.0.0&typename=test_shapefile

i get proper gml that i can open in TatukGIS and see the correct
result!!
Thanks!
--
View this message in context:
http://www.nabble.com/Shapefile-problem-tf1883321.html#a5148438
Sent from the GeoServer - User forum at Nabble.com.


Using Tomcat but need to do more? Need to support web services,
security?
Get stuff done quickly with pre-integrated technology to make your job
easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users

This e-mail and any files transmitted with it are intended only for the use of the addressee(s).  It may contain information that is confidential and privileged.  If you are not an intended recipient, any use, interference with, disclosure, distribution or copying of this material is unauthorised and prohibited.  If you receive this in error, please notify the author by Return email to the sender.  Information in this message not relating to the official business of DLI shall be understood as neither given nor endorsed by it.  While every care is taken, it is recommended that you scan any attachments for viruses.  DLI liability is limited to re-supplying affected attachments.

**********************  

PLEASE NOTE: All dola.wa.gov.au and vgo.wa.gov.au email addresses have been decommissioned. These have been replaced by dli.wa.gov.au addresses. Please ensure that your records are updated to reflect this change.  Further information can be obtained by contacting our service desk on 92737533 or emailing [hidden email]

**********************
   


Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Shapefile problem

Blaz
Yes, there is a prj file. It looks like this:

PROJCS["WGS_1984_UTM_Zone_33N",GEOGCS["GCS_WGS_1984",DATUM["D_WGS_1984",SPHEROID["WGS_1984",6378137,298.257223563]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]],PROJECTION["Transverse_Mercator"],PARAMETER["False_Easting",500000],PARAMETER["False_Northing",0],PARAMETER["Central_Meridian",15],PARAMETER["Scale_Factor",0.9996],PARAMETER["Latitude_Of_Origin",0],UNIT["m",1]]

So i think the normal SRS is 4326 (WGS 1984 Lat/long)????

But if Geoserver creates GML and I save it. Then i open it with TatukGIS i can see it ok. So there must be a problem with something else...

there's one more thing. if i display this shape in uDig using wms import i can see the raster of this shape! so why can't i see the shape using wfs import?
Reply | Threaded
Open this post in threaded view
|

Re: Shapefile problem

Blaz
now i know what's wrong. uDig generates this xml file:

<GetFeature xmlns="http://www.opengis.net/wfs" 
                        xmlns:gml="http://www.opengis.net/gml" 
                        xmlns:ogc="http://www.opengis.net/ogc" 
                        version="1.0.0"
                        service="WFS"
                        outputFormat="GML2">
                        <Query typeName="topp:shape">
                                <ogc:PropertyName>the_geom</ogc:PropertyName>
                                <ogc:Filter>
                                        <ogc:BBOX>
                                                <ogc:PropertyName>the_geom</ogc:PropertyName>
                                                <gml:Box>
                                                        <gml:coordinates decimal="." cs="," ts=" ">289542.431325941,5012202.219176441 349647.404327753,5012202.219176441</gml:coordinates>
                                                </gml:Box>
                                        </ogc:BBOX>
                                </ogc:Filter>
                        </Query>
</GetFeature>

and the server returns nothing. but if i remove the FILTER from the request i get a result.

what could be wrong that the filter filters out all the data?
Reply | Threaded
Open this post in threaded view
|

Re: Shapefile problem

Brent Owens-2
It is just a bounding box filter, which comes back to the unknown SRS
value. UDig isn't broken here, it is relying on your specified SRS value .
Your .prj file says that the projection is a UTM zone, so not lat/lon.
You just need to look for the SRS value corresponding to UTM zone 33N.

Brent Owens
(The Open Planning Project)



GeoUser wrote:

> now i know what's wrong. uDig generates this xml file:
>
> <GetFeature xmlns="http://www.opengis.net/wfs"
> xmlns:gml="http://www.opengis.net/gml"
> xmlns:ogc="http://www.opengis.net/ogc"
> version="1.0.0"
> service="WFS"
> outputFormat="GML2">
> <Query typeName="topp:shape">
> <ogc:PropertyName>the_geom</ogc:PropertyName>
> <ogc:Filter>
> <ogc:BBOX>
> <ogc:PropertyName>the_geom</ogc:PropertyName>
> <gml:Box>
> <gml:coordinates decimal="." cs="," ts="
> ">289542.431325941,5012202.219176441,349647.404327753,5012202.219176441</gml:coordinates>
> </gml:Box>
> </ogc:BBOX>
> </ogc:Filter>
> </Query>
> </GetFeature>
>
> and the server returns nothing. but if i remove the FILTER from the request
> i get a result.
>
> what could be wrong that the filter filters out all the data?
>  

--
Brent Owens
(The Open Planning Project)


Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Shapefile problem

Blaz
I tried every SRS value corresponding to UTM zone 33N and the result was allways the same.

This is interesting...

I cannot see the shape in  uDig but i can select its parts using the uDig select Feature Tool. I click on the map (where there's nothing drawn) and i can select the invisible shape.... then i can see it's properities etc... i tried changing color but nothing happened :)
Reply | Threaded
Open this post in threaded view
|

Re: Shapefile problem

Blaz
problem solved. i guess there was a problem with uDig because when i installed the new version of uDig it all started working like it should...

thank you all for help