Quantcast

SLD / KML bug?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

SLD / KML bug?

Gavin Fleming

Hi

 

I’ve just tried out a new ArcGIS-SLD converter (http://arcmap2sld.geoinform.fh-mainz.de/ArcMap2SLDConverter_Eng.htm) and used it to generate and validate an SLD doc.

 

I then applied the SLD to a the same (PostGIS) layer in uDig and validated it there and it worked fine.

 

The problem appears when I apply it in GeoServer. uDig and OpenLayers interact with it through WMS just fine. However, QGIS gets bounding coordinates wrong and behaves rather strangely with it and Google Earth gives this error (‘mismatched tag’ if you don’t get the screendump image), looks like GeoServer’s not generating good KML:

 

 

Here are the GeoServer Demo links to the layer in question and attached is the sld file. I wonder if it is an SLD version issue?

 

OpenLayers   KML  

 

Another related question: When you tick ‘Validate’ on the Style screen in GeoServer you get no feedback about validation when submitting, whether it validates or not, it just accepts the SLD. Is that intentional?

 

Gavin

 

 


-------------------------------------------------------------------------
Sponsored by: SourceForge.net Community Choice Awards: VOTE NOW!
Studies have shown that voting for your favorite open source project,
along with a healthy diet, reduces your potential for chronic lameness
and boredom. Vote Now at http://www.sourceforge.net/community/cca08
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users

dmerehab.sld (22K) Download Attachment
Loading...