SFCGAL version requirements?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

SFCGAL version requirements?

Paul Ramsey
Regarding this stackexchange question:


Is it possible that PostGIS 2.2 requires SFCGAL 1.3? If so, our configure script should be doing a version test, but I don't see that happening in the configure.ac.

P.

_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: SFCGAL version requirements?

Sebastiaan Couwenberg
On 08/03/2016 03:19 PM, Paul Ramsey wrote:
> Regarding this stackexchange question:
>
> https://gis.stackexchange.com/questions/204575/libsfcgal-so-1-undefined-symbol-upgrading-to-postgis-2-2-2
>
> Is it possible that PostGIS 2.2 requires SFCGAL 1.3? If so, our configure
> script should be doing a version test, but I don't see that happening in
> the configure.ac.

I don't think so, OSGeo-Live built PostGIS 2.2.2 with SFCGAL 1.2.2
without issue.

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1
_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: SFCGAL version requirements?

Paul Ramsey
Right, it will build OK, but you'll be missing some functions. I see tests for 

POSTGIS_SFCGAL_VERSION

in the code. So if I build against 1.3 and then deploy against 1.2 I'll have symbols missing, as in the question. I guess this is a packager problem really, someone built against 1.3 but didn't declare a tight version dependency.

P.


On Wed, Aug 3, 2016 at 6:27 AM, Sebastiaan Couwenberg <[hidden email]> wrote:
On 08/03/2016 03:19 PM, Paul Ramsey wrote:
> Regarding this stackexchange question:
>
> https://gis.stackexchange.com/questions/204575/libsfcgal-so-1-undefined-symbol-upgrading-to-postgis-2-2-2
>
> Is it possible that PostGIS 2.2 requires SFCGAL 1.3? If so, our configure
> script should be doing a version test, but I don't see that happening in
> the configure.ac.

I don't think so, OSGeo-Live built PostGIS 2.2.2 with SFCGAL 1.2.2
without issue.

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1
_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel


_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: SFCGAL version requirements?

Paul Ramsey
Hah, only one function has a version dependency, 

Datum sfcgal_approximate_medial_axis(PG_FUNCTION_ARGS)

probably it's new so the packager got bitten this time out.


On Wed, Aug 3, 2016 at 6:55 AM, Paul Ramsey <[hidden email]> wrote:
Right, it will build OK, but you'll be missing some functions. I see tests for 

POSTGIS_SFCGAL_VERSION

in the code. So if I build against 1.3 and then deploy against 1.2 I'll have symbols missing, as in the question. I guess this is a packager problem really, someone built against 1.3 but didn't declare a tight version dependency.

P.


On Wed, Aug 3, 2016 at 6:27 AM, Sebastiaan Couwenberg <[hidden email]> wrote:
On 08/03/2016 03:19 PM, Paul Ramsey wrote:
> Regarding this stackexchange question:
>
> https://gis.stackexchange.com/questions/204575/libsfcgal-so-1-undefined-symbol-upgrading-to-postgis-2-2-2
>
> Is it possible that PostGIS 2.2 requires SFCGAL 1.3? If so, our configure
> script should be doing a version test, but I don't see that happening in
> the configure.ac.

I don't think so, OSGeo-Live built PostGIS 2.2.2 with SFCGAL 1.2.2
without issue.

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1
_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel



_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: SFCGAL version requirements?

Sebastiaan Couwenberg
On 08/03/2016 03:56 PM, Paul Ramsey wrote:
> probably it's new so the packager got bitten this time out.

It looks more like a user error to me. SFCGAL 1.2.2 is included in
Ubuntu xenial, which also has PostgreSQL 9.5, not 9.3.

It seems the user has installed old packages from PGDG or some other 3rd
party repository.

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1
_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: SFCGAL version requirements?

Paul Ramsey
Should the packager not declare their libsfcgal version dependency?

On Wed, Aug 3, 2016 at 7:32 AM, Sebastiaan Couwenberg <[hidden email]> wrote:
On 08/03/2016 03:56 PM, Paul Ramsey wrote:
> probably it's new so the packager got bitten this time out.

It looks more like a user error to me. SFCGAL 1.2.2 is included in
Ubuntu xenial, which also has PostgreSQL 9.5, not 9.3.

It seems the user has installed old packages from PGDG or some other 3rd
party repository.

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1
_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel


_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: SFCGAL version requirements?

Sebastiaan Couwenberg
On 08/03/2016 04:37 PM, Paul Ramsey wrote:
> Should the packager not declare their libsfcgal version dependency?

The Debian package*s* use the symbols files to determine the minimum
required version, and that show that SFCGAL 1.3.0 is not required yet:

 $ apt-cache show liblwgeom-2.2-5 | grep sfcgal
 Depends: libc6 (>= 2.14), libgeos-c1v5 (>= 3.5.0),
  libjson-c3 (>= 0.10), libproj9 (>= 4.9.0), libsfcgal1 (>= 1.1.0)

 $ apt-cache show postgresql-9.5-postgis-2.2 | grep sfcgal
 Depends: libc6 (>= 2.14), libgdal20 (>= 2.0.1),
  libgeos-c1v5 (>= 3.5.0), libjson-c3 (>= 0.11),
  liblwgeom-2.2-5 (>= 2.2.0), libpcre3, libproj9 (>= 4.9.0),
  libsfcgal1 (>= 1.2.0), libxml2 (>= 2.7.4), postgresql-9.5,
  postgresql-9.5-postgis-2.2-scripts

The biggest question for the SE issue is where did the user get its
packages from. It looks like a typical mess caused by using 3rd party
repositories.

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1
_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel