Renderingerror in Polygon Stroke (with “islands”) when using External Graphics.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Renderingerror in Polygon Stroke (with “islands”) when using External Graphics.

Anders.Soderman@gisassistans.se
Hopefully it also shows up in: http://ec2-75-101-205-144.compute-1.amazonaws.com:8080/geoserver/AWS/wms?service=WMS&version=1.1.0&request=GetMap&layers=AWS:n2000_sci_ej_alvar_101110&styles=&bbox=258605.688,6126818.0,920451.75,7671056.0&width=219&height=512&srs=EPSG:3006&format=application/openlayers Scale = 1 : 11K at approx. E692090, N6559050 ESPG:3006 The relevant part of the SLD: … image/svg+xml 28 20 90 50 … Anybody who has seen this before? Regards Anders Söderman Stockholm Sweden
Reply | Threaded
Open this post in threaded view
|

Re: Renderingerror in Polygon Stroke (with “islands”) when using External Graphics.

Anders.Soderman@gisassistans.se
... something happend to the SLD - here it comes again:

The relevant part of the SLD:

      <FeatureTypeStyle>

        <Rule>
          <PolygonSymbolizer>
             <Stroke>
               <GraphicStroke>
                <Graphic>
                 <ExternalGraphic>
                   <OnlineResource xlink:type="simple" xlink:href="http://www.gisassistans.se/svg/${lmark200x400}"/>
                   <Format>image/svg+xml</Format>
                  </ExternalGraphic> 
                  <Size>
                   <ogc:Literal>28</ogc:Literal>
                  </Size>
                </Graphic>
               </GraphicStroke>
              <CssParameter name="stroke-dasharray">20 90</CssParameter>
              <CssParameter name="stroke-offset">50</CssParameter>
              </Stroke>
          </PolygonSymbolizer>
         </Rule>
      </FeatureTypeStyle>