Re: [postgis] 01/01: Update pgversions to require PostgreSQL 9.2 or newer.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [postgis] 01/01: Update pgversions to require PostgreSQL 9.2 or newer.

Markus Wanner
Hello Bas, hello PostGIS devs,

On 09/27/2016 07:50 PM, Sebastiaan Couwenberg wrote:
> PostGIS is compatible with PostgreSQL 9.1 and above.

That's what I thought as well, but configure.ac has a different opinion.

@upstream: could you please clarify: is PostGIS 2.3 supposed to be
compatible against PostgreSQL 9.1?

Kind Regards

Markus



_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel

signature.asc (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [postgis] 01/01: Update pgversions to require PostgreSQL 9.2 or newer.

Sebastiaan Couwenberg
On 09/27/2016 09:57 PM, Markus Wanner wrote:
> On 09/27/2016 07:50 PM, Sebastiaan Couwenberg wrote:
>> PostGIS is compatible with PostgreSQL 9.1 and above.
>
> That's what I thought as well, but configure.ac has a different opinion.

configure.ac was indeed changed in 2.3.0, but not README.postgis.

I'll send a patch for that.

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1


_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel

signature.asc (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [postgis] 01/01: Update pgversions to require PostgreSQL 9.2 or newer.

Regina Obe
In reply to this post by Markus Wanner
No PostGIS 2.3 is not compatible with PostgreSQL 9.1.

As I recall I think it compiles fine against (without our change in
configure), but we dropped support for it since

1) it is EOL this month
(https://www.postgresql.org/docs/9.1/static/release-9-1-23.html )
2) Some of the raster tests started failing with recent raster changes.

Sorry about that.   I've corrected the readme.

Thanks,
Regina

-----Original Message-----
From: postgis-devel [mailto:[hidden email]] On Behalf
Of Markus Wanner
Sent: Tuesday, September 27, 2016 3:57 PM
To: Sebastiaan Couwenberg <[hidden email]>; PostGIS Development
Discussion <[hidden email]>
Cc: [hidden email]
Subject: Re: [postgis-devel] [postgis] 01/01: Update pgversions to require
PostgreSQL 9.2 or newer.

Hello Bas, hello PostGIS devs,

On 09/27/2016 07:50 PM, Sebastiaan Couwenberg wrote:
> PostGIS is compatible with PostgreSQL 9.1 and above.

That's what I thought as well, but configure.ac has a different opinion.

@upstream: could you please clarify: is PostGIS 2.3 supposed to be
compatible against PostgreSQL 9.1?

Kind Regards

Markus



_______________________________________________
postgis-devel mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-devel