Re: geonode-devel Digest, Vol 37, Issue 21

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: geonode-devel Digest, Vol 37, Issue 21

Thomas Gertin-2
I ran into the same issue you had today SILVIA.

I noticed that for for the pypy GeoNode 2.6.1 package (https://pypi.python.org/pypi/GeoNode/2.6.1), the requirements.txt file lists django-polymorphic as

django-polymorphic>=0.9.2

However, as stated in the django-polymorphic GitHub repo, django-polymorphic==1.3 should be installed for Django 1.11.

Can you try uninstalling django-polymorphic, and installing version 1.3?


To all,

Can we put 'django-polymorphic==1.3' in the requirements.txt for GeoNode 2.6.1?


I am having problems now with awesome-slugify installing correctly, but I need think I need to look into this further.


Thanks,

Tom G.



> On Feb 13, 2018, at 3:00 PM, [hidden email] wrote:
>
> Send geonode-devel mailing list submissions to
> [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> https://lists.osgeo.org/mailman/listinfo/geonode-devel
> or, via email, send a message with subject or body 'help' to
> [hidden email]
>
> You can reach the person managing the list at
> [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of geonode-devel digest..."
>
>
> Today's Topics:
>
>   1. pkg_resources.VersionConflict when python manage.py migrate
>      (SILVIA GAMERO)
>   2. Re: pkg_resources.VersionConflict when python manage.py
>      migrate (Simone Dalmasso)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 12 Feb 2018 16:09:15 -0600
> From: SILVIA GAMERO <[hidden email]>
> To: [hidden email]
> Subject: [GeoNode-devel] pkg_resources.VersionConflict when python
> manage.py migrate
> Message-ID:
> <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> I have problems with geonode2.6x on Centos7, when migrating the data from
> python manage.py migrate or try to start geonode ..
>
> Traceback (most recent call last):
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File
> "/usr/lib/python2.7/site-packages/django/core/management/commands/runserver.py",
> line 107, in inner_run
>    autoreload.raise_last_exception()
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 252, in raise_last_exception
>    six.reraise(*_exception)
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
> setup
>    apps.populate(settings.INSTALLED_APPS)
>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line 85,
> in populate
>    app_config = AppConfig.create(entry)
>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
> in create
>    module = import_module(entry)
>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
> import_module
>    __import__(name)
>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line 13,
> in <module>
>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
> require
>    needed = self.resolve(parse_requirements(requirements))
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
> resolve
>    raise VersionConflict(dist,req) # XXX put more info here
> pkg_resources.VersionConflict: (Django 1.8.18
> (/usr/lib/python2.7/site-packages), Requirement.parse('Django>=1.11'))
>
> I followed the steps of the installation guide, although I commented that I
> have not done the process that explain for the development mode, but
> starting from the installation of postgres, tomcat, geoserver and finally
> geonode.
> With these same steps I had done a previous installation but I had problems
> wanting to upload shapes to geonode or geoserver so I had to reinstall
> everything again.
>
> The version of Django that I am currently observing is the 1.8.18
>
> I would greatly appreciate the help of someone who has already been able to
> do the installation correctly.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180212/9f36e2e5/attachment-0001.html>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 13 Feb 2018 07:20:16 +0100
> From: Simone Dalmasso <[hidden email]>
> To: SILVIA GAMERO <[hidden email]>
> Cc: geonode-devel <[hidden email]>
> Subject: Re: [GeoNode-devel] pkg_resources.VersionConflict when python
> manage.py migrate
> Message-ID:
> <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> Hi, your django version is correct but looks like other libraries are not,
> like polymorphic. I suggest to run pip install -r requirements.txt again.
>
> 2018-02-12 23:09 GMT+01:00 SILVIA GAMERO <[hidden email]>:
>
>> I have problems with geonode2.6x on Centos7, when migrating the data from
>> python manage.py migrate or try to start geonode ..
>>
>> Traceback (most recent call last):
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/core/
>> management/commands/runserver.py", line 107, in inner_run
>>    autoreload.raise_last_exception()
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 252, in raise_last_exception
>>    six.reraise(*_exception)
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
>> setup
>>    apps.populate(settings.INSTALLED_APPS)
>>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line
>> 85, in populate
>>    app_config = AppConfig.create(entry)
>>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
>> in create
>>    module = import_module(entry)
>>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
>> import_module
>>    __import__(name)
>>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line
>> 13, in <module>
>>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
>> require
>>    needed = self.resolve(parse_requirements(requirements))
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
>> resolve
>>    raise VersionConflict(dist,req) # XXX put more info here
>> pkg_resources.VersionConflict: (Django 1.8.18 (/usr/lib/python2.7/site-packages),
>> Requirement.parse('Django>=1.11'))
>>
>> I followed the steps of the installation guide, although I commented that
>> I have not done the process that explain for the development mode, but
>> starting from the installation of postgres, tomcat, geoserver and finally
>> geonode.
>> With these same steps I had done a previous installation but I had
>> problems wanting to upload shapes to geonode or geoserver so I had to
>> reinstall everything again.
>>
>> The version of Django that I am currently observing is the 1.8.18
>>
>> I would greatly appreciate the help of someone who has already been able
>> to do the installation correctly.
>>
>>
>> _______________________________________________
>> geonode-devel mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>>
>>
>
>
> --
> Simone
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180213/365c2a0e/attachment-0001.html>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> geonode-devel mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>
>
> ------------------------------
>
> End of geonode-devel Digest, Vol 37, Issue 21
> *********************************************

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: geonode-devel Digest, Vol 37, Issue 21

Simo D
Dear Tom,

GeoNode 2.6 runs with Django 1.8 so we need to stay with it. I'm wondering why the 1.11 is installed.

Silvia and others also ran in the issue with slugify lately so we need to investigate what happens there. We haven0t changes the 2.6.x as far as I know so something must have changed in the dependencies.

2018-02-14 12:54 GMT+01:00 Thomas Gertin <[hidden email]>:
I ran into the same issue you had today SILVIA.

I noticed that for for the pypy GeoNode 2.6.1 package (https://pypi.python.org/pypi/GeoNode/2.6.1), the requirements.txt file lists django-polymorphic as

django-polymorphic>=0.9.2

However, as stated in the django-polymorphic GitHub repo, django-polymorphic==1.3 should be installed for Django 1.11.

Can you try uninstalling django-polymorphic, and installing version 1.3?


To all,

Can we put 'django-polymorphic==1.3' in the requirements.txt for GeoNode 2.6.1?


I am having problems now with awesome-slugify installing correctly, but I need think I need to look into this further.


Thanks,

Tom G.



> On Feb 13, 2018, at 3:00 PM, [hidden email] wrote:
>
> Send geonode-devel mailing list submissions to
>       [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>       https://lists.osgeo.org/mailman/listinfo/geonode-devel
> or, via email, send a message with subject or body 'help' to
>       [hidden email]
>
> You can reach the person managing the list at
>       [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of geonode-devel digest..."
>
>
> Today's Topics:
>
>   1. pkg_resources.VersionConflict when python manage.py      migrate
>      (SILVIA GAMERO)
>   2. Re: pkg_resources.VersionConflict when python manage.py
>      migrate (Simone Dalmasso)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 12 Feb 2018 16:09:15 -0600
> From: SILVIA GAMERO <[hidden email]>
> To: [hidden email]
> Subject: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py       migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> I have problems with geonode2.6x on Centos7, when migrating the data from
> python manage.py migrate or try to start geonode ..
>
> Traceback (most recent call last):
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File
> "/usr/lib/python2.7/site-packages/django/core/management/commands/runserver.py",
> line 107, in inner_run
>    autoreload.raise_last_exception()
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 252, in raise_last_exception
>    six.reraise(*_exception)
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
> setup
>    apps.populate(settings.INSTALLED_APPS)
>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line 85,
> in populate
>    app_config = AppConfig.create(entry)
>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
> in create
>    module = import_module(entry)
>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
> import_module
>    __import__(name)
>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line 13,
> in <module>
>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
> require
>    needed = self.resolve(parse_requirements(requirements))
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
> resolve
>    raise VersionConflict(dist,req) # XXX put more info here
> pkg_resources.VersionConflict: (Django 1.8.18
> (/usr/lib/python2.7/site-packages), Requirement.parse('Django>=1.11'))
>
> I followed the steps of the installation guide, although I commented that I
> have not done the process that explain for the development mode, but
> starting from the installation of postgres, tomcat, geoserver and finally
> geonode.
> With these same steps I had done a previous installation but I had problems
> wanting to upload shapes to geonode or geoserver so I had to reinstall
> everything again.
>
> The version of Django that I am currently observing is the 1.8.18
>
> I would greatly appreciate the help of someone who has already been able to
> do the installation correctly.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180212/9f36e2e5/attachment-0001.html>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 13 Feb 2018 07:20:16 +0100
> From: Simone Dalmasso <[hidden email]>
> To: SILVIA GAMERO <[hidden email]>
> Cc: geonode-devel <[hidden email]>
> Subject: Re: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> Hi, your django version is correct but looks like other libraries are not,
> like polymorphic. I suggest to run pip install -r requirements.txt again.
>
> 2018-02-12 23:09 GMT+01:00 SILVIA GAMERO <[hidden email]>:
>
>> I have problems with geonode2.6x on Centos7, when migrating the data from
>> python manage.py migrate or try to start geonode ..
>>
>> Traceback (most recent call last):
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/core/
>> management/commands/runserver.py", line 107, in inner_run
>>    autoreload.raise_last_exception()
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 252, in raise_last_exception
>>    six.reraise(*_exception)
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
>> setup
>>    apps.populate(settings.INSTALLED_APPS)
>>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line
>> 85, in populate
>>    app_config = AppConfig.create(entry)
>>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
>> in create
>>    module = import_module(entry)
>>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
>> import_module
>>    __import__(name)
>>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line
>> 13, in <module>
>>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
>> require
>>    needed = self.resolve(parse_requirements(requirements))
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
>> resolve
>>    raise VersionConflict(dist,req) # XXX put more info here
>> pkg_resources.VersionConflict: (Django 1.8.18 (/usr/lib/python2.7/site-packages),
>> Requirement.parse('Django>=1.11'))
>>
>> I followed the steps of the installation guide, although I commented that
>> I have not done the process that explain for the development mode, but
>> starting from the installation of postgres, tomcat, geoserver and finally
>> geonode.
>> With these same steps I had done a previous installation but I had
>> problems wanting to upload shapes to geonode or geoserver so I had to
>> reinstall everything again.
>>
>> The version of Django that I am currently observing is the 1.8.18
>>
>> I would greatly appreciate the help of someone who has already been able
>> to do the installation correctly.
>>
>>
>> _______________________________________________
>> geonode-devel mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>>
>>
>
>
> --
> Simone
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180213/365c2a0e/attachment-0001.html>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> geonode-devel mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>
>
> ------------------------------
>
> End of geonode-devel Digest, Vol 37, Issue 21
> *********************************************

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



--
Simone 

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: geonode-devel Digest, Vol 37, Issue 21

Thomas Gertin-2
sorry I mis-typed. What I meant to say is that in the django-polymorphic GitHub repo, it says for older Django versions than 1.11, install django-polymorphic==1.3.

I think that right now the 'django-polymorphic>=0.9.2' requirement installs a version of django-polymorphic newer than version 1.3, which requires Django version 1.11 or higher, which we don't want.



On Wed, Feb 14, 2018 at 8:00 AM, Simone Dalmasso <[hidden email]> wrote:
Dear Tom,

GeoNode 2.6 runs with Django 1.8 so we need to stay with it. I'm wondering why the 1.11 is installed.

Silvia and others also ran in the issue with slugify lately so we need to investigate what happens there. We haven0t changes the 2.6.x as far as I know so something must have changed in the dependencies.

2018-02-14 12:54 GMT+01:00 Thomas Gertin <[hidden email]>:
I ran into the same issue you had today SILVIA.

I noticed that for for the pypy GeoNode 2.6.1 package (https://pypi.python.org/pypi/GeoNode/2.6.1), the requirements.txt file lists django-polymorphic as

django-polymorphic>=0.9.2

However, as stated in the django-polymorphic GitHub repo, django-polymorphic==1.3 should be installed for Django 1.11.

Can you try uninstalling django-polymorphic, and installing version 1.3?


To all,

Can we put 'django-polymorphic==1.3' in the requirements.txt for GeoNode 2.6.1?


I am having problems now with awesome-slugify installing correctly, but I need think I need to look into this further.


Thanks,

Tom G.



> On Feb 13, 2018, at 3:00 PM, [hidden email] wrote:
>
> Send geonode-devel mailing list submissions to
>       [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>       https://lists.osgeo.org/mailman/listinfo/geonode-devel
> or, via email, send a message with subject or body 'help' to
>       [hidden email]
>
> You can reach the person managing the list at
>       [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of geonode-devel digest..."
>
>
> Today's Topics:
>
>   1. pkg_resources.VersionConflict when python manage.py      migrate
>      (SILVIA GAMERO)
>   2. Re: pkg_resources.VersionConflict when python manage.py
>      migrate (Simone Dalmasso)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 12 Feb 2018 16:09:15 -0600
> From: SILVIA GAMERO <[hidden email]>
> To: [hidden email]
> Subject: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py       migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> I have problems with geonode2.6x on Centos7, when migrating the data from
> python manage.py migrate or try to start geonode ..
>
> Traceback (most recent call last):
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File
> "/usr/lib/python2.7/site-packages/django/core/management/commands/runserver.py",
> line 107, in inner_run
>    autoreload.raise_last_exception()
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 252, in raise_last_exception
>    six.reraise(*_exception)
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
> setup
>    apps.populate(settings.INSTALLED_APPS)
>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line 85,
> in populate
>    app_config = AppConfig.create(entry)
>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
> in create
>    module = import_module(entry)
>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
> import_module
>    __import__(name)
>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line 13,
> in <module>
>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
> require
>    needed = self.resolve(parse_requirements(requirements))
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
> resolve
>    raise VersionConflict(dist,req) # XXX put more info here
> pkg_resources.VersionConflict: (Django 1.8.18
> (/usr/lib/python2.7/site-packages), Requirement.parse('Django>=1.11'))
>
> I followed the steps of the installation guide, although I commented that I
> have not done the process that explain for the development mode, but
> starting from the installation of postgres, tomcat, geoserver and finally
> geonode.
> With these same steps I had done a previous installation but I had problems
> wanting to upload shapes to geonode or geoserver so I had to reinstall
> everything again.
>
> The version of Django that I am currently observing is the 1.8.18
>
> I would greatly appreciate the help of someone who has already been able to
> do the installation correctly.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180212/9f36e2e5/attachment-0001.html>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 13 Feb 2018 07:20:16 +0100
> From: Simone Dalmasso <[hidden email]>
> To: SILVIA GAMERO <[hidden email]>
> Cc: geonode-devel <[hidden email]>
> Subject: Re: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> Hi, your django version is correct but looks like other libraries are not,
> like polymorphic. I suggest to run pip install -r requirements.txt again.
>
> 2018-02-12 23:09 GMT+01:00 SILVIA GAMERO <[hidden email]>:
>
>> I have problems with geonode2.6x on Centos7, when migrating the data from
>> python manage.py migrate or try to start geonode ..
>>
>> Traceback (most recent call last):
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/core/
>> management/commands/runserver.py", line 107, in inner_run
>>    autoreload.raise_last_exception()
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 252, in raise_last_exception
>>    six.reraise(*_exception)
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
>> setup
>>    apps.populate(settings.INSTALLED_APPS)
>>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line
>> 85, in populate
>>    app_config = AppConfig.create(entry)
>>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
>> in create
>>    module = import_module(entry)
>>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
>> import_module
>>    __import__(name)
>>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line
>> 13, in <module>
>>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
>> require
>>    needed = self.resolve(parse_requirements(requirements))
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
>> resolve
>>    raise VersionConflict(dist,req) # XXX put more info here
>> pkg_resources.VersionConflict: (Django 1.8.18 (/usr/lib/python2.7/site-packages),
>> Requirement.parse('Django>=1.11'))
>>
>> I followed the steps of the installation guide, although I commented that
>> I have not done the process that explain for the development mode, but
>> starting from the installation of postgres, tomcat, geoserver and finally
>> geonode.
>> With these same steps I had done a previous installation but I had
>> problems wanting to upload shapes to geonode or geoserver so I had to
>> reinstall everything again.
>>
>> The version of Django that I am currently observing is the 1.8.18
>>
>> I would greatly appreciate the help of someone who has already been able
>> to do the installation correctly.
>>
>>
>> _______________________________________________
>> geonode-devel mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>>
>>
>
>
> --
> Simone
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180213/365c2a0e/attachment-0001.html>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> geonode-devel mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>
>
> ------------------------------
>
> End of geonode-devel Digest, Vol 37, Issue 21
> *********************************************

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: geonode-devel Digest, Vol 37, Issue 21

Simo D
ok thanks Tom! definitely we have to fix this as will affect all pip installations.



2018-02-14 15:46 GMT+01:00 Thomas Gertin <[hidden email]>:
sorry I mis-typed. What I meant to say is that in the django-polymorphic GitHub repo, it says for older Django versions than 1.11, install django-polymorphic==1.3.

I think that right now the 'django-polymorphic>=0.9.2' requirement installs a version of django-polymorphic newer than version 1.3, which requires Django version 1.11 or higher, which we don't want.



On Wed, Feb 14, 2018 at 8:00 AM, Simone Dalmasso <[hidden email]> wrote:
Dear Tom,

GeoNode 2.6 runs with Django 1.8 so we need to stay with it. I'm wondering why the 1.11 is installed.

Silvia and others also ran in the issue with slugify lately so we need to investigate what happens there. We haven0t changes the 2.6.x as far as I know so something must have changed in the dependencies.

2018-02-14 12:54 GMT+01:00 Thomas Gertin <[hidden email]>:
I ran into the same issue you had today SILVIA.

I noticed that for for the pypy GeoNode 2.6.1 package (https://pypi.python.org/pypi/GeoNode/2.6.1), the requirements.txt file lists django-polymorphic as

django-polymorphic>=0.9.2

However, as stated in the django-polymorphic GitHub repo, django-polymorphic==1.3 should be installed for Django 1.11.

Can you try uninstalling django-polymorphic, and installing version 1.3?


To all,

Can we put 'django-polymorphic==1.3' in the requirements.txt for GeoNode 2.6.1?


I am having problems now with awesome-slugify installing correctly, but I need think I need to look into this further.


Thanks,

Tom G.



> On Feb 13, 2018, at 3:00 PM, [hidden email] wrote:
>
> Send geonode-devel mailing list submissions to
>       [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>       https://lists.osgeo.org/mailman/listinfo/geonode-devel
> or, via email, send a message with subject or body 'help' to
>       [hidden email]
>
> You can reach the person managing the list at
>       [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of geonode-devel digest..."
>
>
> Today's Topics:
>
>   1. pkg_resources.VersionConflict when python manage.py      migrate
>      (SILVIA GAMERO)
>   2. Re: pkg_resources.VersionConflict when python manage.py
>      migrate (Simone Dalmasso)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 12 Feb 2018 16:09:15 -0600
> From: SILVIA GAMERO <[hidden email]>
> To: [hidden email]
> Subject: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py       migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> I have problems with geonode2.6x on Centos7, when migrating the data from
> python manage.py migrate or try to start geonode ..
>
> Traceback (most recent call last):
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File
> "/usr/lib/python2.7/site-packages/django/core/management/commands/runserver.py",
> line 107, in inner_run
>    autoreload.raise_last_exception()
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 252, in raise_last_exception
>    six.reraise(*_exception)
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
> setup
>    apps.populate(settings.INSTALLED_APPS)
>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line 85,
> in populate
>    app_config = AppConfig.create(entry)
>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
> in create
>    module = import_module(entry)
>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
> import_module
>    __import__(name)
>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line 13,
> in <module>
>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
> require
>    needed = self.resolve(parse_requirements(requirements))
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
> resolve
>    raise VersionConflict(dist,req) # XXX put more info here
> pkg_resources.VersionConflict: (Django 1.8.18
> (/usr/lib/python2.7/site-packages), Requirement.parse('Django>=1.11'))
>
> I followed the steps of the installation guide, although I commented that I
> have not done the process that explain for the development mode, but
> starting from the installation of postgres, tomcat, geoserver and finally
> geonode.
> With these same steps I had done a previous installation but I had problems
> wanting to upload shapes to geonode or geoserver so I had to reinstall
> everything again.
>
> The version of Django that I am currently observing is the 1.8.18
>
> I would greatly appreciate the help of someone who has already been able to
> do the installation correctly.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180212/9f36e2e5/attachment-0001.html>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 13 Feb 2018 07:20:16 +0100
> From: Simone Dalmasso <[hidden email]>
> To: SILVIA GAMERO <[hidden email]>
> Cc: geonode-devel <[hidden email]>
> Subject: Re: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> Hi, your django version is correct but looks like other libraries are not,
> like polymorphic. I suggest to run pip install -r requirements.txt again.
>
> 2018-02-12 23:09 GMT+01:00 SILVIA GAMERO <[hidden email]>:
>
>> I have problems with geonode2.6x on Centos7, when migrating the data from
>> python manage.py migrate or try to start geonode ..
>>
>> Traceback (most recent call last):
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/core/
>> management/commands/runserver.py", line 107, in inner_run
>>    autoreload.raise_last_exception()
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 252, in raise_last_exception
>>    six.reraise(*_exception)
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
>> setup
>>    apps.populate(settings.INSTALLED_APPS)
>>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line
>> 85, in populate
>>    app_config = AppConfig.create(entry)
>>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
>> in create
>>    module = import_module(entry)
>>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
>> import_module
>>    __import__(name)
>>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line
>> 13, in <module>
>>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
>> require
>>    needed = self.resolve(parse_requirements(requirements))
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
>> resolve
>>    raise VersionConflict(dist,req) # XXX put more info here
>> pkg_resources.VersionConflict: (Django 1.8.18 (/usr/lib/python2.7/site-packages),
>> Requirement.parse('Django>=1.11'))
>>
>> I followed the steps of the installation guide, although I commented that
>> I have not done the process that explain for the development mode, but
>> starting from the installation of postgres, tomcat, geoserver and finally
>> geonode.
>> With these same steps I had done a previous installation but I had
>> problems wanting to upload shapes to geonode or geoserver so I had to
>> reinstall everything again.
>>
>> The version of Django that I am currently observing is the 1.8.18
>>
>> I would greatly appreciate the help of someone who has already been able
>> to do the installation correctly.
>>
>>
>> _______________________________________________
>> geonode-devel mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>>
>>
>
>
> --
> Simone
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180213/365c2a0e/attachment-0001.html>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> geonode-devel mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>
>
> ------------------------------
>
> End of geonode-devel Digest, Vol 37, Issue 21
> *********************************************

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



--
Simone 




--
Simone 

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: geonode-devel Digest, Vol 37, Issue 21

Thomas Gertin-2
Simone,

with the awesome-slugify package there was an issue(https://github.com/dimka665/awesome-slugify/pull/22) in its GitHub repo that was supposed to fix the ImportError. However in the awesome-slugify PyPy package I don't see the fix implemented. What I did for myself was pip uninstall awesome-slugify then I installed awesome-slugify from its GItHub repo (The Github repo has the fix). I used the command: pip install https://github.com/dimka665/awesome-slugify/archive/master.zip

This worked for me. 

Thanks,

-Tom

On Wed, Feb 14, 2018 at 9:51 AM, Simone Dalmasso <[hidden email]> wrote:
ok thanks Tom! definitely we have to fix this as will affect all pip installations.



2018-02-14 15:46 GMT+01:00 Thomas Gertin <[hidden email]>:
sorry I mis-typed. What I meant to say is that in the django-polymorphic GitHub repo, it says for older Django versions than 1.11, install django-polymorphic==1.3.

I think that right now the 'django-polymorphic>=0.9.2' requirement installs a version of django-polymorphic newer than version 1.3, which requires Django version 1.11 or higher, which we don't want.



On Wed, Feb 14, 2018 at 8:00 AM, Simone Dalmasso <[hidden email]> wrote:
Dear Tom,

GeoNode 2.6 runs with Django 1.8 so we need to stay with it. I'm wondering why the 1.11 is installed.

Silvia and others also ran in the issue with slugify lately so we need to investigate what happens there. We haven0t changes the 2.6.x as far as I know so something must have changed in the dependencies.

2018-02-14 12:54 GMT+01:00 Thomas Gertin <[hidden email]>:
I ran into the same issue you had today SILVIA.

I noticed that for for the pypy GeoNode 2.6.1 package (https://pypi.python.org/pypi/GeoNode/2.6.1), the requirements.txt file lists django-polymorphic as

django-polymorphic>=0.9.2

However, as stated in the django-polymorphic GitHub repo, django-polymorphic==1.3 should be installed for Django 1.11.

Can you try uninstalling django-polymorphic, and installing version 1.3?


To all,

Can we put 'django-polymorphic==1.3' in the requirements.txt for GeoNode 2.6.1?


I am having problems now with awesome-slugify installing correctly, but I need think I need to look into this further.


Thanks,

Tom G.



> On Feb 13, 2018, at 3:00 PM, [hidden email] wrote:
>
> Send geonode-devel mailing list submissions to
>       [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>       https://lists.osgeo.org/mailman/listinfo/geonode-devel
> or, via email, send a message with subject or body 'help' to
>       [hidden email]
>
> You can reach the person managing the list at
>       [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of geonode-devel digest..."
>
>
> Today's Topics:
>
>   1. pkg_resources.VersionConflict when python manage.py      migrate
>      (SILVIA GAMERO)
>   2. Re: pkg_resources.VersionConflict when python manage.py
>      migrate (Simone Dalmasso)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 12 Feb 2018 16:09:15 -0600
> From: SILVIA GAMERO <[hidden email]>
> To: [hidden email]
> Subject: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py       migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> I have problems with geonode2.6x on Centos7, when migrating the data from
> python manage.py migrate or try to start geonode ..
>
> Traceback (most recent call last):
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File
> "/usr/lib/python2.7/site-packages/django/core/management/commands/runserver.py",
> line 107, in inner_run
>    autoreload.raise_last_exception()
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 252, in raise_last_exception
>    six.reraise(*_exception)
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
> setup
>    apps.populate(settings.INSTALLED_APPS)
>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line 85,
> in populate
>    app_config = AppConfig.create(entry)
>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
> in create
>    module = import_module(entry)
>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
> import_module
>    __import__(name)
>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line 13,
> in <module>
>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
> require
>    needed = self.resolve(parse_requirements(requirements))
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
> resolve
>    raise VersionConflict(dist,req) # XXX put more info here
> pkg_resources.VersionConflict: (Django 1.8.18
> (/usr/lib/python2.7/site-packages), Requirement.parse('Django>=1.11'))
>
> I followed the steps of the installation guide, although I commented that I
> have not done the process that explain for the development mode, but
> starting from the installation of postgres, tomcat, geoserver and finally
> geonode.
> With these same steps I had done a previous installation but I had problems
> wanting to upload shapes to geonode or geoserver so I had to reinstall
> everything again.
>
> The version of Django that I am currently observing is the 1.8.18
>
> I would greatly appreciate the help of someone who has already been able to
> do the installation correctly.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180212/9f36e2e5/attachment-0001.html>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 13 Feb 2018 07:20:16 +0100
> From: Simone Dalmasso <[hidden email]>
> To: SILVIA GAMERO <[hidden email]>
> Cc: geonode-devel <[hidden email]>
> Subject: Re: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> Hi, your django version is correct but looks like other libraries are not,
> like polymorphic. I suggest to run pip install -r requirements.txt again.
>
> 2018-02-12 23:09 GMT+01:00 SILVIA GAMERO <[hidden email]>:
>
>> I have problems with geonode2.6x on Centos7, when migrating the data from
>> python manage.py migrate or try to start geonode ..
>>
>> Traceback (most recent call last):
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/core/
>> management/commands/runserver.py", line 107, in inner_run
>>    autoreload.raise_last_exception()
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 252, in raise_last_exception
>>    six.reraise(*_exception)
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
>> setup
>>    apps.populate(settings.INSTALLED_APPS)
>>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line
>> 85, in populate
>>    app_config = AppConfig.create(entry)
>>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
>> in create
>>    module = import_module(entry)
>>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
>> import_module
>>    __import__(name)
>>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line
>> 13, in <module>
>>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
>> require
>>    needed = self.resolve(parse_requirements(requirements))
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
>> resolve
>>    raise VersionConflict(dist,req) # XXX put more info here
>> pkg_resources.VersionConflict: (Django 1.8.18 (/usr/lib/python2.7/site-packages),
>> Requirement.parse('Django>=1.11'))
>>
>> I followed the steps of the installation guide, although I commented that
>> I have not done the process that explain for the development mode, but
>> starting from the installation of postgres, tomcat, geoserver and finally
>> geonode.
>> With these same steps I had done a previous installation but I had
>> problems wanting to upload shapes to geonode or geoserver so I had to
>> reinstall everything again.
>>
>> The version of Django that I am currently observing is the 1.8.18
>>
>> I would greatly appreciate the help of someone who has already been able
>> to do the installation correctly.
>>
>>
>> _______________________________________________
>> geonode-devel mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>>
>>
>
>
> --
> Simone
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180213/365c2a0e/attachment-0001.html>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> geonode-devel mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>
>
> ------------------------------
>
> End of geonode-devel Digest, Vol 37, Issue 21
> *********************************************

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



--
Simone 




--
Simone 


_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel
Reply | Threaded
Open this post in threaded view
|

Re: geonode-devel Digest, Vol 37, Issue 21

Simo D
Thanks a lot Thomas, so we need to update the package.

2018-02-14 23:43 GMT+01:00 Thomas Gertin <[hidden email]>:
Simone,

with the awesome-slugify package there was an issue(https://github.com/dimka665/awesome-slugify/pull/22) in its GitHub repo that was supposed to fix the ImportError. However in the awesome-slugify PyPy package I don't see the fix implemented. What I did for myself was pip uninstall awesome-slugify then I installed awesome-slugify from its GItHub repo (The Github repo has the fix). I used the command: pip install https://github.com/dimka665/awesome-slugify/archive/master.zip

This worked for me. 

Thanks,

-Tom

On Wed, Feb 14, 2018 at 9:51 AM, Simone Dalmasso <[hidden email]> wrote:
ok thanks Tom! definitely we have to fix this as will affect all pip installations.



2018-02-14 15:46 GMT+01:00 Thomas Gertin <[hidden email]>:
sorry I mis-typed. What I meant to say is that in the django-polymorphic GitHub repo, it says for older Django versions than 1.11, install django-polymorphic==1.3.

I think that right now the 'django-polymorphic>=0.9.2' requirement installs a version of django-polymorphic newer than version 1.3, which requires Django version 1.11 or higher, which we don't want.



On Wed, Feb 14, 2018 at 8:00 AM, Simone Dalmasso <[hidden email]> wrote:
Dear Tom,

GeoNode 2.6 runs with Django 1.8 so we need to stay with it. I'm wondering why the 1.11 is installed.

Silvia and others also ran in the issue with slugify lately so we need to investigate what happens there. We haven0t changes the 2.6.x as far as I know so something must have changed in the dependencies.

2018-02-14 12:54 GMT+01:00 Thomas Gertin <[hidden email]>:
I ran into the same issue you had today SILVIA.

I noticed that for for the pypy GeoNode 2.6.1 package (https://pypi.python.org/pypi/GeoNode/2.6.1), the requirements.txt file lists django-polymorphic as

django-polymorphic>=0.9.2

However, as stated in the django-polymorphic GitHub repo, django-polymorphic==1.3 should be installed for Django 1.11.

Can you try uninstalling django-polymorphic, and installing version 1.3?


To all,

Can we put 'django-polymorphic==1.3' in the requirements.txt for GeoNode 2.6.1?


I am having problems now with awesome-slugify installing correctly, but I need think I need to look into this further.


Thanks,

Tom G.



> On Feb 13, 2018, at 3:00 PM, [hidden email] wrote:
>
> Send geonode-devel mailing list submissions to
>       [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>       https://lists.osgeo.org/mailman/listinfo/geonode-devel
> or, via email, send a message with subject or body 'help' to
>       [hidden email]
>
> You can reach the person managing the list at
>       [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of geonode-devel digest..."
>
>
> Today's Topics:
>
>   1. pkg_resources.VersionConflict when python manage.py      migrate
>      (SILVIA GAMERO)
>   2. Re: pkg_resources.VersionConflict when python manage.py
>      migrate (Simone Dalmasso)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 12 Feb 2018 16:09:15 -0600
> From: SILVIA GAMERO <[hidden email]>
> To: [hidden email]
> Subject: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py       migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> I have problems with geonode2.6x on Centos7, when migrating the data from
> python manage.py migrate or try to start geonode ..
>
> Traceback (most recent call last):
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File
> "/usr/lib/python2.7/site-packages/django/core/management/commands/runserver.py",
> line 107, in inner_run
>    autoreload.raise_last_exception()
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 252, in raise_last_exception
>    six.reraise(*_exception)
>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py", line
> 229, in wrapper
>    fn(*args, **kwargs)
>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
> setup
>    apps.populate(settings.INSTALLED_APPS)
>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line 85,
> in populate
>    app_config = AppConfig.create(entry)
>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
> in create
>    module = import_module(entry)
>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
> import_module
>    __import__(name)
>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line 13,
> in <module>
>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
> require
>    needed = self.resolve(parse_requirements(requirements))
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
> resolve
>    raise VersionConflict(dist,req) # XXX put more info here
> pkg_resources.VersionConflict: (Django 1.8.18
> (/usr/lib/python2.7/site-packages), Requirement.parse('Django>=1.11'))
>
> I followed the steps of the installation guide, although I commented that I
> have not done the process that explain for the development mode, but
> starting from the installation of postgres, tomcat, geoserver and finally
> geonode.
> With these same steps I had done a previous installation but I had problems
> wanting to upload shapes to geonode or geoserver so I had to reinstall
> everything again.
>
> The version of Django that I am currently observing is the 1.8.18
>
> I would greatly appreciate the help of someone who has already been able to
> do the installation correctly.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180212/9f36e2e5/attachment-0001.html>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 13 Feb 2018 07:20:16 +0100
> From: Simone Dalmasso <[hidden email]>
> To: SILVIA GAMERO <[hidden email]>
> Cc: geonode-devel <[hidden email]>
> Subject: Re: [GeoNode-devel] pkg_resources.VersionConflict when python
>       manage.py migrate
> Message-ID:
>       <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> Hi, your django version is correct but looks like other libraries are not,
> like polymorphic. I suggest to run pip install -r requirements.txt again.
>
> 2018-02-12 23:09 GMT+01:00 SILVIA GAMERO <[hidden email]>:
>
>> I have problems with geonode2.6x on Centos7, when migrating the data from
>> python manage.py migrate or try to start geonode ..
>>
>> Traceback (most recent call last):
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/core/
>> management/commands/runserver.py", line 107, in inner_run
>>    autoreload.raise_last_exception()
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 252, in raise_last_exception
>>    six.reraise(*_exception)
>>  File "/usr/lib/python2.7/site-packages/django/utils/autoreload.py",
>> line 229, in wrapper
>>    fn(*args, **kwargs)
>>  File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in
>> setup
>>    apps.populate(settings.INSTALLED_APPS)
>>  File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line
>> 85, in populate
>>    app_config = AppConfig.create(entry)
>>  File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86,
>> in create
>>    module = import_module(entry)
>>  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in
>> import_module
>>    __import__(name)
>>  File "/usr/lib/python2.7/site-packages/polymorphic/__init__.py", line
>> 13, in <module>
>>    __version__ = pkg_resources.require("django-polymorphic")[0].version
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in
>> require
>>    needed = self.resolve(parse_requirements(requirements))
>>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in
>> resolve
>>    raise VersionConflict(dist,req) # XXX put more info here
>> pkg_resources.VersionConflict: (Django 1.8.18 (/usr/lib/python2.7/site-packages),
>> Requirement.parse('Django>=1.11'))
>>
>> I followed the steps of the installation guide, although I commented that
>> I have not done the process that explain for the development mode, but
>> starting from the installation of postgres, tomcat, geoserver and finally
>> geonode.
>> With these same steps I had done a previous installation but I had
>> problems wanting to upload shapes to geonode or geoserver so I had to
>> reinstall everything again.
>>
>> The version of Django that I am currently observing is the 1.8.18
>>
>> I would greatly appreciate the help of someone who has already been able
>> to do the installation correctly.
>>
>>
>> _______________________________________________
>> geonode-devel mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>>
>>
>
>
> --
> Simone
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20180213/365c2a0e/attachment-0001.html>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> geonode-devel mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/geonode-devel
>
>
> ------------------------------
>
> End of geonode-devel Digest, Vol 37, Issue 21
> *********************************************

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel



--
Simone 




--
Simone 




--
Simone 

_______________________________________________
geonode-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-devel