Re: The GetFeature WFS Request fail if the layer is empty

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: The GetFeature WFS Request fail if the layer is empty

jratike80

Hi,

 

What kind of source dataset do you have, and do you mean that for example a PostGIS table exists but there are no rows in the table?

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users <[hidden email]> Puolesta Andrea Peri
Lähetetty: maanantai 12. elokuuta 2019 14.30
Vastaanottaja: [hidden email]
Aihe: [mapserver-users] The GetFeature WFS Request fail if the layer is empty

 

Hi,

I' notice that the GetFeature WFS request of a mapserver (i'm work using master) return an error if the dataset (and so the layer) is empty.

 

I test using version 1.0.0, 1.1.1 and 2.00.

 

On 2.0.0 the result is:

http status 400

The request sent by the client was syntactically incorrect.

 

On 1.1.0 and 1.0.0 the result is an xml exception with:

msWFSGetFeature(): WFS server error. ms_error->code not found

 

I Guess it should return not an exception or error, but instead an empty GML or an Empty Shapefile and so on...

 

Before to build a test service of this issue, I like to know if this instead is a confirmed specific characteristic of a wfs service.

 

Thx,

 

--

-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: The GetFeature WFS Request fail if the layer is empty

Andrea Peri
Hi Jukka,

I'm testing with GetFeature using a postgis table.
The table in my test is not empty, but I apply a filter to the query for the data retrieving of the layer and the result with the filter is an empty dataset.

A.


Il giorno mar 13 ago 2019 alle ore 09:00 Rahkonen Jukka (MML) <[hidden email]> ha scritto:

Hi,

 

What kind of source dataset do you have, and do you mean that for example a PostGIS table exists but there are no rows in the table?

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users <[hidden email]> Puolesta Andrea Peri
Lähetetty: maanantai 12. elokuuta 2019 14.30
Vastaanottaja: [hidden email]
Aihe: [mapserver-users] The GetFeature WFS Request fail if the layer is empty

 

Hi,

I' notice that the GetFeature WFS request of a mapserver (i'm work using master) return an error if the dataset (and so the layer) is empty.

 

I test using version 1.0.0, 1.1.1 and 2.00.

 

On 2.0.0 the result is:

http status 400

The request sent by the client was syntactically incorrect.

 

On 1.1.0 and 1.0.0 the result is an xml exception with:

msWFSGetFeature(): WFS server error. ms_error->code not found

 

I Guess it should return not an exception or error, but instead an empty GML or an Empty Shapefile and so on...

 

Before to build a test service of this issue, I like to know if this instead is a confirmed specific characteristic of a wfs service.

 

Thx,

 

--

-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------



--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------

_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: The GetFeature WFS Request fail if the layer is empty

jratike80

Hi,

 

Thanks for the clarification. As a comparison here is a request and corresponding result for having a look at what Geoserver does

 

https://demo.geo-solutions.it/geoserver/wfs?service=WFS&version=2.0.0&request=GetFeature&typenames=states&cql_filter=STATE_NAME='Foo'

 

Result:

<?xml version="1.0" encoding="UTF-8"?><wfs:FeatureCollection xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:wfs="http://www.opengis.net/wfs/2.0" xmlns:gml="http://www.opengis.net/gml/3.2" xmlns:topp="http://www.openplans.org/topp" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" numberMatched="0" numberReturned="0" timeStamp="2019-08-13T09:43:54.633Z" xsi:schemaLocation="http://www.opengis.net/wfs/2.0 https://demo.geo-solutions.it:443/geoserver/schemas/wfs/2.0/wfs.xsd http://www.openplans.org/topp https://demo.geo-solutions.it:443/geoserver/wfs?service=WFS&amp;version=2.0.0&amp;request=DescribeFeatureType&amp;typeName=topp%3Astates http://www.opengis.net/gml/3.2 https://demo.geo-solutions.it:443/geoserver/schemas/gml/3.2.1/gml.xsd"/>

 

-Jukka-

 

Lähettäjä: Andrea Peri <[hidden email]>
Lähetetty: tiistai 13. elokuuta 2019 12.35
Vastaanottaja: Rahkonen Jukka (MML) <[hidden email]>
Kopio: [hidden email]
Aihe: Re: [mapserver-users] The GetFeature WFS Request fail if the layer is empty

 

Hi Jukka,

 

I'm testing with GetFeature using a postgis table.

The table in my test is not empty, but I apply a filter to the query for the data retrieving of the layer and the result with the filter is an empty dataset.

 

A.

 

 

Il giorno mar 13 ago 2019 alle ore 09:00 Rahkonen Jukka (MML) <[hidden email]> ha scritto:

Hi,

 

What kind of source dataset do you have, and do you mean that for example a PostGIS table exists but there are no rows in the table?

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users <[hidden email]> Puolesta Andrea Peri
Lähetetty: maanantai 12. elokuuta 2019 14.30
Vastaanottaja: [hidden email]
Aihe: [mapserver-users] The GetFeature WFS Request fail if the layer is empty

 

Hi,

I' notice that the GetFeature WFS request of a mapserver (i'm work using master) return an error if the dataset (and so the layer) is empty.

 

I test using version 1.0.0, 1.1.1 and 2.00.

 

On 2.0.0 the result is:

http status 400

The request sent by the client was syntactically incorrect.

 

On 1.1.0 and 1.0.0 the result is an xml exception with:

msWFSGetFeature(): WFS server error. ms_error->code not found

 

I Guess it should return not an exception or error, but instead an empty GML or an Empty Shapefile and so on...

 

Before to build a test service of this issue, I like to know if this instead is a confirmed specific characteristic of a wfs service.

 

Thx,

 

--

-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------



--

-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users