Re: Problem installing postgis on centos 6.8 desktop + postgresql

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Problem installing postgis on centos 6.8 desktop + postgresql

P O'Toole
>Error: Package: gdal-libs-1.9.2-8.rhel6.x86_64 (pgdg93)
>           Requires: libCharLS.so.1()(64bit)
> You could try using --skip-broken to work around the problem

> You could try running: rpm -Va --nofiles --nodigest

Mike,

I can't address whether this is a packaging issue or not but when I do `rpm -qif /usr/lib64/libCharLS.so.1` it gives me:

Name        : CharLS
Version     : 1.0
Release     : 1.el6
Architecture: x86_64
Install Date: Wed 20 May 2015 10:24:52 AM MDT
Group       : Development/Libraries
Size        : 279772
License     : BSD
Signature   : RSA/SHA256, Mon 14 Feb 2011 09:15:43 AM MST, Key ID 3b49df2a0608b895
Source RPM  : CharLS-1.0-1.el6.src.rpm
Build Date  : Mon 14 Feb 2011 05:11:40 AM MST
Build Host  : x86-05.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://charls.codeplex.com/

There's a chance you can add the right Fedora repo and install CharLS from that. I often cruise http://rpm.pbone.net/ to track down stuff I don't have access to natively by searching for the .so-dependency names in question. That usually saves having to compile things from source.

- Patrick O'Toole

Application Developer
Wyoming Natural Diversity Database
UW Berry Biodiversity Conservation Center
Department 3381, 1000 E. University Av.
Laramie, WY 82071
P: 307-766-3018


-----Original Message-----
From: postgis-users [mailto:[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, October 26, 2016 1:00 PM
To: [hidden email]
Subject: postgis-users Digest, Vol 176, Issue 12

Send postgis-users mailing list submissions to
        [hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.osgeo.org/mailman/listinfo/postgis-users
or, via email, send a message with subject or body 'help' to
        [hidden email]

You can reach the person managing the list at
        [hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of postgis-users digest..."


Today's Topics:

   1. Problem installing postgis on centos 6.8 desktop + postgresql
      93 (Mike Frampton)
   2. Deleted Shp/Dbf Records Feedback (Paul Ramsey)
   3. Re: Deleted Shp/Dbf Records Feedback (Komяpa)


----------------------------------------------------------------------

Message: 1
Date: Tue, 25 Oct 2016 23:16:12 +0000
From: Mike Frampton <[hidden email]>
To: "[hidden email]" <[hidden email]>
Subject: [postgis-users] Problem installing postgis on centos 6.8
        desktop + postgresql 93
Message-ID:
        <[hidden email]>
       
Content-Type: text/plain; charset="iso-8859-1"

Hi


Im trying to install postgis on to a  centos 6.8 desktop  server which has postgresql 93 and phpPgAdmin installed. Ive followed the instructions at


http://postgis.net/install/


but I keep running into an error related to a missing library ( libCharLS.so.1 ). i.e.


cd /tmp ; rm -rf postgis ; mkdir postgis ; cd postgis
wget https://download.postgresql.org/pub/repos/yum/9.3/redhat/rhel-6-x86_64/pgdg-centos93-9.3-3.noarch.rpm

rpm -ivh pgdg*

yum -y install postgis2_93


This gives an error


--> Processing Dependency: libCharLS.so.1()(64bit) for package: gdal-libs-1.9.2-8.rhel6.x86_64
--> Finished Dependency Resolution
Error: Package: gdal-libs-1.9.2-8.rhel6.x86_64 (pgdg93)
           Requires: libCharLS.so.1()(64bit)
 You could try using --skip-broken to work around the problem

 You could try running: rpm -Va --nofiles --nodigest


I tried to manually install / reinstall the epel release but that didnt solve the issue.


rpm -e epel-release-6-8.noarch
rpm -ivh  http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm


Does anyone have any pointers, can anyone provide any suggestions ?


cheers


Mike




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20161025/df728153/attachment-0001.html>

------------------------------

Message: 2
Date: Wed, 26 Oct 2016 10:10:17 -0700
From: Paul Ramsey <[hidden email]>
To: PostGIS Users Discussion <[hidden email]>
Subject: [postgis-users] Deleted Shp/Dbf Records Feedback
Message-ID:
        <CACowWR0pz-vNbX-8DXVw_MPGEhQjbRgfjtHK=[hidden email]>
Content-Type: text/plain; charset="utf-8"

I'm about to fix this issue

https://trac.osgeo.org/postgis/ticket/3645

but I'm unsure whether to fix it as a "bug", with patches back into stable
releases (2.3, 2.2, etc) or just as a "feature" for upcoming releases.
It'll change behaviour, in that by default files with virtually deleted
records will no longer load the deleted records. (Someone wants a flag to
optionally re-enable the old behaviour, but that's definitely a feature,
not something that would go into a bug fix.)

Anyone have opinions, real-world concerns?

P.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20161026/75625954/attachment-0001.html>

------------------------------

Message: 3
Date: Wed, 26 Oct 2016 17:38:51 +0000
From: Komяpa <[hidden email]>
To: PostGIS Users Discussion <[hidden email]>
Subject: Re: [postgis-users] Deleted Shp/Dbf Records Feedback
Message-ID:
        <CAC8Q8tLL_0Q=[hidden email]>
Content-Type: text/plain; charset="utf-8"

I think, back-patch.

This is definitely a bug, so if someone was relying on this behavior, it's
better to get them fix their data than to say later "we can't go to next
major PostGIS, we rely on this bug being not fixed".

ср, 26 окт. 2016 г. в 20:10, Paul Ramsey <[hidden email]>:

> I'm about to fix this issue
>
> https://trac.osgeo.org/postgis/ticket/3645
>
> but I'm unsure whether to fix it as a "bug", with patches back into stable
> releases (2.3, 2.2, etc) or just as a "feature" for upcoming releases.
> It'll change behaviour, in that by default files with virtually deleted
> records will no longer load the deleted records. (Someone wants a flag to
> optionally re-enable the old behaviour, but that's definitely a feature,
> not something that would go into a bug fix.)
>
> Anyone have opinions, real-world concerns?
>
> P.
> _______________________________________________
> postgis-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/postgis-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20161026/bf87e670/attachment-0001.html>

------------------------------

Subject: Digest Footer

_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users

------------------------------

End of postgis-users Digest, Vol 176, Issue 12
**********************************************
_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users