Re: OpenLayers 2.0 RC1 problem.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: OpenLayers 2.0 RC1 problem.

John Preston
I've managed to get it to happen again. A screen dump file is attached
(if the address will allow it). I got this after zooming in then just
clicking the zoom slider to zoom out one level.

John

On 8/18/06, John Preston <[hidden email]> wrote:

> Hi. I'm using OpenLayers 2.0 RC1 and the perfomance increase is very
> welcome. The change to building the tiles for the view the user sees
> first gives me a better feel.
>
> I'm using OpenLayers with Mapserver and a dataset that has multiple
> scales of data grouped with different MINSCALE/MAXSCALE ranges. One
> thing I just noticed is that in zoomin in I get some tiles being built
> from one MINSCALE / MAXSCALE range and other tiles being built from
> the adjacent range. Has anybody else seen this. I've tried to
> reproduce it but it happens randomly.
>
> John
>
> P.S. Keep up the good work.
>

openlayer.jpg (60K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenLayers 2.0 RC1 problem.

Erik Uzureau
Hi John,

Not quite sure I understand what the problem is that you are experiencing, but
if you could send us a link and a description of how to reproduce it, we'd be
happy to look at it.

In the meantime, we have just put some finishing touches on the zoomlevels,
scale, resolution, etc. I even made a wiki which (hopefully) makes some
sense out of the whole thing:
http://trac.openlayers.org/wiki/SettingZoomLevels

Let us know if you need more help,
Erik

On 8/18/06, John Preston <[hidden email]> wrote:

> Hi. I'm using OpenLayers 2.0 RC1 and the perfomance increase is very
> welcome. The change to building the tiles for the view the user sees
> first gives me a better feel.
>
> I'm using OpenLayers with Mapserver and a dataset that has multiple
> scales of data grouped with different MINSCALE/MAXSCALE ranges. One
> thing I just noticed is that in zoomin in I get some tiles being built
> from one MINSCALE / MAXSCALE range and other tiles being built from
> the adjacent range. Has anybody else seen this. I've tried to
> reproduce it but it happens randomly.
>
> John
>
> P.S. Keep up the good work.
> _______________________________________________
> Users mailing list
> [hidden email]
> http://mailman-viper.python-hosting.com/listinfo/users
>
_______________________________________________
Users mailing list
[hidden email]
http://mailman-viper.python-hosting.com/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenLayers 2.0 RC1 problem.

Christopher Schmidt
In reply to this post by John Preston
On Fri, Aug 18, 2006 at 08:24:49AM -0500, John Preston wrote:
> I've managed to get it to happen again. A screen dump file is attached
> (if the address will allow it). I got this after zooming in then just
> clicking the zoom slider to zoom out one level.

This behavior seems to indicate that the outer tiles had not yet loaded.
Was there any indication that there were still more tiles downloading?

If you right click on the incorrect images, can you copy a URL from
them, and ensure that it is for the wrong zoom level (/scale)?

--
Christopher Schmidt
Web Developer
_______________________________________________
Users mailing list
[hidden email]
http://mailman-viper.python-hosting.com/listinfo/users