Re: LAYER with CONNECTIONTYPE UNION fails

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: LAYER with CONNECTIONTYPE UNION fails

Julian
So, I had not much more than just sent this when I discovered this: http://osgeo-org.1560.x6.nabble.com/testing-CONNECTIONTYPE-UNION-td4254182.html

And, voila!

    LAYER
        NAME "dtk_skaermkort"
        EXTENT 120000 5900000 1000000 6500000
        PROJECTION
            "init=epsg:25832"
        END
        STATUS ON
        TYPE raster
        PROCESSING "RESAMPLE=BILINEAR"
        CONNECTIONTYPE UNION
        CONNECTION "s3096,s1548,s774,s387,s193,s96,s48,s24,s12,s6,s3,s1,s07"
        METADATA
            "wms_title" "dtk_skaermkort"
            "wms_srs" "epsg:25832"
            "wms_group_title" "dtk_skaermkort"
        END
    END

appears to solve the issue.

For future reference,
/julian

----------------------------------------------------------------------

Message: 1
Date: Wed, 12 Sep 2018 14:43:09 +0000
From: Julian Hollingbery <[hidden email]>
To: "[hidden email]"
        <[hidden email]>
Subject: [mapserver-users] LAYER with CONNECTIONTYPE UNION fails
        catastrophically when asked to reproject
Message-ID:
        <[hidden email]>
       
Content-Type: text/plain; charset="iso-8859-1"

Hi list,


I have run into something which puzzles me. I have configured a WMS using a MAP file with three layers: dtk_skaermkort, dtk_skaermkort_3096 and dtk_skaermkort_1548. The two latter expose TIFFs via a tile index in a shape file. Data is in EPSG:25832. The first layer uses CONNECTIONTYPE UNION to show the aggregate of the other two layers. This works *as long as I stay in the native projection*. However, this fails:
http://172.30.229.42/fcgi-bin/mapserv.fcgi?map=/mapserver/config/mapfiler/WMS/topo_skaermkort/topo_skaermkort_mailinglist.map&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&BBOX=-280235,5874930,649671,6549730&CRS=EPSG:25833&WIDTH=867&HEIGHT=629&LAYERS=dtk_skaermkort&STYLES=&FORMAT=image/png
With a horrible Apache HTTP 500 (which I can find no trace of in /var/log/apache2/error.log...)

even though these succeed:

http://172.30.229.42/fcgi-bin/mapserv.fcgi?map=/mapserver/config/mapfiler/WMS/topo_skaermkort/topo_skaermkort_mailinglist.map&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&BBOX=-280235,5874930,649671,6549730&CRS=EPSG:25833&WIDTH=867&HEIGHT=629&LAYERS=dtk_skaermkort_3096&STYLES=&FORMAT=image/png
and
http://172.30.229.42/fcgi-bin/mapserv.fcgi?map=/mapserver/config/mapfiler/WMS/topo_skaermkort/topo_skaermkort_mailinglist.map&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&BBOX=-280235,5874930,649671,6549730&CRS=EPSG:25833&WIDTH=867&HEIGHT=629&LAYERS=dtk_skaermkort_1548&STYLES=&FORMAT=image/png

What have I done wrong?

Sample data: https://www.dropbox.com/s/gw8h8lrwwb0gltz/data.zip?dl=0
Map file:

MAP
    NAME "topo_skaermkort"
    EXTENT 120000 5900000 1000000 6500000
    MAXSIZE 10000
    STATUS ON
    UNITS METERS
    DEBUG 5
    SHAPEPATH "/mapserver/data/skaermkort_ok"
    CONFIG "ON_MISSING_DATA" "LOG"
    CONFIG "MS_ERRORFILE" "maperror_topo_skaermkort_local.txt"
    PROJECTION
        "init=epsg:25832"
    END
    WEB
        IMAGEPATH "/mapserver/data/skaermkort_ok/originalt/"
        METADATA
            "wms_title" "DTK/Sk√¶rmkort"
            "wms_srs" "EPSG:4326 EPSG:4258 EPSG:25832 EPSG:25833 EPSG:32632 EPSG:32633 EPSG:4093 EPSG:4094 EPSG:4095 EPSG:4096 EPSG:3395 EPSG:3857"
            "wms_bbox_extended" "TRUE"
            "wms_getmap_formatlist" "image/jpeg,image/png"
            "ows_enable_request" "* !GetFeatureInfo"
            "wms_encoding" "utf-8"
        END
    END
    LAYER
        NAME "dtk_skaermkort"
        EXTENT 120000 5900000 1000000 6500000
        STATUS ON
        TYPE raster
        PROCESSING "RESAMPLE=BILINEAR"
        CONNECTIONTYPE UNION
        CONNECTION "s3096,s1548,s774,s387,s193,s96,s48,s24,s12,s6,s3,s1,s07"
        METADATA
            "wms_title" "dtk_skaermkort"
            "wms_srs" "epsg:25832"
            "wms_group_title" "dtk_skaermkort"
        END
    END
    LAYER
        GROUP "dtk_skaermkort"
        NAME "s3096"
        TILEINDEX "originalt/s3096/s3096x.shp"
        TILEITEM "location"
        EXTENT 120000 5900000 1000000 6500000
        MINSCALEDENOM 1201748.867
        MAXSCALEDENOM 30000000
        STATUS OFF
        TYPE raster
        PROCESSING "RESAMPLE=BILINEAR"
        METADATA
            "wms_title" "s3096"
            "wms_srs" "epsg:25832"
           "wms_enable_request" "!GetCapabilities"
        END
    END
    LAYER
        GROUP "dtk_skaermkort"
        NAME "s1548"
        TILEINDEX "originalt/s1548/s1548x.shp"
        TILEITEM "location"
        EXTENT 120000 5900000 1000000 6500000
        MINSCALEDENOM 600874.809
        MAXSCALEDENOM 1201748.866
        STATUS OFF
        TYPE raster
        PROCESSING "RESAMPLE=BILINEAR"
        METADATA
            "wms_title" "s1548"
            "wms_srs" "epsg:25832"
            "wms_enable_request" "!GetCapabilities"
        END
    END
END

Kind Regards,
/julian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapserver-users/attachments/20180912/a8f199c2/attachment-0001.html>

------------------------------

Subject: Digest Footer

_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users

------------------------------

End of mapserver-users Digest, Vol 128, Issue 9
***********************************************
_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users