Re: Installing QGIS- 3.4.x Madeira LTR for Ubuntu xenial

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Installing QGIS- 3.4.x Madeira LTR for Ubuntu xenial

Mike Flannigan

I have your exact same problem, except I tried to
install QGIS 3.10 after uninstalling my QGIS 2.18.
I am on Linux Mint 19.2.

When I go to the directory: /usr/share/gdal
I have a folder "2.2"

My sources.list file located here:
/etc/apt/sources.list
has this inside it:

#deb cdrom:[Linux Mint 19.2 _Tina_ - Release amd64 20190729]/ bionic
contrib main non-free
deb https://qgis.org/ubuntu/ unstable main
deb-src https://qgis.org/ubuntu/ unstable main


The output of the 2 install commands is shown below.

The problem is that I try to install QGIS 3.10 and I
wind up with QGIS 2.18.

If I get this problem fixed I'll let you know what
I did.  I'm not real motivated to fix it right now
since QGIS 2.18 meets most of my needs.

Thank you.


Mike



mike@mike-linuxmint:~/Documents/00MikeF$ sudo apt-get update
Ign:1 http://packages.linuxmint.com tina InRelease
Hit:2 http://packages.linuxmint.com tina Release
Ign:3 http://dl.google.com/linux/earth/deb stable InRelease
Hit:4 http://archive.canonical.com/ubuntu bionic InRelease
Hit:5 http://dl.google.com/linux/earth/deb stable Release
Hit:7 http://ppa.launchpad.net/thomas.tsai/ubuntu-tuxboot/ubuntu bionic
InRelease
Hit:8 http://archive.ubuntu.com/ubuntu bionic InRelease
Get:9 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:12 https://qgis.org/ubuntu unstable InRelease [3,703 B]
Err:12 https://qgis.org/ubuntu unstable InRelease
   The following signatures couldn't be verified because the public key
is not available: NO_PUBKEY 51F523511C7028C3
Get:13 http://security.ubuntu.com/ubuntu bionic-security/main amd64
DEP-11 Metadata [38.5 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6
kB]
Get:15 http://security.ubuntu.com/ubuntu bionic-security/universe amd64
DEP-11 Metadata [42.2 kB]
Get:16 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11
Metadata [295 kB]
Get:17 http://security.ubuntu.com/ubuntu bionic-security/multiverse
amd64 DEP-11 Metadata [2,460 B]
Get:18 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64
DEP-11 Metadata [264 kB]
Get:19 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64
DEP-11 Metadata [2,464 B]
Get:20 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64
DEP-11 Metadata [7,976 B]
Reading package lists... Done
N: Skipping acquire of configured file 'main/binary-i386/Packages' as
repository 'http://dl.google.com/linux/earth/deb stable InRelease'
doesn't support architecture 'i386'
W: GPG error: https://qgis.org/ubuntu unstable InRelease: The following
signatures couldn't be verified because the public key is not available:
NO_PUBKEY 51F523511C7028C3
E: The repository 'https://qgis.org/ubuntu unstable InRelease' is not
signed.
N: Updating from such a repository can't be done securely, and is
therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user
configuration details.
mike@mike-linuxmint:~/Documents/00MikeF$ sudo apt-get install qgis
qgis-plugin-grass
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
   qgis-provider-grass
Suggested packages:
   gpsbabel
The following NEW packages will be installed:
   qgis qgis-plugin-grass qgis-provider-grass
0 upgraded, 3 newly installed, 0 to remove and 32 not upgraded.
Need to get 5,938 kB of archives.
After this operation, 23.5 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic/universe amd64 qgis amd64
2.18.17+dfsg-1 [5,263 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic/universe amd64
qgis-provider-grass amd64 2.18.17+dfsg-1 [86.7 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/universe amd64
qgis-plugin-grass amd64 2.18.17+dfsg-1 [588 kB]
Fetched 5,938 kB in 4s (1,418 kB/s)
Selecting previously unselected package qgis.
(Reading database ... 360406 files and directories currently installed.)
Preparing to unpack .../qgis_2.18.17+dfsg-1_amd64.deb ...
Unpacking qgis (2.18.17+dfsg-1) ...
Selecting previously unselected package qgis-provider-grass.
Preparing to unpack .../qgis-provider-grass_2.18.17+dfsg-1_amd64.deb ...
Unpacking qgis-provider-grass (2.18.17+dfsg-1) ...
Selecting previously unselected package qgis-plugin-grass.
Preparing to unpack .../qgis-plugin-grass_2.18.17+dfsg-1_amd64.deb ...
Unpacking qgis-plugin-grass (2.18.17+dfsg-1) ...
Setting up qgis (2.18.17+dfsg-1) ...
Setting up qgis-provider-grass (2.18.17+dfsg-1) ...
Setting up qgis-plugin-grass (2.18.17+dfsg-1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23+linuxmint6) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
mike@mike-linuxmint:~/Documents/00MikeF$



On 11/12/19 8:56 AM, [hidden email] wrote:

> Good afternoon,
>
> I have a question about  QGIS- 3.4.x Madeira LTR for Ubuntu xenial.
> Today I installed this version in my computer. I added the lines:
>
> debhttps://qgis.org/ubuntu-ltr  xenial main deb-src
> https://qgis.org/ubuntu-ltr  xenial main
>
> _to the repositories in the source list._
> <https://qgis.org/ubuntu-ltr>
>
> However, when I execute QGIS, instead of version 3.4 Madeira, I find:
> QGis 2.18.28 Las Palmas. Did I do something wrong? How could I get
> version 3.4?
>
> Thanks a lot
>
> Rosa.

On 11/12/19 12:04 PM, [hidden email] wrote:

> Message: 3
> Date: Tue, 12 Nov 2019 17:29:00 +0100
> From: Jürgen E. Fischer<[hidden email]>
> To:[hidden email]
> Subject: Re: [Qgis-user] Installing QGIS- 3.4.x Madeira LTR for Ubuntu
> xenial
>
>
> Hi Rosa,
> xenial's GDAL is too old. QGIS3 at least needs GDAL2. You can use
> ubuntugis-ltr (see
> https://qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu).
>
>
> Jürgen


On 11/9/19 2:00 PM, [hidden email] wrote:

> Message: 9
> Date: Sat, 9 Nov 2019 10:29:17 -0800
> From: Dave Stevens<[hidden email]>
> To: QGIS User<[hidden email]>
> Subject: [Qgis-user] linux qgis repo error
>
> I'm getting this warning on updating Linux Mint:
>
> W: GPG error:https://qgis.org/debian  xenial InRelease: The following
> signatures couldn't be verified because the public key is not
> available: NO_PUBKEY 51F523511C7028C3 W: The repository
> 'https://qgis.org/debian  xenial InRelease' is not signed.
>
> Who is responsible for this?
>
> Thanks!
>
> d


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Installing QGIS- 3.4.x Madeira LTR for Ubuntu xenial

Andre Joost
Am 20.11.19 um 11:13 schrieb Mike Flannigan:

>
> I have your exact same problem, except I tried to
> install QGIS 3.10 after uninstalling my QGIS 2.18.
> I am on Linux Mint 19.2.
>
> When I go to the directory: /usr/share/gdal
> I have a folder "2.2"
>
> My sources.list file located here:
> /etc/apt/sources.list
> has this inside it:
>
> #deb cdrom:[Linux Mint 19.2 _Tina_ - Release amd64 20190729]/ bionic
> contrib main non-free
> deb https://qgis.org/ubuntu/ unstable main
> deb-src https://qgis.org/ubuntu/ unstable main
>
>
> The output of the 2 install commands is shown below.
>
> The problem is that I try to install QGIS 3.10 and I
> wind up with QGIS 2.18.
>

The problem is that you have not added the QGIS key to your keyring.
Hence the whole qgis.org repo is left out, and you get QGIS2 from the
main Ubuntu repo.

Try
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-key
51F523511C7028C3

in one line, and it should work.

HTH,
Andre Joost


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Installing QGIS- 3.4.x Madeira LTR for Ubuntu xenial

Mike Flannigan
In reply to this post by Mike Flannigan

Thanks for the advice.  I think it did not work for me:


mike@mike-linuxmint:~/Documents/00MikeF$ sudo apt-key adv --keyserver
keyserver.ubuntu.com --recv-key 51F523511C7028C3
[sudo] password for mike:
Executing: /tmp/apt-key-gpghome.a2sfPXpuV7/gpg.1.sh --keyserver
keyserver.ubuntu.com --recv-key 51F523511C7028C3
gpg: key 51F523511C7028C3: 1 signature not checked due to a missing key
gpg: key 51F523511C7028C3: public key "QGIS Archive Automatic Signing
Key (2019) <[hidden email]>" imported
gpg: Total number processed: 1
gpg:               imported: 1

mike@mike-linuxmint:~/Documents/00MikeF$


Mike


On 11/20/19 2:00 PM, [hidden email] wrote:

> The problem is that you have not added the QGIS key to your keyring.
> Hence the whole qgis.org repo is left out, and you get QGIS2 from the
> main Ubuntu repo.
>
> Try
> sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-key
> 51F523511C7028C3
>
> in one line, and it should work.
>
> HTH,
> Andre Joost


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Installing QGIS- 3.4.x Madeira LTR for Ubuntu xenial

Mike Flannigan
In reply to this post by Mike Flannigan

About a week or so ago I did a manual update called for
on my Linux Mint panel.  It put both QGIS 3.10.0 and
QGIS 3.8.3 in Software Manager.  I first tried QGIS 3.10.0
and it failed on dependencies.  So I tried QGIS 3.8.3
and it installed great after I uninstalled my 2.18 version.
So I have been using QGIS 3.10.0 for about a week now.

Thank you.


Mike



On 11/20/19 4:13 AM, Mike Flannigan wrote:

>
> I have your exact same problem, except I tried to
> install QGIS 3.10 after uninstalling my QGIS 2.18.
> I am on Linux Mint 19.2.
>
> When I go to the directory: /usr/share/gdal
> I have a folder "2.2"
>
> My sources.list file located here:
> /etc/apt/sources.list
> has this inside it:
>
> #deb cdrom:[Linux Mint 19.2 _Tina_ - Release amd64 20190729]/ bionic
> contrib main non-free
> deb https://qgis.org/ubuntu/ unstable main
> deb-src https://qgis.org/ubuntu/ unstable main
>
>
> The output of the 2 install commands is shown below.
>
> The problem is that I try to install QGIS 3.10 and I
> wind up with QGIS 2.18.
>
> If I get this problem fixed I'll let you know what
> I did.  I'm not real motivated to fix it right now
> since QGIS 2.18 meets most of my needs.
>
> Thank you.
>
>
> Mike
>
>
>
> mike@mike-linuxmint:~/Documents/00MikeF$ sudo apt-get update
> Ign:1 http://packages.linuxmint.com tina InRelease
> Hit:2 http://packages.linuxmint.com tina Release
> Ign:3 http://dl.google.com/linux/earth/deb stable InRelease
> Hit:4 http://archive.canonical.com/ubuntu bionic InRelease
> Hit:5 http://dl.google.com/linux/earth/deb stable Release
> Hit:7 http://ppa.launchpad.net/thomas.tsai/ubuntu-tuxboot/ubuntu 
> bionic InRelease
> Hit:8 http://archive.ubuntu.com/ubuntu bionic InRelease
> Get:9 http://security.ubuntu.com/ubuntu bionic-security InRelease
> [88.7 kB]
> Get:11 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7
> kB]
> Get:12 https://qgis.org/ubuntu unstable InRelease [3,703 B]
> Err:12 https://qgis.org/ubuntu unstable InRelease
>   The following signatures couldn't be verified because the public key
> is not available: NO_PUBKEY 51F523511C7028C3
> Get:13 http://security.ubuntu.com/ubuntu bionic-security/main amd64
> DEP-11 Metadata [38.5 kB]
> Get:14 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
> [74.6 kB]
> Get:15 http://security.ubuntu.com/ubuntu bionic-security/universe
> amd64 DEP-11 Metadata [42.2 kB]
> Get:16 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64
> DEP-11 Metadata [295 kB]
> Get:17 http://security.ubuntu.com/ubuntu bionic-security/multiverse
> amd64 DEP-11 Metadata [2,460 B]
> Get:18 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64
> DEP-11 Metadata [264 kB]
> Get:19 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse
> amd64 DEP-11 Metadata [2,464 B]
> Get:20 http://archive.ubuntu.com/ubuntu bionic-backports/universe
> amd64 DEP-11 Metadata [7,976 B]
> Reading package lists... Done
> N: Skipping acquire of configured file 'main/binary-i386/Packages' as
> repository 'http://dl.google.com/linux/earth/deb stable InRelease'
> doesn't support architecture 'i386'
> W: GPG error: https://qgis.org/ubuntu unstable InRelease: The
> following signatures couldn't be verified because the public key is
> not available: NO_PUBKEY 51F523511C7028C3
> E: The repository 'https://qgis.org/ubuntu unstable InRelease' is not
> signed.
> N: Updating from such a repository can't be done securely, and is
> therefore disabled by default.
> N: See apt-secure(8) manpage for repository creation and user
> configuration details.
> mike@mike-linuxmint:~/Documents/00MikeF$ sudo apt-get install qgis
> qgis-plugin-grass
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following additional packages will be installed:
>   qgis-provider-grass
> Suggested packages:
>   gpsbabel
> The following NEW packages will be installed:
>   qgis qgis-plugin-grass qgis-provider-grass
> 0 upgraded, 3 newly installed, 0 to remove and 32 not upgraded.
> Need to get 5,938 kB of archives.
> After this operation, 23.5 MB of additional disk space will be used.
> Do you want to continue? [Y/n] y
> Get:1 http://archive.ubuntu.com/ubuntu bionic/universe amd64 qgis
> amd64 2.18.17+dfsg-1 [5,263 kB]
> Get:2 http://archive.ubuntu.com/ubuntu bionic/universe amd64
> qgis-provider-grass amd64 2.18.17+dfsg-1 [86.7 kB]
> Get:3 http://archive.ubuntu.com/ubuntu bionic/universe amd64
> qgis-plugin-grass amd64 2.18.17+dfsg-1 [588 kB]
> Fetched 5,938 kB in 4s (1,418 kB/s)
> Selecting previously unselected package qgis.
> (Reading database ... 360406 files and directories currently installed.)
> Preparing to unpack .../qgis_2.18.17+dfsg-1_amd64.deb ...
> Unpacking qgis (2.18.17+dfsg-1) ...
> Selecting previously unselected package qgis-provider-grass.
> Preparing to unpack .../qgis-provider-grass_2.18.17+dfsg-1_amd64.deb ...
> Unpacking qgis-provider-grass (2.18.17+dfsg-1) ...
> Selecting previously unselected package qgis-plugin-grass.
> Preparing to unpack .../qgis-plugin-grass_2.18.17+dfsg-1_amd64.deb ...
> Unpacking qgis-plugin-grass (2.18.17+dfsg-1) ...
> Setting up qgis (2.18.17+dfsg-1) ...
> Setting up qgis-provider-grass (2.18.17+dfsg-1) ...
> Setting up qgis-plugin-grass (2.18.17+dfsg-1) ...
> Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
> Processing triggers for mime-support (3.60ubuntu1) ...
> Processing triggers for desktop-file-utils (0.23+linuxmint6) ...
> Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
> mike@mike-linuxmint:~/Documents/00MikeF$
>
>
>
> On 11/12/19 8:56 AM, [hidden email] wrote:
>> Good afternoon,
>>
>> I have a question about  QGIS- 3.4.x Madeira LTR for Ubuntu xenial.
>> Today I installed this version in my computer. I added the lines:
>>
>> debhttps://qgis.org/ubuntu-ltr  xenial main deb-src
>> https://qgis.org/ubuntu-ltr  xenial main
>>
>> _to the repositories in the source list._
>> <https://qgis.org/ubuntu-ltr>
>>
>> However, when I execute QGIS, instead of version 3.4 Madeira, I find:
>> QGis 2.18.28 Las Palmas. Did I do something wrong? How could I get
>> version 3.4?
>>
>> Thanks a lot
>>
>> Rosa.
>
> On 11/12/19 12:04 PM, [hidden email] wrote:
>> Message: 3
>> Date: Tue, 12 Nov 2019 17:29:00 +0100
>> From: Jürgen E. Fischer<[hidden email]>
>> To:[hidden email]
>> Subject: Re: [Qgis-user] Installing QGIS- 3.4.x Madeira LTR for Ubuntu
>>     xenial
>>
>>
>> Hi Rosa,
>> xenial's GDAL is too old. QGIS3 at least needs GDAL2. You can use
>> ubuntugis-ltr (see
>> https://qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu).
>>
>>
>> Jürgen
>
>
> On 11/9/19 2:00 PM, [hidden email] wrote:
>> Message: 9
>> Date: Sat, 9 Nov 2019 10:29:17 -0800
>> From: Dave Stevens<[hidden email]>
>> To: QGIS User<[hidden email]>
>> Subject: [Qgis-user] linux qgis repo error
>>
>> I'm getting this warning on updating Linux Mint:
>>
>> W: GPG error:https://qgis.org/debian  xenial InRelease: The following
>> signatures couldn't be verified because the public key is not
>> available: NO_PUBKEY 51F523511C7028C3 W: The repository
>> 'https://qgis.org/debian  xenial InRelease' is not signed.
>>
>> Who is responsible for this?
>>
>> Thanks!
>>
>> d
>
>
>


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user