Re: GeoServer Meeting 2017-06-27

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: GeoServer Meeting 2017-06-27

Ben Caradoc-Davies-2
On 28/06/17 04:34, Jody Garnett wrote:
> App-schema online build fails every day and sends mails to Andrea directly
> and to “[hidden email]”.

From:
https://build.geoserver.org/job/geoserver-master-app-schema-online/829/consoleText

/tmp/jenkins8083760168206680279.sh: line 13: psql: command not found

It looks like psql is used in the Jenkins script to set up the postgis
test database.

Kind regards,

--
Ben Caradoc-Davies <[hidden email]>
Director
Transient Software Limited <http://transient.nz/>
New Zealand

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Install psql on build.geoserver.org

Ben Caradoc-Davies-2
On 28/06/17 13:21, Ben Caradoc-Davies wrote:
> On 28/06/17 04:34, Jody Garnett wrote:
>> App-schema online build fails every day and sends mails to Andrea
>> directly
>> and to “[hidden email]”.
> From:
> https://build.geoserver.org/job/geoserver-master-app-schema-online/829/consoleText 
> /tmp/jenkins8083760168206680279.sh: line 13: psql: command not found
> It looks like psql is used in the Jenkins script to set up the postgis
> test database.

Jody and Nick,

fixing this could be as simple as installing psql on
build.geoserver.org. For Debian and Ubuntu, this can be achieved by
installing the postgresql-client metapackage.

Kind regards,

--
Ben Caradoc-Davies <[hidden email]>
Director
Transient Software Limited <http://transient.nz/>
New Zealand

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Torben Barsballe
Hi Ben,

I've been working with Nick on this today, and the postgis and oracle online tests on build.geoserver.org are now passing.

See:

Torben

On Fri, Jun 30, 2017 at 5:52 PM, Ben Caradoc-Davies <[hidden email]> wrote:
On 28/06/17 13:21, Ben Caradoc-Davies wrote:
On 28/06/17 04:34, Jody Garnett wrote:
App-schema online build fails every day and sends mails to Andrea directly
and to “[hidden email]orge.net.off”.
From: https://build.geoserver.org/job/geoserver-master-app-schema-online/829/consoleText /tmp/jenkins8083760168206680279.sh: line 13: psql: command not found
It looks like psql is used in the Jenkins script to set up the postgis test database.

Jody and Nick,

fixing this could be as simple as installing psql on build.geoserver.org. For Debian and Ubuntu, this can be achieved by installing the postgresql-client metapackage.

Kind regards,

--
Ben Caradoc-Davies <[hidden email]>
Director
Transient Software Limited <http://transient.nz/>
New Zealand

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Ben Caradoc-Davies-2
Thanks, Torben and Nick. Much appreciated!

How many more builds need work? How close are we to retiring ares?

Kind regards,
Ben.

On 29/07/17 11:40, Torben Barsballe wrote:

> Hi Ben,
>
> I've been working with Nick on this today, and the postgis and oracle
> online tests on build.geoserver.org are now passing.
>
> See:
> https://build.geoserver.org/job/geotools-master-online-postgis/308/
> https://build.geoserver.org/job/geotools-master-online-oracle/313/
>
> Torben
>
> On Fri, Jun 30, 2017 at 5:52 PM, Ben Caradoc-Davies <[hidden email]>
> wrote:
>
>> On 28/06/17 13:21, Ben Caradoc-Davies wrote:
>>
>>> On 28/06/17 04:34, Jody Garnett wrote:
>>>
>>>> App-schema online build fails every day and sends mails to Andrea
>>>> directly
>>>> and to “[hidden email]”.
>>>>
>>> From: https://build.geoserver.org/job/geoserver-master-app-schema-
>>> online/829/consoleText /tmp/jenkins8083760168206680279.sh: line 13:
>>> psql: command not found
>>> It looks like psql is used in the Jenkins script to set up the postgis
>>> test database.
>>>
>>
>> Jody and Nick,
>>
>> fixing this could be as simple as installing psql on build.geoserver.org.
>> For Debian and Ubuntu, this can be achieved by installing the
>> postgresql-client metapackage.
>>
>> Kind regards,
>>
>> --
>> Ben Caradoc-Davies <[hidden email]>
>> Director
>> Transient Software Limited <http://transient.nz/>
>> New Zealand
>>
>> ------------------------------------------------------------
>> ------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>> _______________________________________________
>> Geoserver-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/geoserver-devel
>>
>

--
Ben Caradoc-Davies <[hidden email]>
Director
Transient Software Limited <http://transient.nz/>
New Zealand

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Torben Barsballe
Remaining failing builds:

Some geotools builds fail on documentation, likely due to a different (newer?) version of sphinx. This is probably something that should be fixed in the docs themselves rather than the build server.
Some geofence builds are failing
geoscript-groovy is failing
geoserver-master-app-schema-online is failing.

Everything else looks good.

I'd say we are pretty close.

Torben



On Fri, Jul 28, 2017 at 5:16 PM, Ben Caradoc-Davies <[hidden email]> wrote:
Thanks, Torben and Nick. Much appreciated!

How many more builds need work? How close are we to retiring ares?

Kind regards,
Ben.


On 29/07/17 11:40, Torben Barsballe wrote:
Hi Ben,

I've been working with Nick on this today, and the postgis and oracle
online tests on build.geoserver.org are now passing.

See:
https://build.geoserver.org/job/geotools-master-online-postgis/308/
https://build.geoserver.org/job/geotools-master-online-oracle/313/

Torben

On Fri, Jun 30, 2017 at 5:52 PM, Ben Caradoc-Davies <[hidden email]>
wrote:

On 28/06/17 13:21, Ben Caradoc-Davies wrote:

On 28/06/17 04:34, Jody Garnett wrote:

App-schema online build fails every day and sends mails to Andrea
directly
and to “[hidden email]orge.net.off”.

From: https://build.geoserver.org/job/geoserver-master-app-schema-
online/829/consoleText /tmp/jenkins8083760168206680279.sh: line 13:
psql: command not found
It looks like psql is used in the Jenkins script to set up the postgis
test database.


Jody and Nick,

fixing this could be as simple as installing psql on build.geoserver.org.
For Debian and Ubuntu, this can be achieved by installing the
postgresql-client metapackage.

Kind regards,

--
Ben Caradoc-Davies <[hidden email]>
Director
Transient Software Limited <http://transient.nz/>
New Zealand

------------------------------------------------------------
------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel



--
Ben Caradoc-Davies <[hidden email]>
Director
Transient Software Limited <http://transient.nz/>
New Zealand


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Ian Turton


On 31 July 2017 at 17:06, Torben Barsballe <[hidden email]> wrote:
Remaining failing builds:

Some geotools builds fail on documentation, likely due to a different (newer?) version of sphinx. This is probably something that should be fixed in the docs themselves rather than the build server.

Do you know which Sphinx version is on the build server?

I seem to be using Sphinx (sphinx-build) 1.4.4 and the docs built for me recently.


Ian 



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Torben Barsballe
Hi Ian

I believe it is using either 1.6.1 or 1.6.2.

Torben

On Mon, Jul 31, 2017 at 9:23 AM, Ian Turton <[hidden email]> wrote:


On 31 July 2017 at 17:06, Torben Barsballe <[hidden email]> wrote:
Remaining failing builds:

Some geotools builds fail on documentation, likely due to a different (newer?) version of sphinx. This is probably something that should be fixed in the docs themselves rather than the build server.

Do you know which Sphinx version is on the build server?

I seem to be using Sphinx (sphinx-build) 1.4.4 and the docs built for me recently.


Ian 




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Nick Stires
sphinx@0.1.2

On Mon, Jul 31, 2017 at 12:27 PM, Torben Barsballe <[hidden email]> wrote:
Hi Ian

I believe it is using either 1.6.1 or 1.6.2.

Torben

On Mon, Jul 31, 2017 at 9:23 AM, Ian Turton <[hidden email]> wrote:


On 31 July 2017 at 17:06, Torben Barsballe <[hidden email]> wrote:
Remaining failing builds:

Some geotools builds fail on documentation, likely due to a different (newer?) version of sphinx. This is probably something that should be fixed in the docs themselves rather than the build server.

Do you know which Sphinx version is on the build server?

I seem to be using Sphinx (sphinx-build) 1.4.4 and the docs built for me recently.


Ian 






--
Nick Stires
DevOps Engineer | Boundless
[hidden email]
Mobile: +1 561-713-0922



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Nick Stires
Looks like it's installed via NPM, so should be easy to upgrade.

-Nick

On Mon, Jul 31, 2017 at 12:30 PM, Nick Stires <[hidden email]> wrote:
sphinx@0.1.2

On Mon, Jul 31, 2017 at 12:27 PM, Torben Barsballe <[hidden email]> wrote:
Hi Ian

I believe it is using either 1.6.1 or 1.6.2.

Torben

On Mon, Jul 31, 2017 at 9:23 AM, Ian Turton <[hidden email]> wrote:


On 31 July 2017 at 17:06, Torben Barsballe <[hidden email]> wrote:
Remaining failing builds:

Some geotools builds fail on documentation, likely due to a different (newer?) version of sphinx. This is probably something that should be fixed in the docs themselves rather than the build server.

Do you know which Sphinx version is on the build server?

I seem to be using Sphinx (sphinx-build) 1.4.4 and the docs built for me recently.


Ian 






--
Nick Stires
DevOps Engineer | Boundless
[hidden email]
Mobile: <a href="tel:(561)%20713-0922" value="+15617130922" target="_blank">+1 561-713-0922





--
Nick Stires
DevOps Engineer | Boundless
[hidden email]
Mobile: +1 561-713-0922



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Ian Turton
I've just made a successful mvn -nsu clean install in docs with sphinx 1.6.3 but there are a couple of warnings that might break the jenkins build 

sphinx-ignore-warnings:
     [exec] Running Sphinx v1.6.3
     [exec] loading pickled environment... failed: Can't get attribute 'WarningStream' on <module 'sphinx.util.nodes' from '/usr/local/lib/python3.4/dist-packages/sphinx/util/nodes.py'>
     [exec] building [mo]: targets for 0 po files that are out of date
     [exec] building [html]: targets for 1 source files that are out of date
     [exec] updating environment: 1 added, 0 changed, 0 removed
     [exec] reading sources... [100%] index

     [exec] /usr/local/lib/python3.4/dist-packages/sphinx/util/requests.py:72: UserWarning: Some links may return broken results due to being unable to check the Server Name Indication (SNI) in the returned SSL cert against the hostname in the url requested. Recommended to install requests-2.4.1+.

doing pip install requests==2.4.1 seems to fix them (seems like 2.2.1 is default on ubuntu)

and then it throws up some actual textual problems

     [exec] /home/ian/code/geotools/docs/index/index.rst:2: WARNING: Duplicate explicit target name: "stable".
     [exec] /home/ian/code/geotools/docs/index/index.rst:2: WARNING: Duplicate explicit target name: "stable".
     [exec] /home/ian/code/geotools/docs/index/index.rst:2: WARNING: Duplicate explicit target name: "stable".
     [exec] /home/ian/code/geotools/docs/index/index.rst:2: WARNING: Duplicate explicit target name: "stable".
     [exec] /home/ian/code/geotools/docs/index/index.rst:2: WARNING: Duplicate explicit target name: "maintenance".
     [exec] looking for now-outdated files... none found
     [exec] /home/ian/code/geotools/docs/index/index.rst:2: WARNING: Duplicate explicit target name: "stable".
     [exec] /home/ian/code/geotools/docs/index/index.rst:2: WARNING: Duplicate explicit target name: "maintenance".

I'll have a look later.

Ian


On 31 July 2017 at 17:31, Nick Stires <[hidden email]> wrote:
Looks like it's installed via NPM, so should be easy to upgrade.

-Nick

On Mon, Jul 31, 2017 at 12:30 PM, Nick Stires <[hidden email]> wrote:
sphinx@0.1.2

On Mon, Jul 31, 2017 at 12:27 PM, Torben Barsballe <[hidden email]> wrote:
Hi Ian

I believe it is using either 1.6.1 or 1.6.2.

Torben

On Mon, Jul 31, 2017 at 9:23 AM, Ian Turton <[hidden email]> wrote:


On 31 July 2017 at 17:06, Torben Barsballe <[hidden email]> wrote:
Remaining failing builds:

Some geotools builds fail on documentation, likely due to a different (newer?) version of sphinx. This is probably something that should be fixed in the docs themselves rather than the build server.

Do you know which Sphinx version is on the build server?

I seem to be using Sphinx (sphinx-build) 1.4.4 and the docs built for me recently.


Ian 






--
Nick Stires
DevOps Engineer | Boundless
[hidden email]
Mobile: <a href="tel:(561)%20713-0922" value="+15617130922" target="_blank">+1 561-713-0922





--
Nick Stires
DevOps Engineer | Boundless
[hidden email]
Mobile: <a href="tel:+1%20561-713-0922" value="+15617130922" target="_blank">+1 561-713-0922





--
Ian Turton

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel
Reply | Threaded
Open this post in threaded view
|

Re: Install psql on build.geoserver.org

Ben Caradoc-Davies-2
In reply to this post by Torben Barsballe
On 01/08/17 04:06, Torben Barsballe wrote:
> geoserver-master-app-schema-online is failing.

Should psql be installed on the slave (as originally requested in this
thread) or will you switch to a one-off manual configuration of the
database?

Kind regards,

--
Ben Caradoc-Davies <[hidden email]>
Director
Transient Software Limited <http://transient.nz/>
New Zealand

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Geoserver-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-devel