Re: GeoNode-Project@2.8 Python version

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: GeoNode-Project@2.8 Python version

toni_schoenbuchner
Dear Julierme,

the problem is of numpy 1.17 you have to downgrade it in your dockerfile.
This is already fixed in geonode core. I will try to PR for the project today.

Cheers,

Toni

> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 15 Jul 2019 22:41:39 -0300
> From: 1520 gis <[hidden email]>
> To: geonode-users <[hidden email]>,  geonode-devel
> <[hidden email]>
> Subject: [GeoNode-devel] GeoNode-Project@2.8 Python version
> Message-ID:
> <[hidden email]>
> Content-Type: text/plain; charset="utf-8"
>
> Dear users and developers,
>
> I have been trying to install GeoNode-Project@2.8 via Docker on an
> Ubuntu@18.04LTS server, but while building the images, the installation is
> facing the following error:
>
> Collecting pygdal==2.1.2.3
>  Downloading
> https://files.pythonhosted.org/packages/37/4f/64823b0000ce4364bbddd4c46a21f80326910bae3763f9e514ececbd37d6/pygdal-2.1.2.3.tar.gz
> (407kB)
>    ERROR: Complete output from command python setup.py egg_info:
>    ERROR: Traceback (most recent call last):
>      File "<string>", line 1, in <module>
>      File "/tmp/pip-install-L5AGEr/pygdal/setup.py", line 173, in <module>
>        cmdclass=dict(build_ext=gdal_ext),
>      File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py",
> line 128, in setup
>        _install_setup_requires(attrs)
>      File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py",
> line 123, in _install_setup_requires
>        dist.fetch_build_eggs(dist.setup_requires)
>      File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py",
> line 504, in fetch_build_eggs
>        replace_conflicting=True,
>      File
> "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
> 774, in resolve
>        replace_conflicting=replace_conflicting
>      File
> "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
> 1057, in best_match
>        return self.obtain(req, installer)
>      File
> "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
> 1069, in obtain
>        return installer(requirement)
>      File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py",
> line 571, in fetch_build_egg
>        return cmd.easy_install(req)
>      File
> "/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
> line 673, in easy_install
>        return self.install_item(spec, dist.location, tmpdir, deps)
>      File
> "/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
> line 699, in install_item
>        dists = self.install_eggs(spec, download, tmpdir)
>      File
> "/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
> line 884, in install_eggs
>        return self.build_and_install(setup_script, setup_base)
>      File
> "/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
> line 1152, in build_and_install
>        self.run_setup(setup_script, setup_base, args)
>      File
> "/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
> line 1138, in run_setup
>        run_setup(setup_script, args)
>      File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
> line 253, in run_setup
>        raise
>      File "/usr/local/lib/python2.7/contextlib.py", line 35, in __exit__
>        self.gen.throw(type, value, traceback)
>      File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
> line 195, in setup_context
>        yield
>      File "/usr/local/lib/python2.7/contextlib.py", line 35, in __exit__
>        self.gen.throw(type, value, traceback)
>      File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
> line 166, in save_modules
>        saved_exc.resume()
>      File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
> line 141, in resume
>        six.reraise(type, exc, self._tb)
>      File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
> line 154, in save_modules
>        yield saved
>      File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
> line 195, in setup_context
>        yield
>      File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
> line 250, in run_setup
>        _execfile(setup_script, ns)
>      File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
> line 45, in _execfile
>        exec(code, globals, locals)
>      File "/tmp/easy_install-1_bgIy/numpy-1.17.0rc1/setup.py", line 31, in
> <module>
>
>    RuntimeError: Python version >= 3.5 required.
>    ----------------------------------------
> ERROR: Command "python setup.py egg_info" failed with error code 1 in
> /tmp/pip-install-L5AGEr/pygdal/
> ERROR: Service 'celery' failed to build: The command '/bin/sh -c
> GDAL_VERSION=`gdal-config --version`     && PYGDAL_VERSION="$(pip install
> pygdal==$GDAL_VERSION 2>&1 | grep -oP '(?<=: )(.*)(?=\))' | grep -oh
> $GDAL_VERSION\.[0-9])"     && pip install pygdal==$PYGDAL_VERSION' returned
> a non-zero code: 1
> (my_geonode) geo@1520GIS:/home/geonode/my_geonode$ python -V
> Python 2.7.15+
>
> Any help will be very appreciated.
>
> Kind regards
>
> Julierme
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20190715/4e030870/attachment-0001.html>
>
> -----
_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users
Reply | Threaded
Open this post in threaded view
|

Re: GeoNode-Project@2.8 Python version

toni_schoenbuchner
Julierme, me again. Please pull latest commits for your project.

best regards,

toni


-----------------------------------------------
CSGIS

-----------------------------------------------
Gottschedstraße 12
04109 Leipzig
-----------------------------------------------
-----------------------------------------------

Hinweis gemäß § 33 BDSG
Daten der Verfahrensbeteiligten werden gespeichert. Dieses Dokument ist ausschließlich für den 
Adressaten bestimmt. Der Inhalt der E-Mail ist vertraulich. Falls Sie diese E-Mail versehentlich 
erhalten haben, rufen Sie uns unter obiger Rufnummer umgehend an und löschen Sie diese Nachricht 
von Ihrem Computer. Jegliche Art von Reproduktionen, Verbreitung, Vervielfältigung, Veränderung, 
Verteilung und/oder Veröffentlichung dieser E-Mail ist verboten.

Am 16.07.2019 um 10:30 schrieb Toni Schönbuchner <[hidden email]>:

Dear Julierme,

the problem is of numpy 1.17 you have to downgrade it in your dockerfile.
This is already fixed in geonode core. I will try to PR for the project today.

Cheers,

Toni

----------------------------------------------------------------------

Message: 1
Date: Mon, 15 Jul 2019 22:41:39 -0300
From: 1520 gis <[hidden email]>
To: geonode-users <[hidden email]>,  geonode-devel
<[hidden email]>
Subject: [GeoNode-devel] GeoNode-Project@2.8 Python version
Message-ID:
<[hidden email]>
Content-Type: text/plain; charset="utf-8"

Dear users and developers,

I have been trying to install GeoNode-Project@2.8 via Docker on an
Ubuntu@18.04LTS server, but while building the images, the installation is
facing the following error:

Collecting pygdal==2.1.2.3
Downloading
https://files.pythonhosted.org/packages/37/4f/64823b0000ce4364bbddd4c46a21f80326910bae3763f9e514ececbd37d6/pygdal-2.1.2.3.tar.gz
(407kB)
  ERROR: Complete output from command python setup.py egg_info:
  ERROR: Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "/tmp/pip-install-L5AGEr/pygdal/setup.py", line 173, in <module>
      cmdclass=dict(build_ext=gdal_ext),
    File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py",
line 128, in setup
      _install_setup_requires(attrs)
    File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py",
line 123, in _install_setup_requires
      dist.fetch_build_eggs(dist.setup_requires)
    File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py",
line 504, in fetch_build_eggs
      replace_conflicting=True,
    File
"/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
774, in resolve
      replace_conflicting=replace_conflicting
    File
"/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
1057, in best_match
      return self.obtain(req, installer)
    File
"/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
1069, in obtain
      return installer(requirement)
    File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py",
line 571, in fetch_build_egg
      return cmd.easy_install(req)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 673, in easy_install
      return self.install_item(spec, dist.location, tmpdir, deps)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 699, in install_item
      dists = self.install_eggs(spec, download, tmpdir)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 884, in install_eggs
      return self.build_and_install(setup_script, setup_base)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 1152, in build_and_install
      self.run_setup(setup_script, setup_base, args)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 1138, in run_setup
      run_setup(setup_script, args)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 253, in run_setup
      raise
    File "/usr/local/lib/python2.7/contextlib.py", line 35, in __exit__
      self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 195, in setup_context
      yield
    File "/usr/local/lib/python2.7/contextlib.py", line 35, in __exit__
      self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 166, in save_modules
      saved_exc.resume()
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 141, in resume
      six.reraise(type, exc, self._tb)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 154, in save_modules
      yield saved
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 195, in setup_context
      yield
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 250, in run_setup
      _execfile(setup_script, ns)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 45, in _execfile
      exec(code, globals, locals)
    File "/tmp/easy_install-1_bgIy/numpy-1.17.0rc1/setup.py", line 31, in
<module>

  RuntimeError: Python version >= 3.5 required.
  ----------------------------------------
ERROR: Command "python setup.py egg_info" failed with error code 1 in
/tmp/pip-install-L5AGEr/pygdal/
ERROR: Service 'celery' failed to build: The command '/bin/sh -c
GDAL_VERSION=`gdal-config --version`     && PYGDAL_VERSION="$(pip install
pygdal==$GDAL_VERSION 2>&1 | grep -oP '(?<=: )(.*)(?=\))' | grep -oh
$GDAL_VERSION\.[0-9])"     && pip install pygdal==$PYGDAL_VERSION' returned
a non-zero code: 1
(my_geonode) geo@1520GIS:/home/geonode/my_geonode$ python -V
Python 2.7.15+

Any help will be very appreciated.

Kind regards

Julierme
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20190715/4e030870/attachment-0001.html>

-----


_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users
Reply | Threaded
Open this post in threaded view
|

Re: GeoNode-Project@2.8 Python version

juliermeopensourcedeveloper
Dear Toni,

The installation went through. I appreciated your reply.

Kind regards

Julierme



On Tue, Jul 16, 2019 at 5:51 AM Toni Schönbuchner <[hidden email]> wrote:
Julierme, me again. Please pull latest commits for your project.

best regards,

toni


-----------------------------------------------
CSGIS

-----------------------------------------------
Gottschedstraße 12
04109 Leipzig
-----------------------------------------------
-----------------------------------------------

Hinweis gemäß § 33 BDSG
Daten der Verfahrensbeteiligten werden gespeichert. Dieses Dokument ist ausschließlich für den 
Adressaten bestimmt. Der Inhalt der E-Mail ist vertraulich. Falls Sie diese E-Mail versehentlich 
erhalten haben, rufen Sie uns unter obiger Rufnummer umgehend an und löschen Sie diese Nachricht 
von Ihrem Computer. Jegliche Art von Reproduktionen, Verbreitung, Vervielfältigung, Veränderung, 
Verteilung und/oder Veröffentlichung dieser E-Mail ist verboten.

Am 16.07.2019 um 10:30 schrieb Toni Schönbuchner <[hidden email]>:

Dear Julierme,

the problem is of numpy 1.17 you have to downgrade it in your dockerfile.
This is already fixed in geonode core. I will try to PR for the project today.

Cheers,

Toni

----------------------------------------------------------------------

Message: 1
Date: Mon, 15 Jul 2019 22:41:39 -0300
From: 1520 gis <[hidden email]>
To: geonode-users <[hidden email]>,  geonode-devel
<[hidden email]>
Subject: [GeoNode-devel] GeoNode-Project@2.8 Python version
Message-ID:
<[hidden email]>
Content-Type: text/plain; charset="utf-8"

Dear users and developers,

I have been trying to install GeoNode-Project@2.8 via Docker on an
Ubuntu@18.04LTS server, but while building the images, the installation is
facing the following error:

Collecting pygdal==2.1.2.3
Downloading
https://files.pythonhosted.org/packages/37/4f/64823b0000ce4364bbddd4c46a21f80326910bae3763f9e514ececbd37d6/pygdal-2.1.2.3.tar.gz
(407kB)
  ERROR: Complete output from command python setup.py egg_info:
  ERROR: Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "/tmp/pip-install-L5AGEr/pygdal/setup.py", line 173, in <module>
      cmdclass=dict(build_ext=gdal_ext),
    File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py",
line 128, in setup
      _install_setup_requires(attrs)
    File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py",
line 123, in _install_setup_requires
      dist.fetch_build_eggs(dist.setup_requires)
    File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py",
line 504, in fetch_build_eggs
      replace_conflicting=True,
    File
"/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
774, in resolve
      replace_conflicting=replace_conflicting
    File
"/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
1057, in best_match
      return self.obtain(req, installer)
    File
"/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line
1069, in obtain
      return installer(requirement)
    File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py",
line 571, in fetch_build_egg
      return cmd.easy_install(req)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 673, in easy_install
      return self.install_item(spec, dist.location, tmpdir, deps)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 699, in install_item
      dists = self.install_eggs(spec, download, tmpdir)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 884, in install_eggs
      return self.build_and_install(setup_script, setup_base)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 1152, in build_and_install
      self.run_setup(setup_script, setup_base, args)
    File
"/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py",
line 1138, in run_setup
      run_setup(setup_script, args)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 253, in run_setup
      raise
    File "/usr/local/lib/python2.7/contextlib.py", line 35, in __exit__
      self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 195, in setup_context
      yield
    File "/usr/local/lib/python2.7/contextlib.py", line 35, in __exit__
      self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 166, in save_modules
      saved_exc.resume()
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 141, in resume
      six.reraise(type, exc, self._tb)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 154, in save_modules
      yield saved
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 195, in setup_context
      yield
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 250, in run_setup
      _execfile(setup_script, ns)
    File "/usr/local/lib/python2.7/site-packages/setuptools/sandbox.py",
line 45, in _execfile
      exec(code, globals, locals)
    File "/tmp/easy_install-1_bgIy/numpy-1.17.0rc1/setup.py", line 31, in
<module>

  RuntimeError: Python version >= 3.5 required.
  ----------------------------------------
ERROR: Command "python setup.py egg_info" failed with error code 1 in
/tmp/pip-install-L5AGEr/pygdal/
ERROR: Service 'celery' failed to build: The command '/bin/sh -c
GDAL_VERSION=`gdal-config --version`     && PYGDAL_VERSION="$(pip install
pygdal==$GDAL_VERSION 2>&1 | grep -oP '(?<=: )(.*)(?=\))' | grep -oh
$GDAL_VERSION\.[0-9])"     && pip install pygdal==$PYGDAL_VERSION' returned
a non-zero code: 1
(my_geonode) geo@1520GIS:/home/geonode/my_geonode$ python -V
Python 2.7.15+

Any help will be very appreciated.

Kind regards

Julierme
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20190715/4e030870/attachment-0001.html>

-----


_______________________________________________
geonode-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geonode-users