Re: [GRASS-user] wxgrass: porblem with combo

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [GRASS-user] wxgrass: porblem with combo

Michael Barton
Jarek,


On 6/4/07 1:03 AM, "Jarosław Jasiewicz" <[hidden email]> wrote:

> Thanks Michel
>
> I tested it more, and I confirm: having 2.6 cousing problmes with
> wx.combo, but this not allow install aplications depending on wxPython2.6
> The only solution is to install 2.6 on very fresh system, next 2.8 next
> other aplication. But At least two aplications on Ubuntu installed from
> repos (for examle wxGlade and pgAdmin3 if installed after) made wx2.6
> default
>
> I don't know if idea of depending wxGRASS on at least 2.8.1 is good idea
> (I red this in last Jachym article on his page). Generally most ubuntu
> application are dependend on wx2.6.

As Hamish says, 2.8 is largely a bug fix for 2.6. However, there are a few
new controls (or slightly modified versions of existing ones).

The reason for depending on 2.8.x is that once we go to serious production
testing and use, the version of wxPython may well get defacto frozen because
of the need to maintain backward compatibility for GRASS within a version
number. So we're developing in the most current version so that we don't
start out a couple versions behind when we go to widespread use.

> I don't know if following example is
> good but may give you addational asspumtion:
> Probably every grass user know pgadmin3 (postgreSQL manager) for now in
> ubuntu repositories is version 1.4.3 depending on wx2.6. I asked
> developers why not 1.6.1 wchich is more advanced. It is because, 1.6.1
> is dependend on wx2.8, ad as long as they will not be sure if wx2.8 is
> fully compatibile with other aplications they will not add 1.6.1

AFAICT, 2.8 is fully backward compatible with 2.6. I ran into the version
problem with wxGlade, but found out that it is necessary to change only a
line or two to run with 2.8. Even easier, you can simply download the
wxGlade source code and use it. Because it's all in wxPython, there is
nothing to compile. Just build it and run from "source".

I don't know about pgadmin3. I thought that was in PHP rather than wxPython.
If in wxPython, however, you probably only need to find the place where it
check (and requires) 2.6 and change it to 2.8. Since wxPython files are all
text files, this should be pretty easy.

Hope this is helpful

Michael


__________________________________________
Michael Barton, Professor of Anthropology
School of Human Evolution & Social Change
Center for Social Dynamics & Complexity
Arizona State University

phone: 480-965-6213
fax: 480-965-7671
www: http://www.public.asu.edu/~cmbarton



_______________________________________________
grassgui mailing list
[hidden email]
http://grass.itc.it/mailman/listinfo/grassgui
Reply | Threaded
Open this post in threaded view
|

Re: [GRASS-user] wxgrass: porblem with combo

Jarek Jasiewicz
Michael Barton wrote:

> Jarek,
>
>
> On 6/4/07 1:03 AM, "Jarosław Jasiewicz" <[hidden email]> wrote:
>
>  
>> Thanks Michel
>>
>> I tested it more, and I confirm: having 2.6 cousing problmes with
>> wx.combo, but this not allow install aplications depending on wxPython2.6
>> The only solution is to install 2.6 on very fresh system, next 2.8 next
>> other aplication. But At least two aplications on Ubuntu installed from
>> repos (for examle wxGlade and pgAdmin3 if installed after) made wx2.6
>> default
>>
>> I don't know if idea of depending wxGRASS on at least 2.8.1 is good idea
>> (I red this in last Jachym article on his page). Generally most ubuntu
>> application are dependend on wx2.6.
>>    
>
> As Hamish says, 2.8 is largely a bug fix for 2.6. However, there are a few
> new controls (or slightly modified versions of existing ones).
>
> The reason for depending on 2.8.x is that once we go to serious production
> testing and use, the version of wxPython may well get defacto frozen because
> of the need to maintain backward compatibility for GRASS within a version
> number. So we're developing in the most current version so that we don't
> start out a couple versions behind when we go to widespread use.
>
>  
>> I don't know if following example is
>> good but may give you addational asspumtion:
>> Probably every grass user know pgadmin3 (postgreSQL manager) for now in
>> ubuntu repositories is version 1.4.3 depending on wx2.6. I asked
>> developers why not 1.6.1 wchich is more advanced. It is because, 1.6.1
>> is dependend on wx2.8, ad as long as they will not be sure if wx2.8 is
>> fully compatibile with other aplications they will not add 1.6.1
>>    
>
> AFAICT, 2.8 is fully backward compatible with 2.6. I ran into the version
> problem with wxGlade, but found out that it is necessary to change only a
> line or two to run with 2.8. Even easier, you can simply download the
> wxGlade source code and use it. Because it's all in wxPython, there is
> nothing to compile. Just build it and run from "source".
>
> I don't know about pgadmin3. I thought that was in PHP rather than wxPython.
> If in wxPython, however, you probably only need to find the place where it
> check (and requires) 2.6 and change it to 2.8. Since wxPython files are all
> text files, this should be pretty easy.
>
> Hope this is helpful
>
> Michael
>
>
> __________________________________________
> Michael Barton, Professor of Anthropology
> School of Human Evolution & Social Change
> Center for Social Dynamics & Complexity
> Arizona State University
>
> phone: 480-965-6213
> fax: 480-965-7671
> www: http://www.public.asu.edu/~cmbarton
>
>  
Thanks for message
I use wxglade 0.5 "from source" it run fine without any modification. I
give it only as a example ....
pgadmin3 is not php (this is phppgadmin) it is binary application just
dependend on wx2.6 newest pgadmin3 is dependend on  wx2.8 nad there are
huge problem with its compilation on ubuntu just due to wx2.8 (this is
information from pgadmin3, developers I don't ask anybody here how to
solve this :)) )

see my next to message on wx2.6 and 2.8 conflict in dependences on
ubuntu (and probably other linux distros) For now there is no package
dependend on wx2.8 - I only point that depending grass on wx2.8 may
conflict with other ubuntu (and other distro) dependencies in next to 12
month - it probably won't be a problem if realase is plannded later
greetings
Jarek

_______________________________________________
grassgui mailing list
[hidden email]
http://grass.itc.it/mailman/listinfo/grassgui