RHEL 6 PostGIS 9.4 cannot install

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

RHEL 6 PostGIS 9.4 cannot install

Andrew Davis

Hello,

I have an instance of RHEL 6 with postGRESQL  9.4.8 running.  I am able to login and create databases (command line and through pgAdmin3). 

Now i am trying to install postGIS..

My results for 'yum list postgis*' show available rpms..

postgis2_94.x86_64
postgis2_94-client.x86_64
postgis2_94-debuginfo.x86_64
postgis2_94-devel.x86_64
postgis2_94-docs.x86_64
postgis2_94-utils.x86_64

When I run the command "yum install postgis2_94' I get a lot of errors for missing dependencies.

Package: postgis2_94-2.1.8-1.rhel6.x86_64 (pgdg94) Requires: hdf5...

There are multiple others as well..

I am more than likely missing something simple, but unable to figure this out...

Have I missed something?.. Any advice is welcome..

Andy.


_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: RHEL 6 PostGIS 9.4 cannot install

Devrim GÜNDÜZ-2
Hi,

Please enable EPEL repo. All deps are there.

Regards, Devrin

On July 27, 2016 10:04:55 PM GMT+03:00, Andrew Davis <[hidden email]> wrote:

Hello,

I have an instance of RHEL 6 with postGRESQL  9.4.8 running.  I am able to login and create databases (command line and through pgAdmin3). 

Now i am trying to install postGIS..

My results for 'yum list postgis*' show available rpms..

postgis2_94.x86_64
postgis2_94-client.x86_64
postgis2_94-debuginfo.x86_64
postgis2_94-devel.x86_64
postgis2_94-docs.x86_64
postgis2_94-utils.x86_64

When I run the command "yum install postgis2_94' I get a lot of errors for missing dependencies.

Package: postgis2_94-2.1.8-1.rhel6.x86_64 (pgdg94) Requires: hdf5...

There are multiple others as well..

I am more than likely missing something simple, but unable to figure this out...

Have I missed something?.. Any advice is welcome..

Andy.



postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.
_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: RHEL 6 PostGIS 9.4 cannot install

Regina Obe
In reply to this post by Andrew Davis

Sounds like you are missing EPEL repo.

You can try:

 

yum -y install epel-release

 

(not sure if that works for RHEL 6 or if you have to get the report)

 

Hopefully these directions I wrote up a while ago will help.  I tested on CentOS but should be much the same for RHEL as well.

 

http://www.postgresonline.com/journal/archives/362-An-almost-idiots-guide-to-install-PostgreSQL-9.5,-PostGIS-2.2-and-pgRouting-2.1.0-with-Yum.html

 

(Also since you are running 9.4 instead of 9.5, you have to just revise your yum to account for that, most of the rest should be the same though)

 

Hope that helps,

Regina

http://www.postgis.us

http://postgis.net

 

 

 

 

From: postgis-users [mailto:[hidden email]] On Behalf Of Andrew Davis
Sent: Wednesday, July 27, 2016 3:05 PM
To: PostGIS Users Discussion <[hidden email]>
Subject: [postgis-users] RHEL 6 PostGIS 9.4 cannot install

 

Hello,

I have an instance of RHEL 6 with postGRESQL  9.4.8 running.  I am able to login and create databases (command line and through pgAdmin3). 

Now i am trying to install postGIS..

My results for 'yum list postgis*' show available rpms..

postgis2_94.x86_64
postgis2_94-client.x86_64
postgis2_94-debuginfo.x86_64
postgis2_94-devel.x86_64
postgis2_94-docs.x86_64
postgis2_94-utils.x86_64

When I run the command "yum install postgis2_94' I get a lot of errors for missing dependencies.

Package: postgis2_94-2.1.8-1.rhel6.x86_64 (pgdg94) Requires: hdf5...

There are multiple others as well..

I am more than likely missing something simple, but unable to figure this out...

Have I missed something?.. Any advice is welcome..

Andy.


_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: RHEL 6 PostGIS 9.4 cannot install

Andrew Davis
Good Morning, thanks for the input.

I was able to get the epel-release to install (Thanks again on that part..)

my 'yum install postgis2_94'  returns an error of 

"Cannot retrieve repository metadata (repmond.xml) for prepository: epel.  Please verify its path and try again


my epel.repo

~~~
[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 6 - $basearch - Debug
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 6 - $basearch - Source
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1
~~~



Andy...

On Wed, Jul 27, 2016 at 3:19 PM, Regina Obe <[hidden email]> wrote:

Sounds like you are missing EPEL repo.

You can try:

 

yum -y install epel-release

 

(not sure if that works for RHEL 6 or if you have to get the report)

 

Hopefully these directions I wrote up a while ago will help.  I tested on CentOS but should be much the same for RHEL as well.

 

http://www.postgresonline.com/journal/archives/362-An-almost-idiots-guide-to-install-PostgreSQL-9.5,-PostGIS-2.2-and-pgRouting-2.1.0-with-Yum.html

 

(Also since you are running 9.4 instead of 9.5, you have to just revise your yum to account for that, most of the rest should be the same though)

 

Hope that helps,

Regina

http://www.postgis.us

http://postgis.net

 

 

 

 

From: postgis-users [mailto:[hidden email]] On Behalf Of Andrew Davis
Sent: Wednesday, July 27, 2016 3:05 PM
To: PostGIS Users Discussion <[hidden email]>
Subject: [postgis-users] RHEL 6 PostGIS 9.4 cannot install

 

Hello,

I have an instance of RHEL 6 with postGRESQL  9.4.8 running.  I am able to login and create databases (command line and through pgAdmin3). 

Now i am trying to install postGIS..

My results for 'yum list postgis*' show available rpms..

postgis2_94.x86_64
postgis2_94-client.x86_64
postgis2_94-debuginfo.x86_64
postgis2_94-devel.x86_64
postgis2_94-docs.x86_64
postgis2_94-utils.x86_64

When I run the command "yum install postgis2_94' I get a lot of errors for missing dependencies.

Package: postgis2_94-2.1.8-1.rhel6.x86_64 (pgdg94) Requires: hdf5...

There are multiple others as well..

I am more than likely missing something simple, but unable to figure this out...

Have I missed something?.. Any advice is welcome..

Andy.


_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users


_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: RHEL 6 PostGIS 9.4 cannot install

Andrew Davis
In reply to this post by Andrew Davis
Ok... I think I got it..

I kept seeing users changing the 'https://' links to 'http://  
Well I changed all of the internal 'https://' over to 'http://' and now it appears to be working.

Andy.

On Wed, Jul 27, 2016 at 2:04 PM, Andrew Davis <[hidden email]> wrote:

Hello,

I have an instance of RHEL 6 with postGRESQL  9.4.8 running.  I am able to login and create databases (command line and through pgAdmin3). 

Now i am trying to install postGIS..

My results for 'yum list postgis*' show available rpms..

postgis2_94.x86_64
postgis2_94-client.x86_64
postgis2_94-debuginfo.x86_64
postgis2_94-devel.x86_64
postgis2_94-docs.x86_64
postgis2_94-utils.x86_64

When I run the command "yum install postgis2_94' I get a lot of errors for missing dependencies.

Package: postgis2_94-2.1.8-1.rhel6.x86_64 (pgdg94) Requires: hdf5...

There are multiple others as well..

I am more than likely missing something simple, but unable to figure this out...

Have I missed something?.. Any advice is welcome..

Andy.



_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users