RE: Installation PRoblem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

RE: Installation PRoblem

Leonardo Parra-2

Hi Hartesh,

The DOS command thing worked.  My OS is Windows XP Pro, I’m using IIS 5.1, I also have a PHP 5.1 installed on the system.

Thank you so much for your help.  Now I can start using the software.

Cheers,

 

Leonardo Parra, B. Eng. (Civil Engineer), P. Grad (GIS)

GIS Especialist

14 Wilholme Drive UNit 23

St. Catharines, Ontario, Canada

L2W 1B5

email:  [hidden email]

phone: (905) 685 0676

cell:     (905) 931 5246 


From: Hartesh Chhabra [mailto:[hidden email]]
Sent: March 14, 2006 1:33 AM
To: [hidden email]
Subject: RE: [mapguide-users] Installation PRoblem

 

Hi Leonardo,

MapGuide Server installer adds this service. I would suggest uninstalling server and then installing it again. If you still don’t see entry for “MapGuide Server” service, please send the information like OS, machine type and in the meantime start server from command line-

1. Open DOS window

2. Go to C:\Program Files\MapGuideOpenSource\Server\Bin (assuming default install location)

3. Type mgeserver.exe /interactive.

You should see message like below. If server doesn’t start up, send the error message.


From: Leonardo Parra [mailto:[hidden email]]
Sent: Monday, March 13, 2006 10:09 PM
To: [hidden email]
Subject: RE: [mapguide-users] Installation PRoblem

 

Hi Hartesh,

You’re in the right direction.  I’ve checked for the service but I couldn’t find it.  How can I add it?

Cheers,

 

Leonardo Parra, B. Eng. (Civil Engineer), P. Grad (GIS)

GIS Especialist

14 Wilholme Drive UNit 23

St. Catharines, Ontario, Canada

L2W 1B5

email:  [hidden email]

phone: (905) 685 0676

cell:     (905) 931 5246 


From: Hartesh Chhabra [mailto:[hidden email]]
Sent: March 14, 2006 12:06 AM
To: [hidden email]
Subject: RE: [mapguide-users] Installation PRoblem

 

HI Leonardo,

Could you check that “MapGuide Server” service is running? You probably wouldn’t need following steps but just in case-

  1. Open the Windows "Control Panel"

  2. Select the "Administrative Tools" entry

  3. Launch the "Services" panel

  4. Status for “MapGuide Server” should be “Started”. If not, right click on the "MapGuide Server" item and select "Start"

Hartesh


From: Leonardo Parra [mailto:[hidden email]]
Sent: Monday, March 13, 2006 8:45 PM
To: [hidden email]
Subject: [mapguide-users] Installation PRoblem

 

Hi Guys,

I have installed mapguide without any problem in one machine, when I try to install it in another machine and I run the first test, I’m getting this error:

Failed to retrieve message for MgConnectionFailedException.

Failed to retrieve message for MgConnectionFailedException. Exception occured in method MgServerConnection.Open at line 94 in file c:\build_tux_area\mgdev\common\service\services\ServerConnection.cpp

I’m really new to this, could somebody give me a hand?  I’d really appreciate it,

Thanks

 

Leonardo Parra, B. Eng. (Civil Engineer), P. Grad (GIS)

GIS Especialist

14 Wilholme Drive UNit 23

St. Catharines, Ontario, Canada

L2W 1B5

email:  [hidden email]

phone: (905) 685 0676

cell:     (905) 931 5246  

 


--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.375 / Virus Database: 268.2.1/279 - Release Date: 10/03/2006


--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.375 / Virus Database: 268.2.1/279 - Release Date: 10/03/2006


--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.375 / Virus Database: 268.2.1/279 - Release Date: 10/03/2006


--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.375 / Virus Database: 268.2.1/279 - Release Date: 10/03/2006


--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.375 / Virus Database: 268.2.1/279 - Release Date: 10/03/2006

Reply | Threaded
Open this post in threaded view
|

Installation problem

_Jon_
Installation problem

Hello,

I just uninstalled the preview version (0.93?) and installed RC1.  I am running IIS6 in Windows Server 2003.  I installed the MapGuide web server and the .NET web extensions using the auto-configure option.  However, when trying the test http://myserver/mapguide/mapagent/mapagent.fcgi?OPERATION=ENUMERATRESOURCES&VERSION=1.0.0&LOCALE=eng&RESOURCEID=Library://&TYPE=&DEPTH=-1 I get the following error message:

The requested operation is invalid.
The requested operation is invalid. Exception occurred in method MgHttpRequest::CreateRequestResponseHandler at line 265 in file c:\build_tux_area\mgdev\web\src\httphandler\HttpRequest.cpp

I went through the configuration, and made a few manual changes that were not taken care of by the "auto-configuration":

I changed the application name of the "mapguide" virtual directory to "mapguide".  Previously it was set to "mapagent".
I set the application names of the mapvierwerajax, mapviewerdwf and mapviewernet folders to mapviewerajax, mapviewerdwf and mapviewernet respectively.  These were originally blank before I modified them manually.

I manually set the ASP.NET version to 2.0.50727 for the mapguide virtual directory.
I manually added the correct path to the MapAgent.exe to the MapAgent web service extension list of required files.  This was still pointing to the MapServer Enterprise location from the previous version.


Anybody know what might be causing this error or what else I should check to make sure everything is installed & configured properly?  Thank you for any assistance you can offer.

 

Regards,

Jon Rizzo
Langan Engineering and Environmental Services, Inc.