Qt4 asked when compiling current master

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Qt4 asked when compiling current master

Pierre_Loicq
Hello,

I am trying to compile current master on ubuntu 16.04. I have this error:

[ 99%] Generating ../output/i18n/qgis_bg.qm
lrelease: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/lrelease': No such file or directory
lrelease: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/lrelease': No such file or directory
i18n/CMakeFiles/translations.dir/build.make:97 : la recette pour la cible « output/i18n/qgis_ar.qm » a échouée
make[2]: *** [output/i18n/qgis_ar.qm] Erreur 1
make[2]: *** Attente des tâches non terminées....
i18n/CMakeFiles/translations.dir/build.make:101 : la recette pour la cible « output/i18n/qgis_bg.qm » a échouée
make[2]: *** [output/i18n/qgis_bg.qm] Erreur 1
CMakeFiles/Makefile2:3686 : la recette pour la cible « i18n/CMakeFiles/translations.dir/all » a échouée
make[1]: *** [i18n/CMakeFiles/translations.dir/all] Erreur 2
make[1]: *** Attente des tâches non terminées....
[ 99%] Built target zzz-db_manager-5-depend
Makefile:160 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2

I don't know why Qt4 is asked here. ccmake configuration only talks about Qt5

Thank you
Pierre
Reply | Threaded
Open this post in threaded view
|

Re: Qt4 asked when compiling current master

Pierre_Loicq
Hello,

I would like to relaunch my question below.
More info: I installed packages like mentionned in the install doc :

apt-get install bison ca-certificates cmake dh-python doxygen flex gdal-bin libgdal-dev python3-gdal etc

But then it told me I needed gdal 2.0, so I remove all above mentionned gdal packages and installed again after adding https://launchpad.net/~ubuntugis/+archive/ubuntugis-unstable to my repositories.

Thank you
Pierre
Reply | Threaded
Open this post in threaded view
|

Re: [resolved] Qt4 asked when compiling current master

Pierre_Loicq
In reply to this post by Pierre_Loicq
Pierre_Loicq wrote
Hello,

I am trying to compile current master on ubuntu 16.04. I have this error:

[ 99%] Generating ../output/i18n/qgis_bg.qm
lrelease: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/lrelease': No such file or directory
lrelease: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/lrelease': No such file or directory
i18n/CMakeFiles/translations.dir/build.make:97 : la recette pour la cible « output/i18n/qgis_ar.qm » a échouée
make[2]: *** [output/i18n/qgis_ar.qm] Erreur 1
make[2]: *** Attente des tâches non terminées....
i18n/CMakeFiles/translations.dir/build.make:101 : la recette pour la cible « output/i18n/qgis_bg.qm » a échouée
make[2]: *** [output/i18n/qgis_bg.qm] Erreur 1
CMakeFiles/Makefile2:3686 : la recette pour la cible « i18n/CMakeFiles/translations.dir/all » a échouée
make[1]: *** [i18n/CMakeFiles/translations.dir/all] Erreur 2
make[1]: *** Attente des tâches non terminées....
[ 99%] Built target zzz-db_manager-5-depend
Makefile:160 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2

I don't know why Qt4 is asked here. ccmake configuration only talks about Qt5

Thank you
Pierre
Resolved ! I used apt-file to know which package I had to install: qt4-linguist-tools

Reply | Threaded
Open this post in threaded view
|

Re: [Qgis-developer] [resolved] Qt4 asked when compiling current master

Raymond Nijssen
Thanks Pierre, I just ran into the same.

Should qt4-linguist-tools be added to the dependency list?

https://htmlpreview.github.io/?https://github.com/qgis/QGIS/blob/master/doc/INSTALL.html#toc6

Raymond



On 21-03-17 21:48, Pierre_Loicq wrote:

> Pierre_Loicq wrote
>> Hello,
>>
>> I am trying to compile current master on ubuntu 16.04. I have this error:
>>
>> [ 99%] Generating ../output/i18n/qgis_bg.qm
>> lrelease: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/lrelease': No
>> such file or directory
>> lrelease: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/lrelease': No
>> such file or directory
>> i18n/CMakeFiles/translations.dir/build.make:97 : la recette pour la cible
>> « output/i18n/qgis_ar.qm » a échouée
>> make[2]: *** [output/i18n/qgis_ar.qm] Erreur 1
>> make[2]: *** Attente des tâches non terminées....
>> i18n/CMakeFiles/translations.dir/build.make:101 : la recette pour la cible
>> « output/i18n/qgis_bg.qm » a échouée
>> make[2]: *** [output/i18n/qgis_bg.qm] Erreur 1
>> CMakeFiles/Makefile2:3686 : la recette pour la cible
>> « i18n/CMakeFiles/translations.dir/all » a échouée
>> make[1]: *** [i18n/CMakeFiles/translations.dir/all] Erreur 2
>> make[1]: *** Attente des tâches non terminées....
>> [ 99%] Built target zzz-db_manager-5-depend
>> Makefile:160 : la recette pour la cible « all » a échouée
>> make: *** [all] Erreur 2
>>
>> I don't know why Qt4 is asked here. ccmake configuration only talks about
>> Qt5
>>
>> Thank you
>> Pierre
>
> Resolved ! I used apt-file to know which package I had to install:
> qt4-linguist-tools
>
>
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/Qt4-asked-when-compiling-current-master-tp5310808p5313502.html
> Sent from the QGIS - Developer mailing list archive at Nabble.com.
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
> Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
>

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer