Qgis-server in single-symbol renderer don't use the metadata title.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Qgis-server in single-symbol renderer don't use the metadata title.

Andrea Peri
Hi,

In qgis-server (i tested with last dev),
when use a category renderer,
and request a GetLegendGraphics.

The return use the LayerName as title of the layer in the Legend.
Like this sample show:

http://tinyurl.com/kwvoo6h

Or this other:

http://tinyurl.com/qaravsm

AFAIK should be better to have as Legend Title the title insert into
the Metadata Title (when filled).

Infact the layername is often a non-understandable code. Instead the
Metadata Title is a Human Understandable value.

The choice to put the layername istead of the Metadata title (when
available) is a bug or a wanted feature. ?

Thx.

--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Qgis-server in single-symbol renderer don't use the metadata title.

René-Luc Dhont
Hi Andrea,

It's a regression since the merge of the new Layer Tree.

Can you open an issue ?

Thanks,

René-Luc

Le 13/10/2014 20:49, Andrea Peri a écrit :

> Hi,
>
> In qgis-server (i tested with last dev),
> when use a category renderer,
> and request a GetLegendGraphics.
>
> The return use the LayerName as title of the layer in the Legend.
> Like this sample show:
>
> http://tinyurl.com/kwvoo6h
>
> Or this other:
>
> http://tinyurl.com/qaravsm
>
> AFAIK should be better to have as Legend Title the title insert into
> the Metadata Title (when filled).
>
> Infact the layername is often a non-understandable code. Instead the
> Metadata Title is a Human Understandable value.
>
> The choice to put the layername istead of the Metadata title (when
> available) is a bug or a wanted feature. ?
>
> Thx.
>

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Qgis-server in single-symbol renderer don't use the metadata title.

Andrea Peri
I open the ticket.
http://hub.qgis.org/issues/11406

Meanwhile I see that contrarly to the first email, the category also
wrong to put the title in the legend response.

Thx,

Andrea.


2014-10-14 8:57 GMT+02:00 René-Luc Dhont <[hidden email]>:

> Hi Andrea,
>
> It's a regression since the merge of the new Layer Tree.
>
> Can you open an issue ?
>
> Thanks,
>
> René-Luc
>
> Le 13/10/2014 20:49, Andrea Peri a écrit :
>>
>> Hi,
>>
>> In qgis-server (i tested with last dev),
>> when use a category renderer,
>> and request a GetLegendGraphics.
>>
>> The return use the LayerName as title of the layer in the Legend.
>> Like this sample show:
>>
>> http://tinyurl.com/kwvoo6h
>>
>> Or this other:
>>
>> http://tinyurl.com/qaravsm
>>
>> AFAIK should be better to have as Legend Title the title insert into
>> the Metadata Title (when filled).
>>
>> Infact the layername is often a non-understandable code. Instead the
>> Metadata Title is a Human Understandable value.
>>
>> The choice to put the layername istead of the Metadata title (when
>> available) is a bug or a wanted feature. ?
>>
>> Thx.
>>
>
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-developer



--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer