Qgis server e Lizmap

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Qgis server e Lizmap

nicoali
Ho provato a installare lizmap su un VPS con ubuntu 16.04 X64 e sembra sia
andata a buon fine, visualizzo il pannello admin etc.. ma non riesco a
visualizzare le mappe in quanto i servizi WMS e WFS di qgis server non
sembrano funzionare.

http://89.47.161.54/cgi-bin/qgis_mapserv.fcgi?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities

ricevo un Internal Server Error!

con *find / -name 'qgis_mapserv.fcgi' *  
ricevo    /usr/lib/cgi-bin/qgis_mapserv.fcgi

"lanciando"

/usr/lib/cgi-bin/qgis_mapserv.fcgi     Warning 1: Unable to find driver ECW
to unload from GDAL_SKIP environment variable.
Warning 1: Unable to find driver ECW to unload from GDAL_SKIP environment
variable.
Warning 1: Unable to find driver JP2ECW to unload from GDAL_SKIP environment
variable.
Warning 1: Unable to find driver ECW to unload from GDAL_SKIP environment
variable.
Warning 1: Unable to find driver JP2ECW to unload from GDAL_SKIP environment
variable.
Content-Type: text/xml; charset=utf-8
Content-Length: 206

<ServiceExceptionReport version="1.3.0" xmlns="http://www.opengis.net/ogc">
 <ServiceException code="Service configuration error">Service unknown or
unsupported</ServiceException>
</ServiceExceptionReport>
fin qui sembra tutto regolare!

ho creato il mio  /etc/apache2/sites-available/qgis.nico.conf
cosi:
https://pastebin.com/uNvGhpRe

e lanciato
a2enmod fcgid
a2ensite qgis.nico
service apache2 restart

il log error:
https://pastebin.com/8QnNfnp0
e qgis.nico.error log
https://pastebin.com/D2K1eiMN






--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Italian-User-f5250612.html
_______________________________________________
QGIS-it-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-it-user
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server e Lizmap

pcav
Hai abilitato cgi?

On 8 October 2019 17:42:07 EEST, nicoali <[hidden email]> wrote:
Ho provato a installare lizmap su un VPS con ubuntu 16.04 X64 e sembra sia
andata a buon fine, visualizzo il pannello admin etc.. ma non riesco a
visualizzare le mappe in quanto i servizi WMS e WFS di qgis server non
sembrano funzionare.

http://89.47.161.54/cgi-bin/qgis_mapserv.fcgi?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities

ricevo un Internal Server Error!

con *find / -name 'qgis_mapserv.fcgi' *
ricevo /usr/lib/cgi-bin/qgis_mapserv.fcgi

"lanciando"

/usr/lib/cgi-bin/qgis_mapserv.fcgi Warning 1: Unable to find driver ECW
to unload from GDAL_SKIP environment variable.
Warning 1: Unable to find driver ECW to unload from GDAL_SKIP environment
variable.
Warning 1: Unable to find driver JP2ECW to unload from GDAL_SKIP environment
variable.
Warning 1: Unable to find driver ECW to unload from GDAL_SKIP environment
variable.
Warning 1: Unable to find driver JP2ECW to unload from GDAL_SKIP environment
variable.
Content-Type: text/xml; charset=utf-8
Content-Length: 206

<ServiceExceptionReport version="1.3.0" xmlns="http://www.opengis.net/ogc">
<ServiceException code="Service configuration error">Service unknown or
unsupported</ServiceException>
</ServiceExceptionReport>
fin qui sembra tutto regolare!

ho creato il mio /etc/apache2/sites-available/qgis.nico.conf
cosi:
https://pastebin.com/uNvGhpRe

e lanciato
a2enmod fcgid
a2ensite qgis.nico
service apache2 restart

il log error:
https://pastebin.com/8QnNfnp0
e qgis.nico.error log
https://pastebin.com/D2K1eiMN






--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Italian-User-f5250612.html
QGIS-it-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-it-user

--
Sorry for being short
_______________________________________________
QGIS-it-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-it-user
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server e Lizmap

nicoali
questo รจ il mio
/etc/apache2/conf-available/php.conf

https://pastebin.com/H6Uvsvr2

e questo
/etc/apache2/conf-available/serve-cgi-bin.conf
https://pastebin.com/jN5fQAiz

php7.0-cgi-bin
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>
Action application/x-httpd-php /cgi-bin/php7.0

non so se manca altro



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Italian-User-f5250612.html
_______________________________________________
QGIS-it-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-it-user
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server e Lizmap

nicoali
In reply to this post by pcav
Non so per quale motivo lanciavo sudo a2ensite 001-qgis e non quello che
avevo editato: 000-default

qualche passo avanti lo ho fatto..

ora funziona
http://89.47.161.54/cgi-bin/qgis_mapserv.fcgi?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities
quindi credo che il problema con qgis server sia risolto...

per quanto riguarda lizmap invece ci devo ancora "lavorare"
vedo la mappa.. purtroppo senza i punti..
http://89.47.161.54/lm/index.php/view/map/?repository=nicoali&project=alberi





--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Italian-User-f5250612.html
_______________________________________________
QGIS-it-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-it-user
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server e Lizmap

pcav
I dati sono raggiungibili sul server, con lo stesso path?

On 9 October 2019 19:48:19 EEST, nicoali <[hidden email]> wrote:
Non so per quale motivo lanciavo sudo a2ensite 001-qgis e non quello che
avevo editato: 000-default

qualche passo avanti lo ho fatto..

ora funziona
http://89.47.161.54/cgi-bin/qgis_mapserv.fcgi?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities
quindi credo che il problema con qgis server sia risolto...

per quanto riguarda lizmap invece ci devo ancora "lavorare"
vedo la mappa.. purtroppo senza i punti..
http://89.47.161.54/lm/index.php/view/map/?repository=nicoali&project=alberi





--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Italian-User-f5250612.html
QGIS-it-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-it-user

--
Sorry for being short
_______________________________________________
QGIS-it-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-it-user