[Qgis-community-team] QGIS Loads Black Screen For PostGIS Out-Db Raster Data

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Qgis-community-team] QGIS Loads Black Screen For PostGIS Out-Db Raster Data

Osahon Oduware
Hi All,

I have an out-db raster on PostGIS which I tried to load in QGIS (v 2.14.12-Essen) utilizing the DB Manager to establish a connection. I could view the raster table, but when I try to "Add to canvas" it displays a black (blank) image instead of the raster image. 

I would be glad if someone could help me to resolve this.

_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qgis-community-team] QGIS Loads Black Screen For PostGIS Out-Db Raster Data

Paolo Cavallini
Il 18/04/2017 17:24, Osahon Oduware ha scritto:
> Hi All,
>
> I have an out-db raster on PostGIS which I tried to load in QGIS (v
> 2.14.12-Essen) utilizing the DB Manager to establish a connection. I
> could view the raster table, but when I try to "Add to canvas" it
> displays a black (blank) image instead of the raster image.
>
> I would be glad if someone could help me to resolve this.

Hi Osahon,
have you checked the values of the cells?
All the best.
--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
https://www.google.com/trends/explore?date=all&geo=IT&q=qgis,arcgis
_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qgis-community-team] QGIS Loads Black Screen For PostGIS Out-Db Raster Data

Yves Jacolin
In reply to this post by Osahon Oduware
Hello,

You can adapt the style of the raster  (layer properties, style tab and play with the min-max values and other settings)

As Paolo said, the cell content have a value and you can adapt the color for each cells.

Y.



Envoyé depuis mon appareil Samsung


-------- Message d'origine --------
De : Paolo Cavallini <[hidden email]>
Date : 18/04/2017 17:26 (GMT+01:00)
À : [hidden email]
Objet : Re: [Qgis-community-team] QGIS Loads Black Screen For PostGIS Out-Db Raster Data

Il 18/04/2017 17:24, Osahon Oduware ha scritto:
> Hi All,
>
> I have an out-db raster on PostGIS which I tried to load in QGIS (v
> 2.14.12-Essen) utilizing the DB Manager to establish a connection. I
> could view the raster table, but when I try to "Add to canvas" it
> displays a black (blank) image instead of the raster image.
>
> I would be glad if someone could help me to resolve this.

Hi Osahon,
have you checked the values of the cells?
All the best.
--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
https://www.google.com/trends/explore?date=all&geo=IT&q=qgis,arcgis
_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team
_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qgis-community-team] QGIS Loads Black Screen For PostGIS Out-Db Raster Data

Osahon Oduware
In reply to this post by Paolo Cavallini
Hi Paolo,


Yes, I have used the ST_Value function to retrieve the value at a point and it returned a value.

On Tue, Apr 18, 2017 at 4:26 PM, Paolo Cavallini <[hidden email]> wrote:
Il 18/04/2017 17:24, Osahon Oduware ha scritto:
> Hi All,
>
> I have an out-db raster on PostGIS which I tried to load in QGIS (v
> 2.14.12-Essen) utilizing the DB Manager to establish a connection. I
> could view the raster table, but when I try to "Add to canvas" it
> displays a black (blank) image instead of the raster image.
>
> I would be glad if someone could help me to resolve this.

Hi Osahon,
have you checked the values of the cells?
All the best.
--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
https://www.google.com/trends/explore?date=all&geo=IT&q=qgis,arcgis
_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team


_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qgis-community-team] QGIS Loads Black Screen For PostGIS Out-Db Raster Data

Osahon Oduware
In reply to this post by Yves Jacolin
Hi,

I have tried altering the properties of the raster with little or no difference. This raster file exist on the filesystem and when it is loaded directly into QGIS it displays the image (aerial photo), however, when I link to the same file as an OUT-DB raster in PostGIS and try to load the PostGIS OUT-DB raster in QGIS (using the DB Manager tool) it displays a black image instead of the aerial photo.

On Tue, Apr 18, 2017 at 8:53 PM, yjacolin <[hidden email]> wrote:
Hello,

You can adapt the style of the raster  (layer properties, style tab and play with the min-max values and other settings)

As Paolo said, the cell content have a value and you can adapt the color for each cells.

Y.



Envoyé depuis mon appareil Samsung


-------- Message d'origine --------
De : Paolo Cavallini <[hidden email]>
Date : 18/04/2017 17:26 (GMT+01:00)
À : [hidden email]
Objet : Re: [Qgis-community-team] QGIS Loads Black Screen For PostGIS Out-Db Raster Data

Il 18/04/2017 17:24, Osahon Oduware ha scritto:
> Hi All,
>
> I have an out-db raster on PostGIS which I tried to load in QGIS (v
> 2.14.12-Essen) utilizing the DB Manager to establish a connection. I
> could view the raster table, but when I try to "Add to canvas" it
> displays a black (blank) image instead of the raster image.
>
> I would be glad if someone could help me to resolve this.

Hi Osahon,
have you checked the values of the cells?
All the best.
--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
https://www.google.com/trends/explore?date=all&geo=IT&q=qgis,arcgis
_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team

_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team


_______________________________________________
Qgis-community-team mailing list for organizing community resources such as documentation, translation etc..
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-community-team
Loading...