Qgis Server - zoom máximo 1:2257

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Qgis Server - zoom máximo 1:2257

Pedro
Continuo a encontrar problemas :)

No meu projeto que publico pelo Qgis Server não consigo fazer zooms
superiores a 1:2257 (independente do ter ou não ligado um mapa base, google,
osm...).
O projeto base no Qgis desktop está ok e consigo ir para qq escala.

Do que li, os parâmetros de escala estão no GlobalOptions.js
(no meu caso está localizado em:
C:\OSGeo4W\apache\htdocs\qwc\site\js\GlobalOptions.js )




Descomentei  o maxScale e minScale e também aumentei o ZOOM_LEVELS, gravei,
reinicei o apache e nada se alterou.

Penso que tenho a versão 1.3 do qgis server
<http://osgeo-org.1560.x6.nabble.com/file/t367412/6.png>  

Alguém tem ideia para onde devo olhar?


obrigado,
Pedro Ferro



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-pt-f5128248.html
_______________________________________________
QGIS-pt mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-pt
Reply | Threaded
Open this post in threaded view
|

Re: Qgis Server - zoom máximo 1:2257

Giovanni Manghi
2018-01-17 17:03 GMT+00:00 Pedro <[hidden email]>:

>
> Continuo a encontrar problemas :)
>
> No meu projeto que publico pelo Qgis Server não consigo fazer zooms
> superiores a 1:2257 (independente do ter ou não ligado um mapa base, google,
> osm...).
> O projeto base no Qgis desktop está ok e consigo ir para qq escala.
>
> Do que li, os parâmetros de escala estão no GlobalOptions.js
> (no meu caso está localizado em:
> C:\OSGeo4W\apache\htdocs\qwc\site\js\GlobalOptions.js )
>
>
>
>
> Descomentei  o maxScale e minScale e também aumentei o ZOOM_LEVELS, gravei,
> reinicei o apache e nada se alterou.
>
> Penso que tenho a versão 1.3 do qgis server
> <http://osgeo-org.1560.x6.nabble.com/file/t367412/6.png>
>
> Alguém tem ideia para onde devo olhar?


eu desconfio que seja um problema de QWC e não de QGIS  Server: para
testar carrega no QGIS Desktop como WMS uma das camadas publicadas com
QGIS Server.

Nota: 1:2257 é a penultima escala disponivel quando se usa googlemaps/bing/etc

https://gis.stackexchange.com/a/7443

mas para algumas camadas (i.e. google streets) é a ultima.

O teu QGIS server não é 1.3, o que ves no GetCapabilities é a versão
do protocolo WMS suportado.
Em geral tenta usar a mesm versão de QGIS Desktop (que usaste para
gravar os projectos) e Server. Se usas uma versão de QGIS Server que
não seja 2.14 ou 2.18 actualiza, as versões anteriores tem alguna bugs
que foram corrigidos já há muito tempo.

-- G --
_______________________________________________
QGIS-pt mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-pt