[QGIS-Developer] Vertex Tool for current layer don't work

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[QGIS-Developer] Vertex Tool for current layer don't work

Carlos López PSIG
Hi,
The new tool for select vertex in current layer doesn't work for me,
Both tool select all vertex from all layers.

Computer 1
SO: Linux Mint 19 & QGIS: 3.4.1
Select all vertex always, although you choose "Select vertex from current layers"

Computer 2:
SO Win10 & QGIS 3.5.0
Select vertex from current Layer always, although you choose "Select vertex from all layers"

Is this a known bug??

Best regards,


_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Vertex Tool for current layer don't work

3nids
Hi Carlos,

I suspect this is the issue with QVariant and meta enums that affect Qt < 5.6.2, although I don't see clearly in the code where would be the issue.
To confirm, what Qt version do you have on Mint?

Could you do following steps:

1. In console, do: QgsSettings().enumValue( "UI/defaultVertexTool" )
2. Select vertex tool with all layers
3. print in console again
4. Select vertex tool with current layer
5. print in console again

Then can you try also this:
1. QgsSettings().setEnumValue( "UI/defaultVertexTool", "AllLayers" )
2. close QGIS and see which tool is selected by default when you restart
3. QgsSettings().setEnumValue( "UI/defaultVertexTool", "ActiveLayer" )
4. close QGIS and see which tool is selected by default when you restart

Sorry for the inconvenience, but this is hard for me test as I don't have the issue.

Cheers,
Denis

Le mer. 7 nov. 2018 à 07:25, Carlos López PSIG <[hidden email]> a écrit :
Hi,
The new tool for select vertex in current layer doesn't work for me,
Both tool select all vertex from all layers.

Computer 1
SO: Linux Mint 19 & QGIS: 3.4.1
Select all vertex always, although you choose "Select vertex from current layers"

Computer 2:
SO Win10 & QGIS 3.5.0
Select vertex from current Layer always, although you choose "Select vertex from all layers"

Is this a known bug??

Best regards,

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
--

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Vertex Tool for current layer don't work

Andrea Giudiceandrea
3nids wrote
> 1. In console, do: QgsSettings().enumValue( "UI/defaultVertexTool" )

Probably
QgsSettings().value( "UI/defaultVertexTool" )

Isn't it?

Andrea



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Developer-f4099106.html
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Vertex Tool for current layer don't work

3nids
yes, replace all enumValue by value and all setEnumValue by setValue.

Le mer. 7 nov. 2018 à 10:10, andreaerdna <[hidden email]> a écrit :
3nids wrote
> 1. In console, do: QgsSettings().enumValue( "UI/defaultVertexTool" )

Probably
QgsSettings().value( "UI/defaultVertexTool" )

Isn't it?

Andrea



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Developer-f4099106.html
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
--

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

[QGIS-Developer] Browser Panel too slow Issue

Jorge Almerio

Hi devs,

 

After update from Qgis 3.3.x to Qgis 3.4.1, the browser panel became too slow. I had to close it to use QGis.

 

Does someone realized this issue?

 

Sorry if it is not the right place for this,

 

Regards,

 

Jorge Almerio


_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

[QGIS-Developer] RES: Browser Panel too slow Issue

Jorge Almerio
In reply to this post by 3nids

Hi devs,

 

I already opened a ticket

https://issues.qgis.org/issues/20411

 

Thanks

 

De: Jorge Almerio [mailto:[hidden email]]
Enviada em: quarta-feira, 7 de novembro de 2018 17:55
Para: '[hidden email]'; '[hidden email]'
Assunto: Browser Panel too slow Issue

 

Hi devs,

 

After update from Qgis 3.3.x to Qgis 3.4.1, the browser panel became too slow. I had to close it to use QGis.

 

Does someone realized this issue?

 

Sorry if it is not the right place for this,

 

Regards,

 

Jorge Almerio


_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Vertex Tool for current layer don't work

3nids
In reply to this post by 3nids
Hi Carlos,

Any chance to test this?

Cheers,
Denis

Le mer. 7 nov. 2018 à 15:12, Denis Rouzaud <[hidden email]> a écrit :
yes, replace all enumValue by value and all setEnumValue by setValue.

Le mer. 7 nov. 2018 à 10:10, andreaerdna <[hidden email]> a écrit :
3nids wrote
> 1. In console, do: QgsSettings().enumValue( "UI/defaultVertexTool" )

Probably
QgsSettings().value( "UI/defaultVertexTool" )

Isn't it?

Andrea



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Developer-f4099106.html
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
--
--

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Vertex Tool for current layer don't work

Carlos López PSIG
Hi Denis,
Sorry for my delay.

I have this QT version =  Qt 5.9.5

I've updated my QGIS to new package and now in my Linux Mint work fine.
I'll continue testing tomorrow using some projects and using another computer or SO.. 
Thanks for your time.

Best regards,



El mar., 13 nov. 2018 a las 7:46, Denis Rouzaud (<[hidden email]>) escribió:
Hi Carlos,

Any chance to test this?

Cheers,
Denis

Le mer. 7 nov. 2018 à 15:12, Denis Rouzaud <[hidden email]> a écrit :
yes, replace all enumValue by value and all setEnumValue by setValue.

Le mer. 7 nov. 2018 à 10:10, andreaerdna <[hidden email]> a écrit :
3nids wrote
> 1. In console, do: QgsSettings().enumValue( "UI/defaultVertexTool" )

Probably
QgsSettings().value( "UI/defaultVertexTool" )

Isn't it?

Andrea



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-Developer-f4099106.html
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
--
--
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer