[QGIS-Developer] QGIS 3.10.2 start issue

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[QGIS-Developer] QGIS 3.10.2 start issue

Martin Steiger

Hello,

 

I hope I write to the correct address with my request.

 

In the "Kantonsverwaltung Zug" we use QGIS since version 2.16 in the department of geoinformation. We always used the following command to start QGIS:

 

"C:\Program Files\QGIS_3_8_ZANZIBAR\bin\nircmd.exe" exec hide C:\Program Files\QGIS_3_8_ZANZIBAR\bin\qgis.bat

(Yes, we install it in a custom named folder)

 

It always worked out fine and QGIS started without any issues. However, in version 3.10.2 this does not work out, because the file qgis.bat does not exist. I found the file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin.exe" and tried to start it.

Unfortunately I get an error message (see attachment). If I start the file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin-g7.exe" I get the same behaviour. I think it’s a little bit odd that the mentioned file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin.env" doesn’t even exist in the file system…

 

Can you help me out with this issue? Or is there a way you would recommend to correctly start QGIS?

 

We use Windows 10 Build 1809 with the newest windows updates.

 

Best Regards

Martin Steiger

 

 

Finanzdirektion Kanton Zug

Amt für Informatik und Organisation (AIO) des Kantons Zug

Martin Steiger

Computer scientist in apprenticeship

Aabachstrasse 1

6300 Zug

Switzerland

T +41 41 728 51 29

[hidden email]

 


_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer

QGIS_3.10.2_error_message.png (15K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 3.10.2 start issue

Bo Victor Thomsen

Hi Martin -

I don't know how you have installed QGIS. Probably a simple xcopy. However, the error message states:

"Look in path_to_directory_for_QGIS_binary\qgis-bin.env for correct paths"

This file - qgis-bin.env - has to be present in the same directory as qgis-bin.exe - contains a lot of setup information previously contained in qgis.bat.

And it has to be configured corecctly. It's a text file, so you can edit the file with a simple text editor like notepad.

A small sample from my own .env file (where qgis-bin.exe is located in c:\ocgeo4win64\bin:

    PATH=C:\OSGEO4~1\apps\qgis\bin;C:\OSGEO4~1\apps\Python37;C:\OSGEO4~1\apps\Python37\Scripts ... blah blah

C:\OSGEO4~1\ is the "DOS old-style 8.3" name for  C:\OSGeo4W64\

All these path names in the .env file has to be configured correctly regarding your home-path for QGIS

--
Med venlig hilsen / Kind regards

Bo Victor Thomsen
Civ.Ing

AestasGIS Denmark

Den 14-02-2020 kl. 14:03 skrev Martin Steiger:

Hello,

 

I hope I write to the correct address with my request.

 

In the "Kantonsverwaltung Zug" we use QGIS since version 2.16 in the department of geoinformation. We always used the following command to start QGIS:

 

"C:\Program Files\QGIS_3_8_ZANZIBAR\bin\nircmd.exe" exec hide C:\Program Files\QGIS_3_8_ZANZIBAR\bin\qgis.bat

(Yes, we install it in a custom named folder)

 

It always worked out fine and QGIS started without any issues. However, in version 3.10.2 this does not work out, because the file qgis.bat does not exist. I found the file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin.exe" and tried to start it.

Unfortunately I get an error message (see attachment). If I start the file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin-g7.exe" I get the same behaviour. I think it’s a little bit odd that the mentioned file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin.env" doesn’t even exist in the file system…

 

Can you help me out with this issue? Or is there a way you would recommend to correctly start QGIS?

 

We use Windows 10 Build 1809 with the newest windows updates.

 

Best Regards

Martin Steiger

 

 

Finanzdirektion Kanton Zug

Amt für Informatik und Organisation (AIO) des Kantons Zug

Martin Steiger

Computer scientist in apprenticeship

Aabachstrasse 1

6300 Zug

Switzerland

T +41 41 728 51 29

[hidden email]

 


_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer

  


_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 3.10.2 start issue

Thomas_Baumann
In reply to this post by Martin Steiger

Hi Martin,

did you use the standalone installer or the OSGEO4W-Installer?

You can have a look if in your C:\Program Files\QGIS_3_10_2_Coruna\bin folder if there exists a qgis.bat.tmpl file as template for the qgis.bat.

If so you can copy the file and rename it to qgis.bat. If not you can create a qgis.bat with a content similar to this:

Afterwards you can open your cmd commandline("Eingabeaufforderung"), navigate to C:\Program Files\QGIS_3_10_2_Coruna\bin and call "qgis.bat --postinstall" to create the env file.

regards,
Thomas


Am Fr., 14. Feb. 2020 um 14:03 Uhr schrieb Martin Steiger <[hidden email]>:

Hello,

 

I hope I write to the correct address with my request.

 

In the "Kantonsverwaltung Zug" we use QGIS since version 2.16 in the department of geoinformation. We always used the following command to start QGIS:

 

"C:\Program Files\QGIS_3_8_ZANZIBAR\bin\nircmd.exe" exec hide C:\Program Files\QGIS_3_8_ZANZIBAR\bin\qgis.bat

(Yes, we install it in a custom named folder)

 

It always worked out fine and QGIS started without any issues. However, in version 3.10.2 this does not work out, because the file qgis.bat does not exist. I found the file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin.exe" and tried to start it.

Unfortunately I get an error message (see attachment). If I start the file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin-g7.exe" I get the same behaviour. I think it’s a little bit odd that the mentioned file "C:\Program Files\QGIS_3_10_2_Coruna\bin\qgis-bin.env" doesn’t even exist in the file system…

 

Can you help me out with this issue? Or is there a way you would recommend to correctly start QGIS?

 

We use Windows 10 Build 1809 with the newest windows updates.

 

Best Regards

Martin Steiger

 

 

Finanzdirektion Kanton Zug

Amt für Informatik und Organisation (AIO) des Kantons Zug

Martin Steiger

Computer scientist in apprenticeship

Aabachstrasse 1

6300 Zug

Switzerland

T +41 41 728 51 29

[hidden email]

 

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer