[QGIS-Developer] Lat Lon Tools - Releasing for QGIS 2 and QGIS 3

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[QGIS-Developer] Lat Lon Tools - Releasing for QGIS 2 and QGIS 3

C Hamilton
I was able to successfully convert Lat Lon Tools to work with QGIS 3. The code for QGIS 2 and 3 are incompatible so is it best to keep two parallel developments going and to keep the release number for the QGIS 2 version at the 0.8.x and start the release number for QGIS 3 at 1.0.0 and continue to release both to the same plugin repo? What is the best practice?

Until QGIS 3 is officially released I probably won't release the QGIS 3 plugin as often as the QGIS 2 plugin.

Thanks!!!

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: [QGIS-Developer] Lat Lon Tools - Releasing for QGIS 2 and QGIS 3

Tom Chadwin
I'll probably do exactly that. v3.x for QGIS3, continue with v2.x for QGIS2.