[QGIS-Developer] Installing qgis custom widgets in designer from development build

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[QGIS-Developer] Installing qgis custom widgets in designer from development build

Chris Crook
Title pretty much is the question - I'm building QGIS development build on ubuntu as per instructions in INSTALL.

I think the thing I need to register with designer is libqgis-customwidgets.so.   But that doesn't seem to be built as part of the CMake build (can't find the file anywhere), and the only reference to it I can find is in the debian directory as a package.  I'm not familiar enough with packaging to figure out how it gets built or what source files are used :-(

Any help would be great - I am building on a virtual machine with source code in a mounted directory.

Thanks for any guidance
Chris

________________________________

This message contains information, which may be in confidence and may be subject to legal privilege. If you are not the intended recipient, you must not peruse, use, disseminate, distribute or copy this message. If you have received this message in error, please notify us immediately (Phone 0800 665 463 or [hidden email]) and destroy the original message. LINZ accepts no responsibility for changes to this email, or for any attachments, after its transmission from LINZ. Thank You.
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Installing qgis custom widgets in designer from development build

Matthias Kuhn 🌍
Hi Chris,

First thing is to run CMake with -DWITH_CUSTOM_WIDGETS

Then the resulting library needs to be copied into the folder where Qt
loads its plugins from.

Matthias

On 9/9/19 9:43 AM, Chris Crook wrote:

> Title pretty much is the question - I'm building QGIS development build on ubuntu as per instructions in INSTALL.
>
> I think the thing I need to register with designer is libqgis-customwidgets.so.   But that doesn't seem to be built as part of the CMake build (can't find the file anywhere), and the only reference to it I can find is in the debian directory as a package.  I'm not familiar enough with packaging to figure out how it gets built or what source files are used :-(
>
> Any help would be great - I am building on a virtual machine with source code in a mounted directory.
>
> Thanks for any guidance
> Chris
>
> ________________________________
>
> This message contains information, which may be in confidence and may be subject to legal privilege. If you are not the intended recipient, you must not peruse, use, disseminate, distribute or copy this message. If you have received this message in error, please notify us immediately (Phone 0800 665 463 or [hidden email]) and destroy the original message. LINZ accepts no responsibility for changes to this email, or for any attachments, after its transmission from LINZ. Thank You.
> _______________________________________________
> QGIS-Developer mailing list
> [hidden email]
> List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
> Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
>
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Installing qgis custom widgets in designer from development build

Chris Crook
Hi all

I'm still having problems installing the custom widgets into designer on ubuntu 18.04.  I've run make  and make install, and copied the custom widgets .so with

sudo cp libqgis_customwidgets.so.3.9.0 /usr/lib/x86_64-linux-gnu/qt5/plugins/designer/libqgis_customwidgets.so

It is being found, in that when designer starts it now dies :-(  I think the problem is that it is not finding qgis.db, though there are other errors along the way.  Output when starting up is listed below.  QGIS itself starts up normally.

Still desperate for ideas!!!

Thanks
Chris

QMetaProperty::read: Unable to handle unregistered datatype 'DocumentViewerContent' for property 'QgsExternalResourceWidget::documentViewerContent'
QMetaProperty::read: Unable to handle unregistered datatype 'QgsFileWidget::RelativeStorage' for property 'QgsExternalResourceWidget::relativeStorage'
QMetaProperty::read: Unable to handle unregistered datatype 'QgsFieldProxyModel::Filters' for property 'QgsFieldComboBox::filters'
QMetaProperty::read: Unable to handle unregistered datatype 'QgsFieldProxyModel::Filters' for property 'QgsFieldExpressionWidget::filters'
QMetaProperty::read: Unable to handle unregistered datatype 'StorageMode' for property 'QgsFileWidget::storageMode'
QMetaProperty::read: Unable to handle unregistered datatype 'RelativeStorage' for property 'QgsFileWidget::relativeStorage'
QMetaProperty::read: Unable to handle unregistered datatype 'QgsTextFormat' for property 'QgsFontButton::textFormat'
QMetaProperty::read: Unable to handle unregistered datatype 'QgsMapLayerProxyModel::Filters' for property 'QgsMapLayerComboBox::filters'
src/gui/qgsproviderguiregistry.cpp:94 : (loadDynamicProviders) [57ms] Checking . for GUI provider plugins
src/gui/qgsproviderguiregistry.cpp:98 : (loadDynamicProviders) [0ms] No dynamic QGIS GUI provider plugins found in:
.

src/gui/qgsgui.cpp:123 : (enableAutoGeometryRestore) [1ms] WARNING: No object name set. Best for it to be set objectName when using QgsGui::enableAutoGeometryRestore
src/core/qgscoordinatereferencesystem.cpp:1221 : (getRecord) [6ms] user qgis.db not found
src/core/qgscoordinatereferencesystem.cpp:1221 : (getRecord) [6ms] user qgis.db not found
ASSERT: "sc" in file /qgis/src/gui/attributetable/qgsdualview.cpp, line 76
Aborted (core dumped)
sudo cp libqgis_customwidgets.so.3.9.0 /usr/lib/x86_64-linux-gnu/qt5/plugins/designer/libqgis_customwidgets.so

________________________________________
From: QGIS-Developer [[hidden email]] on behalf of Matthias Kuhn [[hidden email]]
Sent: Monday, 9 September 2019 10:31 p.m.
To: [hidden email]
Subject: Re: [QGIS-Developer] Installing qgis custom widgets in designer from development build

Hi Chris,

First thing is to run CMake with -DWITH_CUSTOM_WIDGETS

Then the resulting library needs to be copied into the folder where Qt
loads its plugins from.

Matthias

On 9/9/19 9:43 AM, Chris Crook wrote:

> Title pretty much is the question - I'm building QGIS development build on ubuntu as per instructions in INSTALL.
>
> I think the thing I need to register with designer is libqgis-customwidgets.so.   But that doesn't seem to be built as part of the CMake build (can't find the file anywhere), and the only reference to it I can find is in the debian directory as a package.  I'm not familiar enough with packaging to figure out how it gets built or what source files are used :-(
>
> Any help would be great - I am building on a virtual machine with source code in a mounted directory.
>
> Thanks for any guidance
> Chris
>
> ________________________________
>
> This message contains information, which may be in confidence and may be subject to legal privilege. If you are not the intended recipient, you must not peruse, use, disseminate, distribute or copy this message. If you have received this message in error, please notify us immediately (Phone 0800 665 463 or [hidden email]) and destroy the original message. LINZ accepts no responsibility for changes to this email, or for any attachments, after its transmission from LINZ. Thank You.
> _______________________________________________
> QGIS-Developer mailing list
> [hidden email]
> List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
> Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
>
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Installing qgis custom widgets in designer from development build

Jürgen E. Fischer
Hi Chris,

On Tue, 10. Sep 2019 at 21:33:44 +0000, Chris Crook wrote:
> I'm still having problems installing the custom widgets into designer on ubuntu 18.04.  I've run make  and make install, and copied the custom widgets .so with
 
> sudo cp libqgis_customwidgets.so.3.9.0 /usr/lib/x86_64-linux-gnu/qt5/plugins/designer/libqgis_customwidgets.so
 
> It is being found, in that when designer starts it now dies :-(  I think the
> problem is that it is not finding qgis.db, though there are other errors
> along the way.  Output when starting up is listed below.  QGIS itself starts
> up normally.

See fixed https://github.com/qgis/QGIS/issues/31657


Jürgen
 

--
Jürgen E. Fischer           norBIT GmbH             Tel. +49-4931-918175-31
Dipl.-Inf. (FH)             Rheinstraße 13          Fax. +49-4931-918175-50
Software Engineer           D-26506 Norden            https://www.norbit.de
QGIS release manager (PSC)  Germany                    IRC: jef on FreeNode

norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
Rheinstrasse 13, 26506 Norden
GF: Juergen Fischer, Nils Kutscher HR: Amtsgericht Aurich HRB 100827
Datenschutzerklaerung: https://www.norbit.de/83/

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer

signature.asc (844 bytes) Download Attachment