[QGIS-Developer] Creation error for Spatialite layer

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[QGIS-Developer] Creation error for Spatialite layer

Bo Victor Thomsen

Hi list -

I've stumbled into a severe - possible regression - error trying to crate a Spatialite layer with an  autoincrementing id field.

Steps to recreate error:

  1. Create a spatialite layer in QGIS
  2. Check the "Create a autoincrementing primary key" checkbox  (Which correctly create a autoincrementing pkid)
  3. create a record by digitizing
  4. Try to save the record

The following error message appears:

The SQL statement is obviously wrong, missing the name of pkid field

I get the error in both QGIS 3.10.3 - 64 bit and 3.12.0 - 64 bit on Windows 8.1

I remember doing this working correctly in QGIS ver. 2.x.


Can anyone confirm this error before i report it ?

-- 
Med venlig hilsen / Kind regards

Bo Victor Thomsen

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Creation error for Spatialite layer

Alessandro Pasotti-2

Hi,

already reported and fixed (and backported):





On Mon, Mar 9, 2020 at 11:10 AM Bo Victor Thomsen <[hidden email]> wrote:

Hi list -

I've stumbled into a severe - possible regression - error trying to crate a Spatialite layer with an  autoincrementing id field.

Steps to recreate error:

  1. Create a spatialite layer in QGIS
  2. Check the "Create a autoincrementing primary key" checkbox  (Which correctly create a autoincrementing pkid)
  3. create a record by digitizing
  4. Try to save the record

The following error message appears:

The SQL statement is obviously wrong, missing the name of pkid field

I get the error in both QGIS 3.10.3 - 64 bit and 3.12.0 - 64 bit on Windows 8.1

I remember doing this working correctly in QGIS ver. 2.x.


Can anyone confirm this error before i report it ?

-- 
Med venlig hilsen / Kind regards

Bo Victor Thomsen
_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer


--
Alessandro Pasotti
w3:   www.itopen.it

_______________________________________________
QGIS-Developer mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer