QGIS 3 - Postgres Authentication Issue

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

QGIS 3 - Postgres Authentication Issue

Ungerboeck, Erhard

Hello,

 

we are using QGIS  with a Postgres database where each different user (in total about 20 ) each have their own login credentials. Since we changed from QGIS 2.18 to QGIS 3 when opening a project QGIS always asks for the login data twice. I didn’t change anything in the database / server. This is rather annoying, any ideas how I can change that or can find further information / help?

 

Best regards,

Erhard

 

 


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 3 - Postgres Authentication Issue

ginetto
can you describe better the use case? I suppose you can't share project and db connection, so you need to give us steps to replicate the issue starting from a clean qgis profile.

remember that side effects can be introduced by plugins that are not using correctly the qgis authentication infrastructure (if you use it). How do you use the authentication? saving pwd int he project or in the qgis auth infrastructure that need use of a master password?

Luigi Pirelli

**************************************************************************************************
* LinkedIn: https://www.linkedin.com/in/luigipirelli
* Stackexchange: http://gis.stackexchange.com/users/19667/luigi-pirelli
* GitHub: https://github.com/luipir
* Mastering QGIS 2nd Edition:
* https://www.packtpub.com/big-data-and-business-intelligence/mastering-qgis-second-edition
* Hire me: http://goo.gl/BYRQKg
**************************************************************************************************


On Thu, 10 Jan 2019 at 12:01, Ungerboeck, Erhard <[hidden email]> wrote:

Hello,

 

we are using QGIS  with a Postgres database where each different user (in total about 20 ) each have their own login credentials. Since we changed from QGIS 2.18 to QGIS 3 when opening a project QGIS always asks for the login data twice. I didn’t change anything in the database / server. This is rather annoying, any ideas how I can change that or can find further information / help?

 

Best regards,

Erhard

 

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user